17356 matches found
CLEANSTART-2026-YS28886 Security fixes in postgresql 15.2-r0
Package postgresql version 15.2-r0 fixes 1 vulnerabilities: CVE-2022-41862...
PT-2026-66614
Name of the Vulnerable Software and Affected Versions ansible-collection-redhat-leapp affected versions not specified Description A flaw exists when a remediation task is executed with elevated privileges and the leapp old postgresql data option is selected. This results in the creation of a...
CVE-2026-68563: Incorrect Permission Assignment for Critical Resource
A flaw was found in ansible-collection-redhat-leapp. When a remediation task is executed with elevated privileges and the leappoldpostgresqldata option is selected, a PostgreSQL data backup archive is created with insecure permissions. This allows a local non-root user on the managed node to read...
Linux Distros Unpatched Vulnerability : CVE-2026-68563
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - A flaw was found in ansible-collection-redhat-leapp. When a remediation task is executed with elevated privileges and the leappoldpostgresqldata option is...
CVE-2026-62845: Improper Neutralization of Special Elements used in an SQL Command
Kamaji is the Hosted Control Plane Manager for Kubernetes. Prior to 26.7.4-edge, the PostgreSQL and MySQL datastore drivers build DDL statements by interpolating the user-supplied DataStoreUsername/DataStoreSchema directly into SQL via fmt.Sprintf, without escaping identifiers. These fields have ...
postgresql security update
An update is available for postgresql. This update affects Rocky Linux 9. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list PostgreSQL is an advanced object-relational database management system DBM...
RLSA-2026:27741 Important: postgresql security update
PostgreSQL is an advanced object-relational database management system DBMS. Security Fixes: postgresql: PostgreSQL: Operating system account hijack via symlink following in pgbasebackup and pgrewind CVE-2026-6475 postgresql: PostgreSQL libpq: Buffer overflow allows server superuser to overwrite...
MiracleLinux 9 : postgresql:15 (AXSA:2026-1374:01)
The remote MiracleLinux 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the AXSA:2026-1374:01 advisory. postgresql: PostgreSQL: Operating system account hijack via symlink following in pgbasebackup and pgrewind CVE-2026-6475 postgresql: PostgreSQL libp...
CVE-2026-50737
When applying replicated changes for a row that is missing one or more columns, pglogical evaluates the affected table's default expressions on the subscriber. Because the apply worker runs at a privilege level equivalent to a PostgreSQL superuser in default installations, any function invoked by...
php: ext-pgsql: PHP: SQL injection via improper backslash escaping
A flaw was found in PHP. Improper escaping of backslashes in attacker-provided parameters can lead to a SQL injection vulnerability. A remote attacker could exploit this flaw by crafting malicious input, potentially gaining unauthorized access to sensitive information, manipulating data, or causi...
EUVD-2026-49938
A use-after-free condition exists in pglogical's worker signaling code, where a worker structure can be dereferenced after the underlying slot has been freed or recycled during normal worker lifecycle events. The condition is reachable during normal replication operation, including by a...
K000162479: PostgreSQL vulnerability CVE-2026-6474
Security Advisory Description Externally-controlled format string in PostgreSQL timeofday function allows an attacker to retrieve portions of server memory, via crafted timezone zones. Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected. CVE-2026-6474 Impact This...
Important: Red Hat Security Advisory: libpq security update
An update for libpq is now available for Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support and Red Hat Enterprise Linux 8.6 Extended Update Support Long-Life Add-On. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability...
postgresql: PostgreSQL libpq: Buffer overflow allows server superuser to overwrite client stack memory
A flaw was found in PostgreSQL libpq. A server superuser can exploit a buffer overflow vulnerability in the PQfn function, which is used by client functions such as loexport, loread, lolseek64, and lotell64. This allows the superuser to send an arbitrarily large response, overwriting the client's...
K000162478: PostgreSQL vulnerability CVE-2026-6637
Security Advisory Description Stack buffer overflow in PostgreSQL module "refint" allows an unprivileged database user to execute arbitrary code as the operating system user running the database. A distinct attack is possible if the application declares a user-controlled column as a "refint"...
PostgreSQL History - Exposure Detection
Exposed PostgreSQL history files .psqlhistory were detected. These files contain a record of executed SQL commands and may disclose sensitive information like passwords, database schemas, and query logic. !/usr/bin/env python3 -- coding: utf-8 -- """Exposed PostgreSQL history files .""" import re...
PostgreSQL Credentials - Exposure Detection
Detects the exposure of PostgreSQL credentials and history files .pgpass via HTTP. These files may contain plaintext database usernames and passwords, and their leakage could allow unauthorized access to sensitive databases or internal infrastructure. !/usr/bin/env python3 -- coding: utf-8 --...
temBoard Panel - Detect
temBoard was detected — a powerful management tool for PostgreSQL. !/usr/bin/env python3 -- coding: utf-8 -- """temBoard was detected — a powerful management tool for PostgreSQL.""" from kittysploit import from lib.protocols.http.httpclient import Httpclient class ModuleScanner, Httpclient: info ...
PostgreSQL Cluster - Configuration Detection
PostgreSQL Cluster Configuration Page was detected and appeared to be accessible without authentication. !/usr/bin/env python3 -- coding: utf-8 -- """PostgreSQL Cluster Configuration Page was detected and appeared to be accessible without authentication.""" from kittysploit import from...
Rosario Student Information System Unauthenticated SQL Injection Detection
An unauthenticated SQL injection vulnerability in Rosario Student Information System aka rosariosis 8.1 and below allow remote attackers to execute PostgreSQL statements e.g., SELECT, INSERT, UPDATE, and DELETE through /Side.php via the syear parameter. !/usr/bin/env python3 -- coding: utf-8 --...