8 matches found
PoC_CVE-2020-9484
This repository contains a proof of concept exploit for CVE-2020-9484, along with an example web server that is vulnerable to this exploit. Prerequisites for this vulnerability to be exploitable Affected tomcat versions are: Apache Tomcat 10.x 10.0.0-M5 Apache Tomcat 9.x 9.0.35 Apache Tomcat 8.x...
CVE-2025-24813
CVE-2025-24813 - Apache Tomcat Remote Code Execution Exploit This is a proof-of-concept PoC exploit for CVE-2025-24813 , a vulnerability in Apache Tomcat 9.0.80–9.0.83, 10.1.0–10.1.17 that allows remote code execution RCE via session deserialization. The exploit abuses partial PUT requests and th...
CVE-2025-24813
CVE-2025-24813 — Apache Tomcat Partial PUT Deserialization RCE Severity: Critical CVSS 9.8 Auth required: None Affected: Apache Tomcat 9.0.0.M1 – 9.0.98 / 10.1.0-M1 – 10.1.34 / 11.0.0-M1 – 11.0.2 Patched in: Tomcat 9.0.99 / 10.1.35 / 11.0.3 How It Works Apache Tomcat supports partial PUT chunked...
CVE-2025-24813
CVE-2025-24813 — Apache Tomcat 部分 PUT デシリアライゼーション RCE 深刻度: クリティカル CVSS 9.8 認証要否: 不要 影響を受けるバージョン: Apache Tomcat 9.0.0.M1 – 9.0.98 / 10.1.0-M1 – 10.1.34 / 11.0.0-M1 – 11.0.2 修正済み: Tomcat 9.0.99 / 10.1.35 / 11.0.3 仕組み Apache Tomcat は 部分 PUT Content-Range によるチャンクアップロード をサポートしています。 部分 PUT が到着すると、Tomca...
Exploit for Deserialization of Untrusted Data in Apache Tomcat
CVE-2025-24813 — Apache Tomcat Partial PUT Deserialization RCE...
CVE-2020-9484 — PersistentManager Java deserialization vulnerability
When using Apache Tomcat versions 10.0.0-M1 to 10.0.0-M4, 9.0.0.M1 to 9.0.34, 8.5.0 to 8.5.54 and 7.0.0 to 7.0.103 if a an attacker is able to control the contents and name of a file on the server; and b the server is configured to use the PersistenceManager with a FileStore; and c the...
MySQL Enterprise Monitor 3.2.x < 3.2.2.1075 Multiple Vulnerabilities (January 2017 CPU)
According to its self-reported version, the MySQL Enterprise Monitor application running on the remote host is 3.2.x prior to 3.2.2.1075. It is, therefore, affected by multiple vulnerabilities : - An information disclosure vulnerability exists in the bundled version of Apache Tomcat in the Manage...
PT-2016-1316
Name of the Vulnerable Software and Affected Versions Apache Tomcat versions 6.x before 6.0.45 Apache Tomcat versions 7.x before 7.0.68 Apache Tomcat versions 8.x before 8.0.31 Apache Tomcat versions 9.x before 9.0.0.M2 Description The issue is related to the session-persistence implementation in...