12156 matches found
nodejs-normalize-url: ReDoS for data URLs
A flaw was found in normalize-url. Node.js has a ReDoS regular expression denial of service issue because it has exponential performance for data...
FindFunc - Advanced Filtering/Finding of Functions in IDA Pro
FindFunc is an IDA Pro plugin to find code functions that contain a certain assembly or byte pattern, reference a certain name or string, or conform to various other constraints. This is not a competitor to tools like Diaphora or BinNavi, but it is ideal to find a known function in a new binary f...
[SECURITY] Fedora 36 Update: firefox-100.0.2-1.fc36
Mozilla Firefox is an open-source web browser, designed for standards compliance, performance and portability...
SUSE: Security Advisory (SUSE-SU-2022:1847-1)
The remote host is missing an update for the SPDX-FileCopyrightText: 2022 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
EulerOS 2.0 SP3 : bind (EulerOS-SA-2022-1705)
According to the versions of the bind packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : - In BIND 9.3.0 - 9.11.35, 9.12.0 - 9.16.21, and versions 9.9.3-S1 - 9.11.35-S1 and 9.16.8-S1 - 9.16.21-S1 of BIND Supported Preview Edition, as wel...
GHSA-GJ94-V4P9-W672 Denial-of-service vulnerability processing large chat messages containing many newlines
Impact PocketMine-MP caps maximum chat message length at 512 Unicode characters, or about 2048 bytes. No more than 2 chat messages may be sent per tick. However, due to legacy reasons, incoming chat message blobs are split by \n, and each part is treated as a separate message, the length of each...
Denial-of-service vulnerability processing large chat messages containing many newlines
Impact PocketMine-MP caps maximum chat message length at 512 Unicode characters, or about 2048 bytes. No more than 2 chat messages may be sent per tick. However, due to legacy reasons, incoming chat message blobs are split by \n, and each part is treated as a separate message, the length of each...
SUSE: Security Advisory (SUSE-SU-2022:1832-1)
The remote host is missing an update for the SPDX-FileCopyrightText: 2022 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
PT-2022-28247
Name of the Vulnerable Software and Affected Versions PocketMine-MP versions prior to the version containing the fix in https://github.com/pmmp/PocketMine-MP/commit/df33e179e5d3ff13b56a2d7060bf592b0f797258 Description The issue arises from how PocketMine-MP handles incoming chat message blobs. Du...
Automotive Shop Management System Cross-Site Scripting Vulnerability (CNVD-2022-77486)
Automotive Shop Management System is a system with customer management, vehicle sales, parts sales, repair and maintenance, agency services, auto credit, auto leasing, used car trading, and performance management functions. xss vulnerability exists in Automotive Shop Management System v1.0. An...
com.github.mjdetullio.jenkins.plugins:multi-branch-project-plugin (>=0.5, <=0.5.1), com.piketec.jenkins.plugins:piketec-tpt (>=6.4, <=8.8) +36 more potentially affected by CVE-2019-10405 via org.jenkins-ci.main:jenkins-core (1.625.1)
org.jenkins-ci.main:jenkins-core MAVEN version 1.625.1 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - com.github.mjdetullio.jenkins.plugins:multi-branch-project-plugin =0.5, =6.4, =2.4.3, =2.4.3,...
com.github.mjdetullio.jenkins.plugins:multi-branch-project-plugin (>=0.5, <=0.5.1), com.piketec.jenkins.plugins:piketec-tpt (>=6.4, <=8.8) +36 more potentially affected by CVE-2019-10403 via org.jenkins-ci.main:jenkins-core (1.625.1)
org.jenkins-ci.main:jenkins-core MAVEN version 1.625.1 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - com.github.mjdetullio.jenkins.plugins:multi-branch-project-plugin =0.5, =6.4, =2.4.3, =2.4.3,...
XXE vulnerability in Jenkins Performance Plugin
Jenkins Performance Plugin 3.20 and earlier does not configure its XML parser to prevent XML external entity XXE attacks. This allows attackers able to control workspace contents to have Jenkins parse a crafted XML report file that uses external entities for extraction of secrets from the Jenkins...
org.jenkins-ci.plugins:influxdb (>=1.12.1, <=1.12.3) potentially affected by CVE-2021-21701 via org.jenkins-ci.plugins:performance (3.0)
org.jenkins-ci.plugins:performance MAVEN version 3.0 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:performance and may be impacted: - org.jenkins-ci.plugins:influxdb =1.12.1, =1.12.3 Source cves: CVE-2021-21701 Source advisory:...
org.jenkins-ci.plugins:influxdb (>=1.9, <=1.12) potentially affected by CVE-2021-21701 via org.jenkins-ci.plugins:performance (1.15)
org.jenkins-ci.plugins:performance MAVEN version 1.15 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:performance and may be impacted: - org.jenkins-ci.plugins:influxdb =1.9, =1.12 Source cves: CVE-2021-21701 Source advisory:...
org.jenkins-ci.plugins:influxdb (>=1.12.1, <=1.12.3) potentially affected by CVE-2021-21701 via org.jenkins-ci.plugins:performance (3.0)
org.jenkins-ci.plugins:performance MAVEN version 3.0 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:performance and may be impacted: - org.jenkins-ci.plugins:influxdb =1.12.1, =1.12.3 Source cves: CVE-2021-21701 Source advisory:...
GHSA-HR8P-76Q8-FXWQ XXE vulnerability in Jenkins Performance Plugin
Jenkins Performance Plugin 3.20 and earlier does not configure its XML parser to prevent XML external entity XXE attacks. This allows attackers able to control workspace contents to have Jenkins parse a crafted XML report file that uses external entities for extraction of secrets from the Jenkins...
com.github.mjdetullio.jenkins.plugins:multi-branch-project-plugin (>=0.5, <=0.5.1), com.piketec.jenkins.plugins:piketec-tpt (>=6.4, <=8.8) +36 more potentially affected by CVE-2021-21686 via org.jenkins-ci.main:jenkins-core (1.625.1)
org.jenkins-ci.main:jenkins-core MAVEN version 1.625.1 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - com.github.mjdetullio.jenkins.plugins:multi-branch-project-plugin =0.5, =6.4, =2.4.3, =2.4.3,...
com.blazemeter.plugins:blazemeterjenkinsplugin (>=2.0, <=2.6), jenkins.plugins.elanceodesk:workplace-notifier (>=1.14, <=1.16) +7 more potentially affected by CVE-2021-21685 via org.jenkins-ci.main:jenkins-core (1.576)
org.jenkins-ci.main:jenkins-core MAVEN version 1.576 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - com.blazemeter.plugins:blazemeterjenkinsplugin =2.0, =1.14, =1.14, =1.5, =1.6 Source cves:...
com.blazemeter.plugins:blazemeterjenkinsplugin (>=2.0, <=2.6), jenkins.plugins.elanceodesk:workplace-notifier (>=1.14, <=1.16) +7 more potentially affected by CVE-2021-21690 via org.jenkins-ci.main:jenkins-core (1.576)
org.jenkins-ci.main:jenkins-core MAVEN version 1.576 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - com.blazemeter.plugins:blazemeterjenkinsplugin =2.0, =1.14, =1.14, =1.5, =1.6 Source cves:...