35286 matches found
CVE-2025-54869
FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service DoS vulnerability. An attacker...
CVE-2025-54869
FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service DoS vulnerability. An attacker...
CVE-2025-54869 FPDI is Vulnerable to Memory Exhaustion (OOM) through its PDF Parser
FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service DoS vulnerability. An attacker...
CVE-2025-54869 FPDI is Vulnerable to Memory Exhaustion (OOM) through its PDF Parser
FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service DoS vulnerability. An attacker...
CVE-2025-54869
CVE-2025-54869 affects FPDI (PHP) up to version 2.6.2. The vulnerability arises when processing user-supplied PDFs, causing server-side memory exhaustion and DoS; service availability can be degraded under repeated attacks. Remediation: upgrade to FPDI 2.6.3 or later. This summary reflects detail...
CVE-2025-54869 FPDI is Vulnerable to Memory Exhaustion (OOM) through its PDF Parser
FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service DoS vulnerability. An attacker...
CVE-2013-10068
Foxit Reader versions through 5.4.5.0114, including the bundled Foxit Reader Plugin 2.2.1.530, contains a stack-based buffer overflow vulnerability in the npFoxitReaderPlugin.dll module. When a PDF file is loaded from a remote host, an overly long query string in the URL can overflow a buffer,...
CVE-2013-10068
Foxit Reader versions through 5.4.5.0114, including the bundled Foxit Reader Plugin 2.2.1.530, contains a stack-based buffer overflow vulnerability in the npFoxitReaderPlugin.dll module. When a PDF file is loaded from a remote host, an overly long query string in the URL can overflow a buffer,...
CVE-2013-10068
Foxit Reader Plugin (npFoxitReaderPlugin.dll) in Foxit Reader 5.4.4.11281 bundle includes a stack-based buffer overflow in version 2.2.1.530 when processing a remote PDF URL with an overly long query string, enabling arbitrary code execution. Affected component: Foxit Reader Plugin URL processing...
GHSA-JXHH-4648-VPP3 FPDI allows Memory Exhaustion (OOM) in PDF Parser which leads to Denial of Service
Impact This is a significant Denial of Service DoS vulnerability. Any application that uses FPDI to process user-supplied PDF files is at risk. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to...
FPDI allows Memory Exhaustion (OOM) in PDF Parser which leads to Denial of Service
Impact This is a significant Denial of Service DoS vulnerability. Any application that uses FPDI to process user-supplied PDF files is at risk. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to...
Allocation of Resources Without Limits or Throttling
Overview Affected versions of this package are vulnerable to Allocation of Resources Without Limits or Throttling via the PdfType::resolve which evaluates indirect and direct object references until a final value is reached. An attacker can cause memory exhaustion and crash the server by uploadin...
CVE-2025-47152
An out-of-bounds read vulnerability exists in the EMF functionality of PDF-XChange Co. Ltd PDF-XChange Editor 10.6.0.396. By using a specially crafted EMF file, an attacker could exploit this vulnerability to perform an out-of-bounds read, potentially leading to the disclosure of sensitive...
CVE-2025-27931
An out-of-bounds read vulnerability exists in the EMF functionality of PDF-XChange Editor version 10.5.2.395. By using a specially crafted EMF file, an attacker could exploit this vulnerability to perform an out-of-bounds read, potentially leading to the disclosure of sensitive information...
CVE-2025-27931
An out-of-bounds read vulnerability exists in the EMF functionality of PDF-XChange Editor version 10.5.2.395. By using a specially crafted EMF file, an attacker could exploit this vulnerability to perform an out-of-bounds read, potentially leading to the disclosure of sensitive information...
CVE-2025-27931
An out-of-bounds read vulnerability exists in the EMF functionality of PDF-XChange Editor version 10.5.2.395. By using a specially crafted EMF file, an attacker could exploit this vulnerability to perform an out-of-bounds read, potentially leading to the disclosure of sensitive information...
CVE-2025-27931
An out-of-bounds read vulnerability exists in the EMF functionality of PDF-XChange Editor version 10.5.2.395. By using a specially crafted EMF file, an attacker could exploit this vulnerability to perform an out-of-bounds read, potentially leading to the disclosure of sensitive information...
CVE-2025-27931
PDF-XChange Editor 10.5.2.395 has an out-of-bounds read in the EMF processing path (CVE-2025-27931). A specially crafted EMF file can trigger a read of memory beyond bounds, potentially exposing sensitive data. TALOS confirms the affected version and describes the EMF parsing issue in EMR_POLYDRA...
CVE-2025-47152
An out-of-bounds read vulnerability exists in the EMF functionality of PDF-XChange Co. Ltd PDF-XChange Editor 10.6.0.396. By using a specially crafted EMF file, an attacker could exploit this vulnerability to perform an out-of-bounds read, potentially leading to the disclosure of sensitive...
CVE-2025-47152
CVE-2025-47152 is a PDF-XChange Editor EMF processing vulnerability. Cisco Talos details an out-of-bounds read in the EMF functionality of PDF-XChange Editor 10.6.0.396 caused by insufficient validation of the Facename field within EMR_EXTCREATEFONTINDIRECTW, which can lead to leakage of memory c...