13688 matches found
CVE-2026-85453 MOOS core-moos through 10.4.0 MOOSDB HTTP Pages Stored Cross-Site Scripting
MOOS core-moos through 10.4.0 fails to escape database contents when rendering MOOSDB HTTP pages, allowing attackers to inject malicious scripts. Any MOOS publisher can set variable values containing script payloads that execute in the browser of operators viewing the web interface...
CVE-2026-85453 MOOS core-moos through 10.4.0 MOOSDB HTTP Pages Stored Cross-Site Scripting
MOOS core-moos through 10.4.0 fails to escape database contents when rendering MOOSDB HTTP pages, allowing attackers to inject malicious scripts. Any MOOS publisher can set variable values containing script payloads that execute in the browser of operators viewing the web interface...
ApostropheCMS: Missing destination-parent authorization in page `move()` allows a low-privileged editor to move and re-rank pages inside a restricted subtree
Summary ApostropheCMS enforces per-type authorization on pages: a page type may declare editRole / publishRole and the core @apostrophecms/archive-page does, so a project can have page-type subtrees that only higher-privileged roles are allowed to create or edit within. The move operation is...
Next.js Framework 13.4 < 15.5.24 / 16.x < 16.3.3 RCE (Windows)
The Next.js Framework on the remote host is affected by a remote code execution vulnerability: - A vulnerability in applications using both the Pages Router and App Router without Cache Components can lead to unauthenticated remote code execution when the Next.js server uses a Windows filesystem...
CVE-2026-84677
The Jenkins update-center2 tool (version 3.18.3 and earlier ) contains a stored cross-site scripting (XSS) vulnerability. The root cause is the failure to escape plugin-provided values, specifically plugin names, descriptions, and version metadata , when rendering plugin download index pages. Thi...
CVE-2026-84677
Jenkins update-center2 3.18.3 and earlier does not escape plugin-provided values plugin names, descriptions, and version metadata on plugin download index pages, resulting in a stored cross-site scripting XSS vulnerability exploitable by attackers able to provide a plugin for hosting...
CVE-2026-84677
Jenkins update-center2 3.18.3 and earlier does not escape plugin-provided values plugin names, descriptions, and version metadata on plugin download index pages, resulting in a stored cross-site scripting XSS vulnerability exploitable by attackers able to provide a plugin for hosting...
EUVD-2026-70150
Jenkins update-center2 3.18.3 and earlier does not escape plugin-provided values plugin names, descriptions, and version metadata on plugin download index pages, resulting in a stored cross-site scripting XSS vulnerability exploitable by attackers able to provide a plugin for hosting...
CVE-2026-12865 Photo Gallery by 10Web < 1.8.44 - Reflected XSS via title and paged Parameters
The Photo Gallery by 10Web WordPress plugin before 1.8.44 does not escape two request parameters before reflecting them into input-attribute values on its admin pages one on the Shortcode page, one on the Galleries/Albums list page, so an unauthenticated attacker can craft a link that, when opene...
Stored XSS vulnerability in update-center2
https://github.com/jenkins-infra/update-center2/Update-center2 is the tool used to generate the Jenkins update sites hosted on updates.jenkins.io. NOTE: While it is designed for use by the Jenkins project for this purpose, others may be using it to operate their own self-hosted update sites...
CVE-2026-12865: Improper Neutralization of Input During Web Page Generation
The Photo Gallery by 10Web WordPress plugin before 1.8.44 does not escape two request parameters before reflecting them into input-attribute values on its admin pages one on the Shortcode page, one on the Galleries/Albums list page, so an unauthenticated attacker can craft a link that, when opene...
PT-2026-84800
Jenkins update-center2 3.18.3 and earlier does not escape plugin-provided values plugin names, descriptions, and version metadata on plugin download index pages, resulting in a stored cross-site scripting XSS vulnerability exploitable by attackers able to provide a plugin for hosting...
CVE-2026-75604
Next.js is a React framework for building full-stack web applications. From 13.4.0 until 15.5.24 and 16.3.3, Next.js applications using Pages Router or App Router without Cache Components on Windows-hosted servers do not consistently escape backslashes in route segments before constructing...
CVE-2026-84193
LibreNMS through version 26.2.0 is affected by a stored cross-site scripting (XSS) vulnerability in legacy PHP template pages that render unescaped SNMP-sourced data fields , including BGP peer descriptions, VRF names, process information, and SLA tags. An attacker with device management access o...
CVE-2026-84188
LibreNMS versions configuration settings, which are echoed verbatim without HTML escaping in includes/html/pages/graphs.inc.php. An administrator can store a malicious HTML payload that executes in the browser of any authenticated user who views the affected graph type. The issue is fixed in...
kernel: mm/khugepaged: write all dirty file folios when collapsing
A flaw was found in the Linux kernel's memory management mm/khugepaged component. A local user could trigger an edge case where unsaved changes to file data dirty folios are improperly discarded. This occurs when a file with previous writes is subjected to a specific sequence of memory advice...
CVE-2026-84191: Improper Neutralization of Input During Web Page Generation
LibreNMS before 26.5.0 contains stored cross-site scripting vulnerabilities in VRF display pages where mplsVpnVrfDescription, vrfname, and mplsVpnVrfRouteDistinguisher fields from SNMP polling are rendered without sanitization. Attackers controlling a monitored network device can inject arbitrary...
CVE-2026-84193: Improper Neutralization of Input During Web Page Generation
LibreNMS through 26.2.0 contains a stored cross-site scripting vulnerability in legacy PHP template pages that render unescaped SNMP-sourced data fields including BGP peer descriptions, VRF names, process information, and SLA tags. Attackers with device management access or network access to enro...
CVE-2026-75604: Improper Limitation of a Pathname to a Restricted Directory
Next.js is a React framework for building full-stack web applications. From 13.4.0 until 15.5.24 and 16.3.3, Next.js applications using Pages Router or App Router without Cache Components on Windows-hosted servers do not consistently escape backslashes in route segments before constructing...
CVE-2026-84188: Improper Neutralization of Input During Web Page Generation
LibreNMS versions = 26.4.0 contain a stored cross-site scripting vulnerability in the graphdescr. configuration settings, which are echoed verbatim without HTML escaping in includes/html/pages/graphs.inc.php. An administrator can store a malicious HTML payload that executes in the browser of any...