34930 matches found
CVE-2025-7003
Heap buffer out-of-bounds read vulnerability in Avira Antivirus engine when scanning a malformed PDF file may allow Local Execution of Code or Denial-of-Service of the antivirus engine process. This issue affects Avira Antivirus on Windows, macOS, and Linux for engine builds before 8.3.70.56...
CVE-2025-9033 Avira antivirus engine heap buffer OOB read when scanning a malformed PDF file (variant 3)
Heap buffer out-of-bounds read vulnerability in Avira Antivirus engine when scanning a malformed PDF file may allow Local Execution of Code or Denial-of-Service of the antivirus engine process. This issue affects Avira Antivirus on Windows, macOS, and Linux for engine builds before 8.3.70.76...
CVE-2025-9033
The CVE-2025-9033 issue affects Avira Antivirus engine on Windows, macOS, and Linux for engine builds before 8.3.70.76. It is a heap buffer out-of-bounds read in the scanner when processing a malformed PDF, variant 3, which may allow Local Execution of Code or Denial-of-Service of the antivirus e...
CVE-2025-9033 Avira antivirus engine heap buffer OOB read when scanning a malformed PDF file (variant 3)
Heap buffer out-of-bounds read vulnerability in Avira Antivirus engine when scanning a malformed PDF file may allow Local Execution of Code or Denial-of-Service of the antivirus engine process. This issue affects Avira Antivirus on Windows, macOS, and Linux for engine builds before 8.3.70.76...
CVE-2025-7010 Avast antivirus stack overflow when scanning a malformed PDF file
Stack overflow vulnerability due to uncontrolled recursion in Avast Antivirus when scanning a malformed PDF file may allow Denial-of-Service of the antivirus process. This issue affects Avast Antivirus, AVG Antivirus, Norton Antivirus, Avast One, and Avast Business Antivirus on Windows, macOS, an...
CVE-2025-7010
CVE-2025-7010 describes a stack overflow vulnerability (uncontrolled recursion) in Avast’s scanning engine when processing a malformed PDF, leading to Denial‑of‑Service of the antivirus process. Affected products include Avast Antivirus, AVG Antivirus, Norton Antivirus, Avast One, and Avast Busin...
CVE-2025-7003
CVE-2025-7003 describes a heap buffer out-of-bounds read in the Avira Antivirus engine when scanning malformed PDF files, potentially enabling local code execution or denial-of-service. Affected: Avira Antivirus engine on Windows, macOS, and Linux for builds prior to 8.3.70.56. Exploitation detai...
CVE-2025-7003 Avira antivirus engine heap buffer OOB read when scanning a malformed PDF file (variant 1)
Heap buffer out-of-bounds read vulnerability in Avira Antivirus engine when scanning a malformed PDF file may allow Local Execution of Code or Denial-of-Service of the antivirus engine process. This issue affects Avira Antivirus on Windows, macOS, and Linux for engine builds before 8.3.70.56...
CVE-2025-7002 Avira antivirus engine heap buffer OOB read when scanning a malformed PDF file (variant 2)
Heap buffer out-of-bounds read vulnerability in Avira Antivirus engine when scanning a malformed PDF file may allow Local Execution of Code or Denial-of-Service of the antivirus engine process. This issue affects Avira Antivirus on Windows, macOS, and Linux for engine builds before 8.3.70.68...
CVE-2025-7002
CVE-2025-7002 is a heap buffer out-of-bounds read vulnerability in the Avira Antivirus engine when scanning a malformed PDF, potentially allowing local code execution or crashing the antivirus process. Affected products are Avira Antivirus engines on Windows, macOS, and Linux with builds prior to...
GHSA-248M-82V9-Q6G6 pypdf: Possible long runtimes for zero-only width values in cross-reference streamsuntimes for zero-only width values in cross-reference streams
Impact An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires cross-reference streams with /W 0 0 0 values and large /Size values. Patches This has been fixed in pypdf==6.12.0. Workarounds If developers are unable to upgrade their apps immediately, the...
genai-4-dps-helper (0.2.31), news-scraper-pdf (1.1.6) +5 more potentially affected by CVE-2026-48156 via pypdf (5.3.0)
pypdf PYPI version 5.3.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - genai-4-dps-helper 0.2.31 - news-scraper-pdf 1.1.6 - polytext =0.1.0, =0.1.0, =0.1.10 - python-pdf-toolkit 0.1.1 - synforge 0.1.0 - textspitter 0.3.7r...
smart-pdf (2023.9.11.1) potentially affected by CVE-2026-48156 via pypdf (3.16.0)
pypdf PYPI version 3.16.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - smart-pdf 2023.9.11.1 Source cves: CVE-2026-48156 Source advisory: OSV:GHSA-248M-82V9-Q6G6...
docrx (>=0.0.1, <=0.0.10), paperreview (0.1.0) +1 more potentially affected by CVE-2026-48156 via pypdf (3.15.0)
pypdf PYPI version 3.15.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - docrx =0.0.1, =1.1.11, =1.1.13 Source cves: CVE-2026-48156 Source advisory: OSV:GHSA-248M-82V9-Q6G6...
gai-common (>=0.1.2, <=0.86.0), gai-lib (0.120.0) +4 more potentially affected by CVE-2026-48156 via pypdf (4.3.0)
pypdf PYPI version 4.3.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - gai-common =0.1.2, =1.1.3, =0.3.1, =5.3.8, =0.6.6, =0.7.0 Source cves: CVE-2026-48156 Source advisory: OSV:GHSA-248M-82V9-Q6G6...
docrx (>=0.0.1, <=0.0.10), paperreview (0.1.0) +1 more potentially affected by CVE-2026-48155 via pypdf (3.15.0)
pypdf PYPI version 3.15.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - docrx =0.0.1, =1.1.11, =1.1.13 Source cves: CVE-2026-48155 Source advisory: OSV:GHSA-CJ93-CHG6-VGV8...
smart-pdf (2023.9.11.1) potentially affected by CVE-2026-48155 via pypdf (3.16.0)
pypdf PYPI version 3.16.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - smart-pdf 2023.9.11.1 Source cves: CVE-2026-48155 Source advisory: OSV:GHSA-CJ93-CHG6-VGV8...
gai-common (>=0.1.2, <=0.86.0), gai-lib (0.120.0) +4 more potentially affected by CVE-2026-48155 via pypdf (4.3.0)
pypdf PYPI version 4.3.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - gai-common =0.1.2, =1.1.3, =0.3.1, =5.3.8, =0.6.6, =0.7.0 Source cves: CVE-2026-48155 Source advisory: OSV:GHSA-CJ93-CHG6-VGV8...
add-staves (>=0.1.1, <=0.2.4), agentix-agent-sdk (0.1.0) +135 more potentially affected by CVE-2026-48155 via pypdf (4.3.1)
pypdf PYPI version 4.3.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - add-staves =0.1.1, =0.0.1, =0.0.1.dev1, =3.0.0, =0.1.0, =1.0.0, =0.3.8.0, =0.3.2, =0.1.6, =1725528079.0.0, =0.1.4, =0.1.9 and more Source cves:...
genai-4-dps-helper (0.2.31), news-scraper-pdf (1.1.6) +5 more potentially affected by CVE-2026-48155 via pypdf (5.3.0)
pypdf PYPI version 5.3.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - genai-4-dps-helper 0.2.31 - news-scraper-pdf 1.1.6 - polytext =0.1.0, =0.1.0, =0.1.10 - python-pdf-toolkit 0.1.1 - synforge 0.1.0 - textspitter 0.3.7r...