61858 matches found
OpenClaw: Agent gateway config mutations could change protected operator settings
Affected Packages / Versions - Package: openclaw npm - Affected versions: 2026.4.20 - Patched version: 2026.4.20 Impact The agent-facing gateway config.patch / config.apply guard did not cover several operator-trusted settings, including sandbox policy, plugin enablement, gateway auth/TLS, hook...
NPM: OpenClaw: Agent gateway config mutations could change protected operator settings
NPM: OpenClaw: Agent gateway config mutations could change protected operator settings vulnerability discovered by ? in WordPress Npm openclaw versions 2026.4.20...
GHSA-7JM2-G593-4QRC OpenClaw: Agent gateway config mutations could change protected operator settings
Affected Packages / Versions - Package: openclaw npm - Affected versions: 2026.4.20 - Patched version: 2026.4.20 Impact The agent-facing gateway config.patch / config.apply guard did not cover several operator-trusted settings, including sandbox policy, plugin enablement, gateway auth/TLS, hook...
GHSA-V8QF-FR4G-28P2 OpenClaw: Assistant media route missed scope enforcement for trusted-proxy authorization
Affected Packages / Versions - Package: openclaw npm - Affected versions: 2026.4.20 - Patched version: 2026.4.20 Impact The Control UI assistant-media route authenticated trusted-proxy callers but did not enforce the declared operator scopes for identity-bearing HTTP auth paths. A trusted-proxy...
OpenClaw: Assistant media route missed scope enforcement for trusted-proxy authorization
Affected Packages / Versions - Package: openclaw npm - Affected versions: 2026.4.20 - Patched version: 2026.4.20 Impact The Control UI assistant-media route authenticated trusted-proxy callers but did not enforce the declared operator scopes for identity-bearing HTTP auth paths. A trusted-proxy...
CVE-2026-29181 vulnerabilities
Vulnerabilities for packages: crossplane-provider-aws-secretsmanager, blob-csi-fips, gitlab-kas, dex, crossplane-provider-aws-emr, external-dns-fips, commercial-grafana, ucd, knative-client, kubernetes-csi-node-driver-registrar-fips, cluster-api, blob-csi, crossplane-provider-aws-bedrockagent,...
GHSA-MH2Q-Q3FH-2475 vulnerabilities
Vulnerabilities for packages: crossplane-provider-aws-secretsmanager, blob-csi-fips, gitlab-kas, dex, crossplane-provider-aws-emr, external-dns-fips, commercial-grafana, ucd, knative-client, kubernetes-csi-node-driver-registrar-fips, cluster-api, blob-csi, crossplane-provider-aws-bedrockagent,...
GHSA-MH2Q-Q3FH-2475 vulnerabilities
Vulnerabilities for packages: kargo, crossplane-provider-aws-cloudformation, flux-helm-controller, prometheus, aactl, docker-machine-driver-harvester, crossplane-provider-azure-storage, neuvector-scanner, argo-events, dex, crossplane-provider-aws-ec2, skopeo, src, cloud-provider-vsphere,...
CVE-2026-29181 vulnerabilities
Vulnerabilities for packages: kargo, crossplane-provider-aws-cloudformation, flux-helm-controller, prometheus, aactl, docker-machine-driver-harvester, crossplane-provider-azure-storage, neuvector-scanner, argo-events, dex, crossplane-provider-aws-ec2, skopeo, src, cloud-provider-vsphere,...
CLEANSTART-2026-YX54699 race condition in the Apache Kafka Java producer client’s buffer pool management can cause messages to be silently delivered to incorrect topics
Multiple security vulnerabilities affect the strimzi-kafka-operator package. A race condition in the Apache Kafka Java producer client’s buffer pool management can cause messages to be silently delivered to incorrect topics. See references for individual vulnerability details...
CVE-2026-32952 vulnerabilities
Vulnerabilities for packages: minio, rancher-agent, trufflehog, cert-manager-csi-driver, harbor, kyverno, seaweedfs, juicefs, teleport, zot, external-secrets-operator, k6, dex, flux-source-controller, grafana, gitea, cert-manager-cmctl, gitlab-runner, openbao, telegraf, xeol, ratify,...
GHSA-PJCQ-XVWQ-HHPJ vulnerabilities
Vulnerabilities for packages: minio, rancher-agent, trufflehog, cert-manager-csi-driver, harbor, kyverno, seaweedfs, juicefs, teleport, zot, external-secrets-operator, k6, dex, flux-source-controller, grafana, gitea, cert-manager-cmctl, gitlab-runner, openbao, telegraf, xeol, ratify,...
CVE-2026-32952 vulnerabilities
Vulnerabilities for packages: cert-manager-openshift-routes, openbao, harbor-fips, seaweedfs-fips, dex, commercial-grafana, minio-fips, neuvector-fips, rclone, openbao-fips, packer-fips, kyverno-notation-aws, syncthing-fips, rancher-webhook-fips, k6-fips, cert-manager, harbor, xeol, versitygw,...
k8sGPT has Prompt Injection through its k8sGPT-Operator
Summary In the auto-remediation pipeline, objecttoexecution.go was deserializing the AI-generated YAML directly into a Deployment object, but there was lack of validation from the original Deployment object. Details This issue was fixed after coordination with Alex Jones. PoC To minimize the...
GHSA-394X-274P-MQC6 Duplicate Advisory: OpenClaw: Gateway operator.write Can Reach Admin-Class Telegram Config and Cron Persistence via send
Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-767m-xrhc-fxm7. This link is maintained to preserve external references. Original Description OpenClaw before 2026.3.28 contains a privilege escalation vulnerability allowing authenticated operators with write...
Duplicate Advisory: OpenClaw: HTTP operator endpoints lack browser-origin validation in trusted-proxy mode
Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-mhr7-2xmv-4c4q. This link is maintained to preserve external references. Original Description OpenClaw before 2026.3.31 lacks browser-origin validation in HTTP operator endpoints when operating in trusted-proxy...
EUVD-2026-25331
OpenClaw before 2026.3.31 lacks browser-origin validation in HTTP operator endpoints when operating in trusted-proxy mode, allowing cross-site request forgery attacks. Attackers can exploit this by sending malicious requests from a browser in trusted-proxy deployments to perform unauthorized...
GHSA-2XP4-QHR4-XQM2 Duplicate Advisory: OpenClaw: HTTP operator endpoints lack browser-origin validation in trusted-proxy mode
Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-mhr7-2xmv-4c4q. This link is maintained to preserve external references. Original Description OpenClaw before 2026.3.31 lacks browser-origin validation in HTTP operator endpoints when operating in trusted-proxy...
CVE-2026-41347
OpenClaw before 2026.3.31 lacks browser-origin validation in HTTP operator endpoints when operating in trusted-proxy mode, allowing cross-site request forgery attacks. Attackers can exploit this by sending malicious requests from a browser in trusted-proxy deployments to perform unauthorized...
CVE-2026-41359 OpenClaw < 2026.3.28 - Privilege Escalation via operator.write to Admin-Class Telegram Config and Cron Persistence
OpenClaw before 2026.3.28 contains a privilege escalation vulnerability allowing authenticated operators with write permissions to access admin-class Telegram configuration and cron persistence settings via the send endpoint. Attackers with operator.write credentials can exploit insufficient acce...