757 matches found
Security Advisory 2020-12-09-1 - Linux kernel - ICMP rate limiting can be used to facilitate DNS poisoning attack (CVE-2020-25705)
DESCRIPTION A flaw has been found in the ICMP rate limiting algorithm of the Linux kernel. This flaw allows an off-path attacker to quickly determine open ephemeral ports that are used by applications making outbound connections. This can be exploited by an off-path attacker to more easily perfor...
OpenWrt Web UI Detection.
Binary data openwrtwebuidetect.nbin...
OpenWrt < 18.06.2 XSS (direct check)
Binary data openwrtcve201819630.nbin...
CVE-2020-28951
libuci in OpenWrt before 18.06.9 and 19.x before 19.07.5 may encounter a use after free when using malicious package names. This is related to uciparsepackage in file.c and ucistrdup in util.c...
CVE-2020-28951
libuci in OpenWrt before 18.06.9 and 19.x before 19.07.5 may encounter a use after free when using malicious package names. This is related to uciparsepackage in file.c and ucistrdup in util.c...
Double free
libuci in OpenWrt before 18.06.9 and 19.x before 19.07.5 may encounter a use after free when using malicious package names. This is related to uciparsepackage in file.c and ucistrdup in util.c...
CVE-2020-28951
libuci in OpenWrt before 18.06.9 and 19.x before 19.07.5 may encounter a use after free when using malicious package names. This is related to uciparsepackage in file.c and ucistrdup in util.c...
CVE-2020-28951
CVE-2020-28951 affects OpenWrt libuci. A use-after-free can occur in libuci when processing malicious package names, specifically in uci_parse_package (file.c) and uci_strdup (util.c). Affected OpenWrt versions: 18.06.0–18.06.8 and 19.07.0–19.07.4. Remediation is to upgrade to OpenWrt 18.06.9 or ...
CVE-2020-28951: Use After Free
libuci in OpenWrt before 18.06.9 and 19.x before 19.07.5 may encounter a use after free when using malicious package names. This is related to uciparsepackage in file.c and ucistrdup in util.c...
OpenWrt Resource Management Error Vulnerability
OpenWrt is a Linux operating system for embedded devices. A security vulnerability exists in libuci in OpenWrt versions prior to 18.06.9 and 19.x series versions prior to 19.07.5, which stems from the possibility of encountering the use of a malware package name after using free. This is related ...
PT-2020-5336 · Openwrt · Openwrt +1
Name of the Vulnerable Software and Affected Versions: OpenWrt versions 18.06.0 through 18.06.8 OpenWrt versions 19.0.0 through 19.07.4 Description: The issue is related to a use after free error in the libuci library of OpenWrt. This error can occur when using malicious package names, specifical...
LuCI Configuration Interface Inter-site Request Manipulation
The vulnerability of the LuCI configuration web interface in the embedded operating system OpenWrt exists due to the improper functioning of the mechanism for protecting the web page structure. Exploiting this vulnerability allows a malicious actor to manipulate inter-site requests using certain...
OpenWrt uhttpd DoS
The vulnerability of the uhttpd function in the embedded operating system OpenWrt relates to the execution of operations outside the buffer boundaries. Exploiting this vulnerability allows a malicious actor to trigger a service failure by sending a specially crafted HTTP POST request to the CGI...
Ustream-SSL Man-in-the-Middle
The vulnerability of the Ustream-SSL library in the embedded operating system OpenWrt is related to errors in the certificate validation process. Exploiting this vulnerability allows a malicious actor to carry out a “man-in-the-middle” attack...
Ustream-SSL Man-in-the-Middle
The vulnerability of the Ustream-SSL library in the embedded operating system OpenWrt is related to errors in the certificate validation process. Exploiting this vulnerability allows a malicious actor to carry out a “man-in-the-middle” attack...
OpenWrt relayd Buffer Overflow
The vulnerability of the relayd function in the embedded operating system OpenWrt relates to reading data beyond the buffer limit. Exploiting this vulnerability can allow a remote attacker to cause a buffer overflow...
OpenWrt umdns Buffer Overflow
The vulnerability of the umdns function in the embedded operating system OpenWrt relates to reading data beyond the buffer limit. Exploiting this vulnerability can allow a remote attacker to trigger a buffer overflow...
PT-2020-2161
Name of the Vulnerable Software and Affected Versions OpenWrt affected versions not specified Description The issue is related to a buffer overflow in the relayd function of the OpenWrt embedded operating system. This can be exploited by a remote attacker to cause a buffer overflow. Recommendatio...
Security Advisory 2020-05-06-1 - umdns out-of-bounds reads of heap data and possible buffer overflow (CVE-2020-11750)
DESCRIPTION umdns in OpenWrt through 18.06.8 and 19.07.2 has potential for out-of-bounds reads of heap data and possible buffer overflow. umdns is the OpenWrt Multicast DNS Daemon. We have not been made aware of any exploits at this time, however users are advised to update the umdns package to...
Security Advisory 2020-05-06-2 - relayd out-of-bounds reads of heap data and possible buffer overflow (CVE-2020-11752)
DESCRIPTION relayd in OpenWrt through 19.07.2 and 18.06.8 has potential for out-of-bounds reads of heap data and possible buffer overflow. relayd is a transparent routing / relay daemon for OpenWrt. It can be used to relay traffic between two networks, including DHCP and broadcast, when other...