1670 matches found
openSUSE Security Update : opencv (openSUSE-2019-436)
This update for opencv fixes this security issue : - CVE-2017-18009: Prevent heap-based buffer over-read in the function cv::HdrDecoder::checkSignature bsc1074312. %NASLMINLEVEL 70300 C Tenable Network Security, Inc. The descriptive text and package checks in this plugin were extracted from...
Command Injection
opencv is vulnerable to command injection. User input is not validated for the flag parameter, which would allow an attacker to inject and execute arbitrary commands...
Command injection
utils/find-opencv.js in node-opencv aka OpenCV bindings for Node.js prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands...
CVE-2019-10061
utils/find-opencv.js in node-opencv aka OpenCV bindings for Node.js prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands...
CVE-2019-10061
utils/find-opencv.js in node-opencv aka OpenCV bindings for Node.js prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands...
DEBIAN-CVE-2019-10061
utils/find-opencv.js in node-opencv aka OpenCV bindings for Node.js prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands...
CVE-2019-10061
utils/find-opencv.js in node-opencv aka OpenCV bindings for Node.js prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands...
CVE-2019-10061
CVE-2019-10061 affects the Node.js OpenCV bindings (node-opencv). The vulnerable component is utils/find-opencv.js , with versions prior to 6.1.0 . Root cause: it does not validate user input, enabling attackers to execute arbitrary commands via a crafted input. Impact is described as Command Inj...
CVE-2019-10061
utils/find-opencv.js in node-opencv aka OpenCV bindings for Node.js prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands...
abe-cli (>=2.11.3, <=2.14.2), abeadfab (>=2.16.15, <=3.7.20) +25 more potentially affected by CVE-2019-10061 via opencv (>=0.0.12, <=5.0.0)
opencv NPM version =0.0.12, =2.11.3, =2.16.15, =1.0.0, =0.1.0, =0.1.0, =0.0.1, =1.0.0, =0.0.2, =1.1.1 and more Source cves: CVE-2019-10061 Source advisory: MEND:CVE-2019-10061...
CVE-2019-10061
utils/find-opencv.js in node-opencv aka OpenCV bindings for Node.js prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands...
CVE-2019-10061
utils/find-opencv.js in node-opencv aka OpenCV bindings for Node.js prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands...
node-opencv command injection vulnerability
node-opencv is the OpenCV binding for Node.js. A command injection vulnerability exists in utils/find-opencv.js in versions of node-opencv prior to 6.1.0. The vulnerability stems from node-opencv failing to validate user input. An attacker can exploit the vulnerability to execute arbitrary comman...
CVE-2019-10061: Improper Neutralization of Special Elements used in an OS Command
utils/find-opencv.js in node-opencv aka OpenCV bindings for Node.js prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands...
PT-2019-11412
Name of the Vulnerable Software and Affected Versions: node-opencv versions prior to 6.1.0 Description: The issue concerns a command injection problem where user input is not properly validated, allowing attackers to execute arbitrary commands. Recommendations: For versions prior to 6.1.0, update...
Command Injection
Overview Versions of opencvprior to 6.1.0 are vulnerable to Command Injection. The utils/ script find-opencv.js does not validate user input allowing attackers to execute arbitrary commands. Recommendation Upgrade to version 6.1.0. References GitHub Advisory...
opencv/imdecode_fuzzer: Negative-size-param in _TIFFmemcpy
Project: https://github.com/opencv/opencv.git Detailed report: https://oss-fuzz.com/testcase?key=5766572742803456 Project: opencv Fuzzer: aflopencvimdecodefuzzer Fuzz target binary: imdecodefuzzer Job Type: aflasanopencv Platform Id: linux Crash Type: Negative-size-param Crash Address: Crash Stat...
opencv/imread_fuzzer: Use-of-uninitialized-value in Imf::copyIntoFrameBuffer
Detailed report: https://oss-fuzz.com/testcase?key=5141671744897024 Project: opencv Fuzzer: libFuzzeropencvimreadfuzzer Fuzz target binary: imreadfuzzer Job Type: libfuzzermsanopencv Platform Id: linux Crash Type: Use-of-uninitialized-value Crash Address: Crash State: Imf::copyIntoFrameBuffer...
opencv/imread_fuzzer: Use-of-uninitialized-value in inflate
Detailed report: https://oss-fuzz.com/testcase?key=5708657289854976 Project: opencv Fuzzer: libFuzzeropencvimreadfuzzer Fuzz target binary: imreadfuzzer Job Type: libfuzzermsanopencv Platform Id: linux Crash Type: Use-of-uninitialized-value Crash Address: Crash State: inflate uncompress2 uncompre...
opencv/imread_fuzzer: Use-of-uninitialized-value in adler32_z
Detailed report: https://oss-fuzz.com/testcase?key=5755561323266048 Project: opencv Fuzzer: libFuzzeropencvimreadfuzzer Fuzz target binary: imreadfuzzer Job Type: libfuzzermsanopencv Platform Id: linux Crash Type: Use-of-uninitialized-value Crash Address: Crash State: adler32z inflate ZIPDecode...