Lucene search
+L

14 matches found

Mend
Mend
•added 2026/08/06 1:30 p.m.•9 views

CVE-2026-19041

A vulnerability has been found in MissionSquad mcp-api up to 1.11.8. The impacted element is the function this.packageService.installPackage of the file src/controllers/packages.ts of the component NPM Package Version Handler. The manipulation leads to command injection. It is possible to initiat...

6.5CVSS5.9AI score0.02121EPSS
SaveExploits0References11
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2026/08/06 12:00 a.m.•10 views

CVE-2026-19041: Improper Neutralization of Special Elements used in a Command

A vulnerability has been found in MissionSquad mcp-api up to 1.11.8. The impacted element is the function this.packageService.installPackage of the file src/controllers/packages.ts of the component NPM Package Version Handler. The manipulation leads to command injection. It is possible to initiat...

6.5CVSS6AI score0.02121EPSS
SaveExploits0References3
Positive Technologies
Positive Technologies
•added 2026/08/06 12:00 a.m.•16 views

PT-2026-68495

Name of the Vulnerable Software and Affected Versions MissionSquad mcp-api versions prior to 1.11.9 Description Command injection is possible via remote attack in the NPM Package Version Handler component. The issue resides in the this.packageService.installPackage function within the...

6.5CVSS6.5AI score0.02121EPSS
SaveExploits0References14
vulnersOsv
vulnersOsv
•added 2022/08/03 12:00 a.m.•9 views

@cyber-insight/cyber-scripts (>=1.7.9, <=6.0.0-alpha.4), @cyber.insight/cyber-scripts (>=1.0.0, <=1.0.2) +4 more potentially affected by CVE-2020-7795 via get-npm-package-version (1.0.6)

get-npm-package-version NPM version 1.0.6 is affected by a known vulnerability. The following packages have a transitive dependency on get-npm-package-version and may be impacted: - @cyber-insight/cyber-scripts =1.7.9, =1.0.0, =5.0.20, =1.0.0, =1.0.7 - temp-test-scripts 0.0.30 Source cves:...

9.8CVSS5.3AI score0.03968EPSS
SaveExploits1
osv_ghsa
osv_ghsa
•added 2022/08/03 12:00 a.m.•63 views

GHSA-4H66-VGHF-XG5X get-npm-package-version Command Injection vulnerability

The package get-npm-package-version before 1.0.7 is vulnerable to Command Injection via the main function in index.js...

9.8CVSS5.9AI score0.03968EPSS
SaveExploits1References6
vulnersOsv
vulnersOsv
•added 2022/08/03 12:00 a.m.•2 views

@cyber-insight/cyber-scripts (>=1.7.9, <=6.0.0-alpha.4), @cyber.insight/cyber-scripts (>=1.0.0, <=1.0.2) +4 more potentially affected by CVE-2020-7795 via get-npm-package-version (1.0.6)

get-npm-package-version NPM version 1.0.6 is affected by a known vulnerability. The following packages have a transitive dependency on get-npm-package-version and may be impacted: - @cyber-insight/cyber-scripts =1.7.9, =1.0.0, =5.0.20, =1.0.0, =1.0.7 - temp-test-scripts 0.0.30 Source cves:...

9.8CVSS0.03968EPSS
SaveExploits1
vulnersOsv
vulnersOsv
•added 2022/08/02 1:27 p.m.•2 views

@cyber-insight/cyber-scripts (>=1.7.9, <=6.0.0-alpha.4), @cyber.insight/cyber-scripts (>=1.0.0, <=1.0.2) +4 more potentially affected by CVE-2020-7795 via get-npm-package-version (1.0.6)

get-npm-package-version NPM version 1.0.6 is affected by a known vulnerability. The following packages have a transitive dependency on get-npm-package-version and may be impacted: - @cyber-insight/cyber-scripts =1.7.9, =1.0.0, =5.0.20, =1.0.0, =1.0.7 - temp-test-scripts 0.0.30 Source cves:...

9.8CVSS0.03968EPSS
SaveExploits1
CVE
CVE
•added 2022/08/02 1:27 p.m.•71 views

CVE-2020-7795

CVE-2020-7795 affects the npm package get-npm-package-version prior to 1.0.7. The vulnerability is a command injection flaw exploited via the main function in index.js, enabling arbitrary code execution. Public sources (e.g., Veracode, PSIRT notes) describe the issue as a command injection with i...

9.8CVSS8.6AI score0.03968EPSS
SaveExploits1References4Affected Software1
Mend
Mend
•added 2022/08/02 1:27 p.m.•11 views

CVE-2020-7795

The package get-npm-package-version before 1.0.7 are vulnerable to Command Injection via main function in index.js...

9.8CVSS0.03968EPSS
SaveExploits1References7
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2022/08/02 12:00 a.m.•6 views

CVE-2020-7795: Improper Neutralization of Special Elements used in a Command

The package get-npm-package-version before 1.0.7 are vulnerable to Command Injection via main function in index.js...

9.8CVSS8.2AI score0.03968EPSS
SaveExploits1References2
Positive Technologies
Positive Technologies
•added 2022/08/02 12:00 a.m.•19 views

PT-2022-9062 · Unknown · Get-Npm-Package-Version

Name of the Vulnerable Software and Affected Versions: get-npm-package-version versions prior to 1.0.7 Description: The issue concerns Command Injection via the main function in index.js. Recommendations: For versions prior to 1.0.7, update to version 1.0.7 or later to resolve the issue. As a...

9.8CVSS9.7AI score0.03968EPSS
SaveExploits1References12
CNNVD
CNNVD
•added 2022/08/02 12:00 a.m.•23 views

Get-npm-package-version command injection vulnerability

get-npm-package-version is a package for hoperyy individual developers. It is used to get the npm package version. A command injection vulnerability exists in get-npm-package-version before 1.0.7, which is caused by command injection via the main function in index.js...

9.8CVSS8.3AI score0.03968EPSS
SaveExploits1References5
vulnersOsv
vulnersOsv
•added 2020/12/11 2:18 p.m.•6 views

@cyber-insight/cyber-scripts (>=1.7.9, <=6.0.0-alpha.4), @cyber.insight/cyber-scripts (>=1.0.0, <=1.0.2) +4 more potentially affected by CVE-2020-7795 via get-npm-package-version (1.0.6)

get-npm-package-version NPM version 1.0.6 is affected by a known vulnerability. The following packages have a transitive dependency on get-npm-package-version and may be impacted: - @cyber-insight/cyber-scripts =1.7.9, =1.0.0, =5.0.20, =1.0.0, =1.0.7 - temp-test-scripts 0.0.30 Source cves:...

9.8CVSS5.3AI score0.03968EPSS
SaveExploits1
Snyk
Snyk
•added 2020/12/11 2:18 p.m.•16 views

Command Injection

Overview Affected versions of this package are vulnerable to Command Injection via main function in index.js. PoC var a = require"get-npm-package-version"; a"& touch JHU"; Remediation Upgrade get-npm-package-version to version 1.0.7 or higher. References - GitHub Commit - NPM Package - Vulnerable...

9.8CVSS7.1AI score0.03968EPSS
SaveExploits1References2
Rows per page
Query Builder