5830 matches found
Oracle Linux 9 : nodejs:22 (ELSA-2026-35892)
The remote Oracle Linux 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the ELSA-2026-35892 advisory. - Update to version 22.23.1 Resolves: RHEL-186622 RHEL-185998 RHEL-183669 Fixes: CVE-2026-12151 CVE-2026-48618 CVE-2026-48933 CVE-2026-48937...
CVE-2026-49866
CVE-2026-49866 affects the JavaScript libp2p implementation, specifically the @libp2p/gossipsub component. The root cause is defaultDecodeRpcLimits allowing maxIhaveMessageIDs and maxIwantMessageIDs to be Infinity prior to v16.0.0, enabling oversized IHAVE/IWANT control message arrays in message/...
CVE-2026-48619 affecting package nodejs for versions less than 24.17.0-1
CVE-2026-48619 affecting package nodejs for versions less than 24.17.0-1. An upgraded version of the package is available that resolves this issue...
CVE-2026-48933 affecting package nodejs for versions less than 24.17.0-1
CVE-2026-48933 affecting package nodejs for versions less than 24.17.0-1. An upgraded version of the package is available that resolves this issue...
CVE-2026-48931 affecting package nodejs for versions less than 24.17.0-1
CVE-2026-48931 affecting package nodejs for versions less than 24.17.0-1. An upgraded version of the package is available that resolves this issue...
CVE-2026-48615 affecting package nodejs for versions less than 24.17.0-1
CVE-2026-48615 affecting package nodejs for versions less than 24.17.0-1. An upgraded version of the package is available that resolves this issue...
CVE-2026-48930 affecting package nodejs for versions less than 24.17.0-1
CVE-2026-48930 affecting package nodejs for versions less than 24.17.0-1. An upgraded version of the package is available that resolves this issue...
CVE-2026-48934 affecting package nodejs for versions less than 24.17.0-1
CVE-2026-48934 affecting package nodejs for versions less than 24.17.0-1. An upgraded version of the package is available that resolves this issue...
CVE-2026-48928 affecting package nodejs for versions less than 24.17.0-1
CVE-2026-48928 affecting package nodejs for versions less than 24.17.0-1. An upgraded version of the package is available that resolves this issue...
CVE-2026-9697 affecting package nodejs for versions less than 24.17.0-1
CVE-2026-9697 affecting package nodejs for versions less than 24.17.0-1. An upgraded version of the package is available that resolves this issue...
CVE-2026-48617 affecting package nodejs for versions less than 24.17.0-1
CVE-2026-48617 affecting package nodejs for versions less than 24.17.0-1. An upgraded version of the package is available that resolves this issue...
CVE-2026-48618 affecting package nodejs for versions less than 24.17.0-1
CVE-2026-48618 affecting package nodejs for versions less than 24.17.0-1. An upgraded version of the package is available that resolves this issue...
CVE-2026-48937 affecting package nodejs for versions less than 24.17.0-1
CVE-2026-48937 affecting package nodejs for versions less than 24.17.0-1. An upgraded version of the package is available that resolves this issue...
CVE-2026-48935 affecting package nodejs for versions less than 24.17.0-1
CVE-2026-48935 affecting package nodejs for versions less than 24.17.0-1. An upgraded version of the package is available that resolves this issue...
RLSA-2026:35842 Important: nodejs22 security, bug fix, and enhancement update
Node.js is a platform built on Chrome's JavaScript runtime \ for easily building fast, scalable network applications. \ Node.js uses an event-driven, non-blocking I/O model that \ makes it lightweight and efficient, perfect for data-intensive \ real-time applications that run across distributed...
nodejs22 security, bug fix, and enhancement update
An update is available for nodejs22. This update affects Rocky Linux 10. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list Node.js is a platform built on Chrome's JavaScript runtime \ for easily...
RockyLinux 10 : nodejs22 (RLSA-2026:35842)
The remote RockyLinux 10 host has packages installed that are affected by multiple vulnerabilities as referenced in the RLSA-2026:35842 advisory. ip-address: ip-address: Cross-site scripting via improper HTML escaping of untrusted input CVE-2026-42338 undici: undici: Denial of Service due to...
urllib3 does not control redirects in browsers and Node.js
urllib3 supports being used in a Pyodide runtime utilizing the JavaScript Fetch API or falling back on XMLHttpRequest. This means you can use Python libraries to make HTTP requests from your browser or Node.js. Additionally, urllib3 provides a mechanism to control redirects.However, the retries a...