Lucene search
+L

5844 matches found

SUSE Linux
SUSE Linux
•added 2025/01/24 4:05 p.m.•22 views

Security update for nodejs18

This update for nodejs18 fixes the following issues: Update to 18.20.6: CVE-2025-23085: Fixed HTTP2 memory leak on premature close and ERRPROTO bsc1236250 CVE-2025-22150: Fixed insufficiently random values used when defining the boundary for a multipart/form-data request in undici bsc1236258 Patc...

7.4CVSS6.2AI score0.01377EPSS
SaveExploits0References8
SUSE Linux
SUSE Linux
•added 2025/01/24 2:33 p.m.•18 views

Security update for nodejs20

This update for nodejs20 fixes the following issues: Update to 20.18.2: CVE-2025-23083: Fixed worker permission bypass via InternalWorker leak in diagnostics bsc1236251 CVE-2025-23085: Fixed HTTP2 memory leak on premature close and ERRPROTO bsc1236250 CVE-2025-22150: Fixed insufficiently random...

7.8CVSS6.1AI score0.01377EPSS
SaveExploits0References12
osv_opensuse
osv_opensuse
•added 2025/01/23 12:00 a.m.•10 views

OPENSUSE-SU-2025:14687-1 nodejs-electron-33.3.2-1.1 on GA media

These are all security issues fixed in the nodejs-electron-33.3.2-1.1 package on the GA media of openSUSE Tumbleweed...

8.8CVSS6.4AI score0.05956EPSS
SaveExploits1References1
osv_azl
osv_azl
•added 2025/01/22 8:15 p.m.•22 views

AZL-56052 CVE-2025-0612 affecting package nodejs18 18.20.3-11

Out of bounds memory access in V8 in Google Chrome prior to 132.0.6834.110 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. Chromium security severity: High...

7.5CVSS8.3AI score0.0048EPSS
SaveExploits0References1
osv_azl
osv_azl
•added 2025/01/22 8:15 p.m.•22 views

AZL-56022 CVE-2025-0611 affecting package nodejs18 18.20.3-11

Object corruption in V8 in Google Chrome prior to 132.0.6834.110 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. Chromium security severity: High...

8.2CVSS8.2AI score0.00412EPSS
SaveExploits0References1
osv_azl
osv_azl
•added 2025/01/22 8:15 p.m.•22 views

AZL-56035 CVE-2025-0612 affecting package nodejs for versions less than 24.14.1-3

Out of bounds memory access in V8 in Google Chrome prior to 132.0.6834.110 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. Chromium security severity: High...

7.5CVSS8.3AI score0.0048EPSS
SaveExploits0References1
osv_azl
osv_azl
•added 2025/01/22 8:15 p.m.•22 views

AZL-56041 CVE-2025-0611 affecting package nodejs for versions less than 24.14.1-3

Object corruption in V8 in Google Chrome prior to 132.0.6834.110 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. Chromium security severity: High...

8.2CVSS8.2AI score0.00412EPSS
SaveExploits0References1
Chainguard
Chainguard
•added 2025/01/22 2:15 a.m.•30 views

CVE-2025-23090 vulnerabilities

Vulnerabilities for packages: nodejs...

6.9AI score
SaveExploits0
osv_azl
osv_azl
•added 2025/01/22 2:15 a.m.•31 views

AZL-55922 CVE-2025-23083 affecting package nodejs for versions less than 20.14.0-4

With the aid of the diagnosticschannel utility, an event can be hooked into whenever a worker thread is created. This is not limited only to workers but also exposes internal workers, where an instance of them can be fetched, and its constructor can be grabbed and reinstated for malicious usage...

7.7CVSS7.3AI score0.00422EPSS
SaveExploits0References1
osv_azl
osv_azl
•added 2025/01/21 6:15 p.m.•27 views

AZL-55950 CVE-2025-22150 affecting package nodejs for versions less than 20.14.0-5

Undici is an HTTP/1.1 client. Starting in version 4.5.0 and prior to versions 5.28.5, 6.21.1, and 7.2.3, undici uses Math.random to choose the boundary for a multipart/form-data request. It is known that the output of Math.random can be predicted if several of its generated values are known. If...

6.8CVSS6.1AI score0.00763EPSS
SaveExploits0References1
BDU FSTEC
BDU FSTEC
•added 2025/01/15 12:00 a.m.•19 views

Node.js WebSocket Privilege Escalation

The vulnerability of the WebSocket module in Node.js operating systems on FortiOS and FortiProxy proxy servers relates to bypassing the authentication process by using an alternative path or channel. Exploiting this vulnerability allows a malicious actor to elevate their privileges to “super-admi...

10CVSS8.7AI score0.9435EPSS
SaveExploits11References3Affected Software2
CBLMariner
CBLMariner
•added 2025/01/12 9:15 a.m.•48 views

CVE-2022-4904 affecting package nodejs 14.21.3-1

CVE-2022-4904 affecting package nodejs 14.21.3-1. No patch is available currently...

8.6CVSS7.5AI score0.01222EPSS
SaveExploits1
Wolfi
Wolfi
•added 2025/01/09 1:15 a.m.•240 views

CVE-2024-27980 vulnerabilities

Vulnerabilities for packages: nodejs...

8.1CVSS7.7AI score0.01402EPSS
SaveExploits0
Chainguard
Chainguard
•added 2025/01/09 1:15 a.m.•93 views

CVE-2024-27980 vulnerabilities

Vulnerabilities for packages: nodejs...

8.1CVSS7.7AI score0.01402EPSS
SaveExploits0
UbuntuCve
UbuntuCve
•added 2025/01/09 1:15 a.m.•48 views

CVE-2024-27980

Due to the improper handling of batch files in childprocess.spawn / childprocess.spawnSync, a malicious command line argument can inject arbitrary commands and achieve code execution even if the shell option is not enabled...

8.1CVSS8.1AI score0.01402EPSS
SaveExploits0References2
Amazon
Amazon
•added 2025/01/09 12:00 a.m.•20 views

Medium: nodejs

Issue Overview: Versions of the package cross-spawn before 7.0.5 are vulnerable to Regular Expression Denial of Service ReDoS due to improper input sanitization. An attacker can increase the CPU usage and crash the program by crafting a very large and well crafted string. CVE-2024-21538 Affected...

8.7CVSS6.6AI score0.00868EPSS
SaveExploits0
Amazon
Amazon
•added 2025/01/09 12:00 a.m.•13 views

Medium: nodejs

Issue Overview: Versions of the package cross-spawn before 7.0.5 are vulnerable to Regular Expression Denial of Service ReDoS due to improper input sanitization. An attacker can increase the CPU usage and crash the program by crafting a very large and well crafted string. CVE-2024-21538 Affected...

8.7CVSS6.6AI score0.00868EPSS
SaveExploits0
Github Security Blog
Github Security Blog
•added 2024/12/27 7:23 a.m.•3 views

Malware in binance-toolbox-nodejs

Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be rotated immediately from a different computer. The package should be removed, but as full control of the computer may have been given to an outsid...

5.8AI score
SaveExploits0References1Affected Software1
CVE
CVE
•added 2024/12/26 9:52 p.m.•99 views

CVE-2024-55950

Tabby (formerly Terminus) prior to version 1.0.216 is affected by a vulnerability caused by overly permissive entitlements that enable dangerous capabilities (camera, microphone, and access to personal folders) through Apple Events, plus entitlements that can permit code injection. The root cause...

8.6CVSS6AI score0.00306EPSS
SaveExploits0References2
BDU FSTEC
BDU FSTEC
•added 2024/12/25 12:00 a.m.•16 views

Node.js Cross-Spawn DoS

The vulnerability of the Node.js software platform’s cross-spawn package, related to the use of a regular expression with inefficient computational complexity. Exploiting this vulnerability can allow a remote attacker to cause service interruptions...

7.8CVSS6.9AI score0.00868EPSS
SaveExploits0References10Affected Software6
Rows per page
Query Builder