5840 matches found
Linux Distros Unpatched Vulnerability : CVE-2016-10539
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - negotiator is an HTTP content negotiator for Node.js and is used by many modules and frameworks including Express and Koa. The header for Accept-Language, when...
Linux Distros Unpatched Vulnerability : CVE-2017-11499
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Node.js v4.0 through v4.8.3, all versions of v5.x, v6.0 through v6.11.0, v7.0 through v7.10.0, and v8.0 through v8.1.3 was susceptible to hash flooding remote D...
Linux Distros Unpatched Vulnerability : CVE-2025-47153
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Certain build processes for libuv and Node.js for 32-bit systems, such as for the nodejs binary package through nodejs20.19.0+dfsg-2i386.deb for Debian GNU/Linu...
Linux Distros Unpatched Vulnerability : CVE-2021-33587
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - The css-what package 4.0.0 through 5.0.0 for Node.js does not ensure that attribute parsing has Linear Time Complexity relative to the size of the input...
Linux Distros Unpatched Vulnerability : CVE-2017-18869
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - A TOCTOU issue in the chownr package before 1.1.0 for Node.js 10.10 could allow a local attacker to trick it into descending into unintended directories via...
Medium: nodejs22
Issue Overview: There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns available. This could lead to a memory corruption issue. We recommend upgrading to version 3.50.2 or above. CVE-2025-6965 Affected Packages: nodejs2...
Linux Distros Unpatched Vulnerability : CVE-2019-14939
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - An issue was discovered in the mysql aka mysqljs module 2.17.1 for Node.js. The LOAD DATA LOCAL INFILE option is open by default. CVE-2019-14939 Note that Nessu...
Linux Distros Unpatched Vulnerability : CVE-2020-13822
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - The Elliptic package 6.5.2 for Node.js allows ECDSA signature malleability via variations in encoding, leading '\0' bytes, or integer overflows. This could...
Linux Distros Unpatched Vulnerability : CVE-2021-22930
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change...
Linux Distros Unpatched Vulnerability : CVE-2021-44533
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Node.js 12.22.9, 14.18.3, 16.13.2, and 17.3.1 did not handle multi-value Relative Distinguished Names correctly. Attackers could craft certificate subjects...
Malicious code in nodejs-prettier-plugin-markdown-terraforming-websockets (npm)
The package nodejs-prettier-plugin-markdown-terraforming-websockets was found to contain malicious code...
Malicious code in procyon-jasmine-nodejs-darkenergy (npm)
The package procyon-jasmine-nodejs-darkenergy was found to contain malicious code...
MAL-2025-37501 Malicious code in udplogger (npm)
The package udplogger was found to contain malicious code...
MAL-2025-34547 Malicious code in taphonomy-graphql-nodejs-isostasy (npm)
The package taphonomy-graphql-nodejs-isostasy was found to contain malicious code...
MAL-2025-27524 Malicious code in nightwatch-nodejs-run-script-castor (npm)
The package nightwatch-nodejs-run-script-castor was found to contain malicious code...
Malicious code in taphonomy-graphql-nodejs-isostasy (npm)
The package taphonomy-graphql-nodejs-isostasy was found to contain malicious code...
MAL-2025-12773 Malicious code in @zalastax/nolb-nodejs_ (npm)
The package @zalastax/nolb-nodejs was found to contain malicious code...
MAL-2025-12779 Malicious code in @zalastax/nolb-nodejsw (npm)
The package @zalastax/nolb-nodejsw was found to contain malicious code...