Lucene search
+L

13237 matches found

NVD
NVD
•added 2022/06/18 9:15 p.m.•21 views

CVE-2022-33987

The got package before 12.1.0 also fixed in 11.8.5 for Node.js allows a redirect to a UNIX socket...

5.3CVSS0.02416EPSS
SaveExploits0References3
UbuntuCve
UbuntuCve
•added 2022/06/18 9:15 p.m.•187 views

CVE-2022-33987

The got package before 12.1.0 also fixed in 11.8.5 for Node.js allows a redirect to a UNIX socket...

5.3CVSS6.8AI score0.02416EPSS
SaveExploits0References3
Prion
Prion
•added 2022/06/18 9:15 p.m.•34 views

Design/Logic Flaw

The got package before 12.1.0 also fixed in 11.8.5 for Node.js allows a redirect to a UNIX socket...

5CVSS6.2AI score0.02416EPSS
SaveExploits0References3Affected Software1
osv_cve
osv_cve
•added 2022/06/18 8:51 p.m.•31 views

CVE-2022-33987

The got package before 12.1.0 also fixed in 11.8.5 for Node.js allows a redirect to a UNIX socket...

5.2AI score0.02416EPSS
SaveExploits0References5
CVE
CVE
•added 2022/06/18 8:51 p.m.•474 views

CVE-2022-33987

CVE-2022-33987 affects the Node.js got package. The vulnerability allows a redirect to a UNIX socket due to how redirects are handled. IBM/related advisories confirm the issue and that fixes are in got v12.1.0 and v11.8.5. Remediation: upgrade to 12.1.0+ (or 11.8.5+). Base scoring shown as MEDIUM...

5.3CVSS6.1AI score0.02416EPSS
SaveExploits0References3Affected Software1
Debian CVE
Debian CVE
•added 2022/06/18 8:51 p.m.•69 views

CVE-2022-33987

The got package before 12.1.0 also fixed in 11.8.5 for Node.js allows a redirect to a UNIX socket...

5.3CVSS6.4AI score0.02416EPSS
SaveExploits0
Cvelist
Cvelist
•added 2022/06/18 8:51 p.m.•36 views

CVE-2022-33987

The got package before 12.1.0 also fixed in 11.8.5 for Node.js allows a redirect to a UNIX socket...

6.6AI score0.02416EPSS
SaveExploits0References3
Mend
Mend
•added 2022/06/18 8:51 p.m.•7 views

CVE-2022-33987

The got package before 12.1.0 also fixed in 11.8.5 for Node.js allows a redirect to a UNIX socket...

6.9CVSS0.02416EPSS
SaveExploits0References10
AlpineLinux
AlpineLinux
•added 2022/06/18 8:51 p.m.•29 views

CVE-2022-33987

The got package before 12.1.0 also fixed in 11.8.5 for Node.js allows a redirect to a UNIX socket...

5.3CVSS6.7AI score0.02416EPSS
SaveExploits0References3
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2022/06/18 12:00 a.m.•6 views

CVE-2022-33987: Undefined Security Weakness

The got package before 12.1.0 also fixed in 11.8.5 for Node.js allows a redirect to a UNIX socket...

5.3CVSS6.8AI score0.02416EPSS
SaveExploits0References1
Prion
Prion
•added 2022/06/17 7:15 p.m.•40 views

Authentication flaw

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 4.10.11 and 5.2.2, the certificate in the Parse Server Apple Game Center auth adapter not validated. As a result, authentication could potentially be bypassed by making a fake...

5CVSS7.1AI score0.00902EPSS
SaveExploits0References4Affected Software1
Cvelist
Cvelist
•added 2022/06/17 6:15 p.m.•65 views

CVE-2022-31083 Authentication bypass in Parse Server Apple Game Center auth adapter

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 4.10.11 and 5.2.2, the certificate in the Parse Server Apple Game Center auth adapter not validated. As a result, authentication could potentially be bypassed by making a fake...

8.6CVSS8.4AI score0.00902EPSS
SaveExploits0References4
CNNVD
CNNVD
•added 2022/06/17 12:00 a.m.•20 views

npm pg-native code issue vulnerabilities

npm pg-native is a high-performance native binding between node.js and PostgreSQL from US-based npm, using a simple API via libpq. A code issue vulnerability exists in pg-native that stems from the plugin's susceptibility to a denial of service DoS when it attempts to convert the second parameter...

7.5CVSS7.4AI score0.01399EPSS
SaveExploits1References3
vulnersOsv
vulnersOsv
•added 2022/06/16 11:14 p.m.•10 views

@ascua/electron (0.0.227), @finsemble/finsemble-electron-adapter (>=1.0.0-beta-1, <=7.3.11) +5 more potentially affected by CVE-2022-29247 via electron (>=17.0.0, <=17.1.2)

electron NPM version =17.0.0, =1.0.0-beta-1, =0.29.10, =0.18.16, =2.0.69, =3.14.5, =6.2.5 Source cves: CVE-2022-29247 Source advisory: OSV:GHSA-MQ8J-3H7H-P8G7...

9.8CVSS8.6AI score0.01089EPSS
SaveExploits0
IBM Security Bulletins
IBM Security Bulletins
•added 2022/06/13 5:09 p.m.•41 views

Security Bulletin: IBM Sterling Control Center is vulnerable to server-side request forgery due to Node.js axios module (CVE-2020-28168)

Summary Node.js axios module is used by IBM Sterling Control Center. A server-side request forgery vulnerability in Node.js axios module has been addressed. Vulnerability Details CVEID: CVE-2020-28168 DESCRIPTION: Node.js axios module is vulnerable to server-side request forgery, caused by improp...

5.9CVSS1.1AI score0.02359EPSS
SaveExploits1Affected Software1
Hacker One
Hacker One
•added 2022/06/13 3:07 p.m.•64 views

Internet Bug Bounty: Undici ProxyAgent vulnerable to MITM

Full GitHub advisory summarizing the issue is here: https://github.com/nodejs/undici/security/advisories/GHSA-pgw7-wx7w-2w33 The original Node.js HackerOne report is here: https://hackerone.com/bugs?reportid=1583680 This was fixed & disclosed in Undici v5.5.1. This primarily affects Undici, a...

6.7AI score
SaveExploits0
NVD
NVD
•added 2022/06/13 2:15 p.m.•21 views

CVE-2022-29244

npm pack ignores root-level .gitignore and .npmignore file exclusion directives when run in a workspace or with a workspace flag ie. --workspaces, --workspace=. Anyone who has run npm pack or npm publish inside a workspace, as of v7.9.0 and v7.13.0 respectively, may be affected and have published...

7.5CVSS0.04004EPSS
SaveExploits0References10
AlpineLinux
AlpineLinux
•added 2022/06/13 2:15 p.m.•55 views

CVE-2022-29244

npm pack ignores root-level .gitignore and .npmignore file exclusion directives when run in a workspace or with a workspace flag ie. --workspaces, --workspace=. Anyone who has run npm pack or npm publish inside a workspace, as of v7.9.0 and v7.13.0 respectively, may be affected and have published...

7.5CVSS3.7AI score0.04004EPSS
SaveExploits0
Prion
Prion
•added 2022/06/13 2:15 p.m.•35 views

Code injection

npm pack ignores root-level .gitignore and .npmignore file exclusion directives when run in a workspace or with a workspace flag ie. --workspaces, --workspace=. Anyone who has run npm pack or npm publish inside a workspace, as of v7.9.0 and v7.13.0 respectively, may be affected and have published...

5CVSS7.3AI score0.04004EPSS
SaveExploits0References10Affected Software1
UbuntuCve
UbuntuCve
•added 2022/06/13 2:15 p.m.•42 views

CVE-2022-29244

npm pack ignores root-level .gitignore and .npmignore file exclusion directives when run in a workspace or with a workspace flag ie. --workspaces, --workspace=. Anyone who has run npm pack or npm publish inside a workspace, as of v7.9.0 and v7.13.0 respectively, may be affected and have published...

7.5CVSS6.8AI score0.04004EPSS
SaveExploits0References10
Rows per page
Query Builder