13025 matches found
CVE-2023-49803: Origin Validation Error
@koa/cors npm provides Cross-Origin Resource Sharing CORS for koa, a web framework for Node.js. Prior to version 5.0.0, the middleware operates in a way that if an allowed origin is not provided, it will return an Access-Control-Allow-Origin header with the value of the origin from the request...
EverShop Security Breach
EverShop is EverShop open source a NodeJS e-commerce platform. A security vulnerability exists in EverShop versions prior to 1.0.0-rc.5 that stems from the presence of a Reflective Cross-Site Scripting XSS vulnerability, which allows attackers to inject malicious code into the application's admin...
[SECURITY] Fedora 39 Update: llhttp-9.1.3-1.fc39
This project is a port of httpparser to TypeScript. llparse is used to generate the output C source file, which could be compiled and linked with the embedder's program like Node.js...
[SECURITY] Fedora 38 Update: llhttp-9.1.3-1.fc38
This project is a port of httpparser to TypeScript. llparse is used to generate the output C source file, which could be compiled and linked with the embedder's program like Node.js...
Fedora: Security Advisory for llhttp (FEDORA-2023-bc1f081ca0)
The remote host is missing an update for the SPDX-FileCopyrightText: 2023 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
Security Bulletin: Mutiple Vulnerabilties in Open Source packages affects IBM Watson Machine Learning Accelerator on Cloud Pak for Data
Summary IBM Watson Machine Learning Accelerator on Cloud Pak for Data component GUI, Notebook and Logstash are vulenrable to multiple vunerabilites. These are fixed. Vulnerability Details CVEID:CVE-2022-25857 DESCRIPTION: Java package org.yaml:snakeyam is vulnerable to a denial of service, caused...
Security Bulletin: IBM Cloud Transformation Advisor is vulnerable to multiple vulnerabilities
Summary IBM Cloud Transformation Advisor has addressed multiple Java and Node.js security vulnerabilities listed herein. Vulnerability Details CVEID:CVE-2023-22045 DESCRIPTION: An unspecified vulnerability in Java SE related to the VM component could allow a remote attacker to cause low...
CVE-2023-6460
A potential logging of the firestore key via logging within nodejs-firestore exists - Developers who were logging objects through this.settings would be logging the firestore key as well potentially exposing it to anyone with logs read access. We recommend upgrading to version 6.1.0 to avoid this...
@deploysentinel/playwright-watch (>=0.1.0, <=0.2.2), @finsemble/finsemble-core (>=1.0.0-beta-9, <=8.7.0) +9 more potentially affected by CVE-2023-44402 via electron (>=22.0.0, <=22.3.13)
electron NPM version =22.0.0, =0.1.0, =1.0.0-beta-9, =1.0.0-beta-9, =9.13.1, =60.0.0-pre1, =0.0.1-alpha.2022-12-11.1670718306317, =1.3.0, =0.0.87, =2.0.92, =2.0.98 Source cves: CVE-2023-44402 Source advisory: OSV:GHSA-7M48-WC93-9G85...
@dweb-browser/desktop (0.1.2), @dweb-browser/js-process (0.1.2) +27 more potentially affected by CVE-2023-44402 via electron (>=25.0.0-beta.1, <=25.8.0)
electron NPM version =25.0.0-beta.1, =1.0.0, =1.0.0, =0.6.0, =0.0.22, =0.0.93, =0.0.95 - firedev 16.444.5 - firedev-class-helpers 16.444.4 - firedev-config 16.444.4 - firedev-core 16.444.5 - firedev-logger 16.444.4 - firedev-rest 16.444.3 - firedev-storage 16.444.4 and more Source cves:...
Node.js: Node.js is vulnerable to the Marvin Attack (timing variant of the Bleichenbacher attack against PKCS#1 v1.5 padding)
A timing side-channel vulnerability in the crypto library's privateDecrypt API allowed attackers to remotely exploit and decrypt or forge signatures when processing encrypted messages...
Path Traversal
nodejs-current is vulnerable to Path Traversal. The vulnerability occurs due to the implementation not adequately protecting itself against applications overwriting built-in utility functions with user-defined implementations resulting in malicious attackers to gain unauthorized access to sensiti...
Path Traversal
nodejs-current is vulnerable to Path Traversal. The vulnerability is due to there is no proper neutralization for special elements within the pathname that specifically within the handling of file system paths by various node:fs functions. This vulnerability is the result of the way Node.js handl...
Security Bulletin: IBM Event Streams is affected by a vulnerability in Node.js (CVE-2023-32006)
Summary This security vulnerability affects a required node.js module within IBM Event Streams UI component. CVE-2023-32006 Vulnerability Details CVEID:CVE-2023-32006 DESCRIPTION: Node.js could allow a remote attacker to bypass security restrictions, caused by the use of...
Security Bulletin: IBM Event Streams is affected by a vulnerability in Node.js (CVE-2023-32559)
Summary This security vulnerability affects a required node.js module within IBM Event Streams UI component. CVE-2023-32559 Vulnerability Details CVEID:CVE-2023-32559 DESCRIPTION: Node.js could allow a remote attacker to bypass security restrictions, caused by the use of the deprecated API...
Security Bulletin: IBM Event Streams is affected by a vulnerability in Node.js (CVE-2023-25883)
Summary This security vulnerability affects a required node.js module within IBM Event Streams UI component. CVE-2023-25883 Vulnerability Details CVEID:CVE-2022-25883 DESCRIPTION: Node.js semver package is vulnerable to a denial of service, caused by a regular expression denial of service ReDoS...
Security Bulletin: IBM Event Streams is affected by a vulnerability in Node.js Module._load() module (CVE-2023-32002)
Summary This security vulnerability affects a required node.js module within IBM Event Streams UI component. CVE-2023-32002 Vulnerability Details CVEID:CVE-2023-32002 DESCRIPTION: Node.js could allow a remote attacker to bypass security restrictions, caused by the use of Module.load. By sending a...
Cross Site Scripting (XSS)
nodejs is vulnerable to Cross Site Scripting XSS. The vulnerability exists because maliciously crafted export names in an imported WebAssembly module can inject JavaScript code. The injected code may be able to access data and functions that the WebAssembly module itself does not have access to,...
Security Bulletin: IBM InfoSphere Information Server is affected by multiple vulnerabilities in Node.js lodash module
Summary Multiple vulnerabilities in Node.js lodash module used by IBM InfoSphere Information Server were addressed. Vulnerability Details CVEID:CVE-2020-28500 DESCRIPTION: Node.js lodash module is vulnerable to a denial of service, caused by a regular expression denial of service ReDoS in the...
Security Bulletin: IBM InfoSphere Information Server is affected by a vulnerability in Node.js semver (CVE-2022-25883)
Summary A vulnerability in Node.js semver used by IBM InfoSphere Information Server was addressed. Vulnerability Details CVEID:CVE-2022-25883 DESCRIPTION: Node.js semver package is vulnerable to a denial of service, caused by a regular expression denial of service ReDoS flaw in the new Range...