Lucene search
+L

1824 matches found

The Hacker News
The Hacker News
•added 2025/03/24 9:17 a.m.•47 views

Critical Next.js Vulnerability Allows Attackers to Bypass Middleware Authorization Checks

A critical security flaw has been disclosed in the Next.js React framework that could be potentially exploited to bypass authorization checks under certain conditions. The vulnerability, tracked as CVE-2025-29927 , carries a CVSS score of 9.1 out of 10.0. "Next.js uses an internal header...

9.1CVSS7.2AI score0.99225EPSS
SaveExploits63
Akamai Blog
Akamai Blog
•added 2025/03/24 8:00 a.m.•18 views

Detecting and Mitigating an Authorization Bypass Vulnerability in Next.js

...

7.3AI score
SaveExploits0
Tenable Nessus
Tenable Nessus
•added 2025/03/24 12:00 a.m.•17 views

Next.js 15.x < 15.2.3 Authorization Bypass

The version of Next.js installed on the remote host is 11.1.4 prior to 12.3.5, 13.0.x prior to 13.5.9, 14.x prior to 14.2.25 or 15.x prior to 15.2.3. It is, therefore, affected by Authorization Bypass if the authorization check occurs in middleware. Note that the scanner has not attempted to...

9.1CVSS7.5AI score0.99225EPSS
SaveExploits63References3
Tenable Nessus
Tenable Nessus
•added 2025/03/24 12:00 a.m.•31 views

Next.js 14.x < 14.2.25 Authorization Bypass

The version of Next.js installed on the remote host is 11.1.4 prior to 12.3.5, 13.0.x prior to 13.5.9, 14.x prior to 14.2.25 or 15.x prior to 15.2.3. It is, therefore, affected by Authorization Bypass if the authorization check occurs in middleware. Note that the scanner has not attempted to...

9.1CVSS7.5AI score0.99225EPSS
SaveExploits63References3
Tenable Nessus
Tenable Nessus
•added 2025/03/24 12:00 a.m.•23 views

Next.js 13.0.x < 13.5.9 Authorization Bypass

The version of Next.js installed on the remote host is 11.1.4 prior to 12.3.5, 13.0.x prior to 13.5.9, 14.x prior to 14.2.25 or 15.x prior to 15.2.3. It is, therefore, affected by Authorization Bypass if the authorization check occurs in middleware. Note that the scanner has not attempted to...

9.1CVSS7.5AI score0.99225EPSS
SaveExploits63References3
GithubExploit
GithubExploit
•added 2025/03/23 7:41 p.m.•261 views

Exploit for CVE-2025-29927

CVE-2025-29927-PoC-Exploit Proof-of-Concept for Authorization...

9.1CVSS7.9AI score0.99225EPSS
SaveExploits63
GithubExploit
GithubExploit
•added 2025/03/23 7:41 p.m.•229 views

Exploit for CVE-2025-29927

CVE-2025-29927-PoC-Exploit Proof-of-Concept for Authorization...

9.1CVSS7.9AI score0.99225EPSS
SaveExploits63
GithubExploit
GithubExploit
•added 2025/03/23 4:04 p.m.•157 views

Exploit for CVE-2025-29927

Scanner de Vulnerabilidade Middleware Subrequest do Next.js U...

9.1CVSS7.9AI score0.99225EPSS
SaveExploits63
RedhatCVE
RedhatCVE
•added 2025/03/23 3:20 p.m.•72 views

CVE-2025-29927

A flaw was found in Next.js package. This vulnerability allows bypassing authorization checks within a Next.js application if the authorization check occurs in middleware. Mitigation Block or drop external user requests which contain the x-middleware-subrequest header from reaching your Next.js...

9.1CVSS7.3AI score0.99225EPSS
SaveExploits63References5
GithubExploit
GithubExploit
•added 2025/03/23 8:37 a.m.•510 views

Exploit for CVE-2025-29927

Next.js POC for CVE-2025-29927 - Authorization Bypass in Ne...

9.1CVSS7.9AI score0.99225EPSS
SaveExploits63
GithubExploit
GithubExploit
•added 2025/03/23 8:11 a.m.•112 views

Exploit for CVE-2025-29927

nextjs-CVE-2025-29927 A Nuclei template to detect CVE-2025-299...

9.1CVSS7.8AI score0.99225EPSS
SaveExploits63
GithubExploit
GithubExploit
•added 2025/03/22 6:42 p.m.•129 views

Exploit for CVE-2025-29927

CVE-2025-29927 Next.js Middleware Authorization Bypass T...

9.1CVSS7.7AI score0.99225EPSS
SaveExploits63
Github Security Blog
Github Security Blog
•added 2025/03/21 3:20 p.m.•145 views

Authorization Bypass in Next.js Middleware

Impact It is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. Patches For Next.js 15.x, this issue is fixed in 15.2.3 For Next.js 14.x, this issue is fixed in 14.2.25 For Next.js 13.x, this issue is fixed in 13.5.9 For Next.js...

9.1CVSS7.5AI score0.99225EPSS
SaveExploits63References11Affected Software1
NVD
NVD
•added 2025/03/21 3:15 p.m.•44 views

CVE-2025-29927

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to ...

9.1CVSS0.99225EPSS
SaveExploits63References8
Cvelist
Cvelist
•added 2025/03/21 2:34 p.m.•56 views

CVE-2025-29927 Authorization Bypass in Next.js Middleware

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to ...

9.1CVSS0.99225EPSS
SaveExploits63References5
Mend
Mend
•added 2025/03/21 2:34 p.m.•11 views

CVE-2025-29927

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to ...

9.3CVSS7.3AI score0.99225EPSS
SaveExploits63References14
osv_cve
osv_cve
•added 2025/03/21 2:34 p.m.•23 views

CVE-2025-29927 Authorization Bypass in Next.js Middleware

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to ...

9.1CVSS7.3AI score0.99225EPSS
SaveExploits63References10
Vulnrichment
Vulnrichment
•added 2025/03/21 2:34 p.m.•40 views

CVE-2025-29927 Authorization Bypass in Next.js Middleware

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to ...

9.1CVSS7.3AI score0.99225EPSS
SaveExploits63References5
CVE
CVE
•added 2025/03/21 2:34 p.m.•944 views

CVE-2025-29927

CVE‑2025‑29927 affects Next.js before patches: versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3. The issue is an authorization bypass that can occur if the check runs in middleware. Fixed in the specified versions; patching to a safe version is recommended. If patching is infeasible, block external r...

9.1CVSS7.3AI score0.99225EPSS
SaveIn wildExploits63References8Affected Software1
Positive Technologies
Positive Technologies
•added 2025/03/21 12:00 a.m.•13 views

PT-2025-12427

Name of the Vulnerable Software and Affected Versions Next.js versions 1.11.4 through 12.3.4 Next.js versions 13.x through 13.5.8 Next.js versions 14.x through 14.2.24 Next.js versions 15.x through 15.2.2 Description An authorization bypass exists in the Next.js framework due to the improper...

9.1CVSS7.3AI score0.99225EPSS
SaveExploits63
Rows per page
Query Builder