1517 matches found
Amazon Linux 2 : libndp (ALAS-2024-2571)
The version of libndp installed on the remote host is prior to 1.2-7. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2024-2571 advisory. A vulnerability was found in libndp. A buffer overflow in NetworkManager that can be triggered by sending a malformed IPv6 router...
GLib: Privilege Escalation
Background GLib is a library providing a number of GNOME's core objects and functions. Description A vulnerability has been discovered in GLib. Please review the CVE identifier referenced below for details. Impact When a GDBus-based client subscribes to signals from a trusted system service such ...
MGASA-2024-0225 Updated libndp packages fix security vulnerabilities
A vulnerability was found in libndp. This flaw allows a local malicious user to cause a buffer overflow in NetworkManager, triggered by sending a malformed IPv6 router advertisement packet. This issue occurred as libndp was not correctly validating the route length information...
Updated libndp packages fix security vulnerabilities
A vulnerability was found in libndp. This flaw allows a local malicious user to cause a buffer overflow in NetworkManager, triggered by sending a malformed IPv6 router advertisement packet. This issue occurred as libndp was not correctly validating the route length information...
OPENSUSE-SU-2024:10603-1 NetworkManager-applet-1.24.0-1.2 on GA media
These are all security issues fixed in the NetworkManager-applet-1.24.0-1.2 package on the GA media of openSUSE Tumbleweed...
OPENSUSE-SU-2024:10604-1 NetworkManager-vpnc-1.2.6-4.1 on GA media
These are all security issues fixed in the NetworkManager-vpnc-1.2.6-4.1 package on the GA media of openSUSE Tumbleweed...
OPENSUSE-SU-2024:10152-1 NetworkManager-1.4.2-1.2 on GA media
These are all security issues fixed in the NetworkManager-1.4.2-1.2 package on the GA media of openSUSE Tumbleweed...
OPENSUSE-SU-2024:10602-1 NetworkManager-1.32.10-2.1 on GA media
These are all security issues fixed in the NetworkManager-1.32.10-2.1 package on the GA media of openSUSE Tumbleweed...
NetworkManager-libreswan bug fix update
An update is available for NetworkManager-libreswan. This update affects Rocky Linux 9. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list This package contains software for integrating the libreswan...
USN-6830-1 libndp vulnerability
It was discovered that libndp incorrectly handled certain malformed IPv6 router advertisement packets. A local attacker could use this issue to cause NetworkManager to crash, resulting in a denial of service, or possibly execute arbitrary code...
USN-6830-1: libndp vulnerability
It was discovered that libndp incorrectly handled certain malformed IPv6 router advertisement packets. A local attacker could use this issue to cause NetworkManager to crash, resulting in a denial of service, or possibly execute arbitrary code...
Ubuntu 20.04 LTS / 22.04 LTS / 23.10 / 24.04 LTS : libndp vulnerability (USN-6830-1)
The remote Ubuntu 20.04 LTS / 22.04 LTS / 23.10 / 24.04 LTS host has packages installed that are affected by a vulnerability as referenced in the USN-6830-1 advisory. It was discovered that libndp incorrectly handled certain malformed IPv6 router advertisement packets. A local attacker could use...
NetworkManager Glib DoS
The vulnerability of the NetworkManager service in the Glib library is related to improper checking of the connection source. Exploiting this vulnerability can allow a malicious actor to cause a service failure...
libndp >= 1.0 Buffer Overflow
A vulnerability was found in libndp. This flaw allows a local malicious user to cause a buffer overflow in NetworkManager, triggered by sending a malformed IPv6 router advertisement packet. This issue occurred as libndp was not correctly validating the route length information. Note that Nessus h...
RHEL 6 : networkmanager (Unpatched Vulnerability)
The remote Redhat Enterprise Linux 6 host has one or more packages installed that are affected by multiple vulnerabilities that have been acknowledged by the vendor but will not be patched. - NetworkManager: creating new WPA-secured wireless network results in insecure network being created inste...
RHEL 5 : networkmanager (Unpatched Vulnerability)
The remote Redhat Enterprise Linux 5 host has one or more packages installed that are affected by a vulnerability that has been acknowledged by the vendor but will not be patched. - NetworkManager: creating new WPA-secured wireless network results in insecure network being created instead...
RHEL 4 : wpa_supplicant (Unpatched Vulnerability)
The remote Redhat Enterprise Linux 4 host has one or more packages installed that are affected by a vulnerability that has been acknowledged by the vendor but will not be patched. - NetworkManager, wpasupplicant: Improper x509v3 certificate and key file paths sanitization CVE-2012-1096 Note that...
RHEL 6 : wpa_supplicant (Unpatched Vulnerability)
The remote Redhat Enterprise Linux 6 host has one or more packages installed that are affected by multiple vulnerabilities that have been acknowledged by the vendor but will not be patched. - NetworkManager, wpasupplicant: Improper x509v3 certificate and key file paths sanitization CVE-2012-1096 ...
RHEL 5 : wpa_supplicant (Unpatched Vulnerability)
The remote Redhat Enterprise Linux 5 host has one or more packages installed that are affected by multiple vulnerabilities that have been acknowledged by the vendor but will not be patched. - wpasupplicant: local configuration update allows privilege escalation CVE-2016-4477 - wpasupplicant:...
CVE-2024-5564
A vulnerability was found in libndp. This flaw allows a local malicious user to cause a buffer overflow in NetworkManager, triggered by sending a malformed IPv6 router advertisement packet. This issue occurred as libndp was not correctly validating the route length information...