646 matches found
LLM-Based Dynamic Differential Testing for Database Connectors with Reinforcement Learning-Guided Prompt Selection
Database connectors are critical components enabling applications to interact with underlying database management systems DBMS, yet their security vulnerabilities often remain overlooked. Unlike traditional software defects, connector vulnerabilities exhibit subtle behavioral patterns and are...
CVE-2022-39944
In Apache Linkis =1.2.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures a JDBC EC with a MySQL data source and malicious parameters. Therefore, the parameters in...
CVE-2022-44644
In Apache Linkis =1.3.0 when used with the MySQL Connector/J in the data source module, an authenticated attacker could read arbitrary local files by connecting a rogue MySQL server, By adding allowLoadLocalInfile to true in the JDBC parameter. Therefore, the parameters in the JDBC URL should be...
OPENSUSE-SU-2025:15026-1 mysql-connector-java-9.3.0-1.1 on GA media
These are all security issues fixed in the mysql-connector-java-9.3.0-1.1 package on the GA media of openSUSE Tumbleweed...
UBUNTU-CVE-2025-30714
Vulnerability in the MySQL Connectors product of Oracle MySQL component: Connector/Python. Supported versions that are affected are 9.0.0-9.2.0. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successful...
CVE-2025-30706
Vulnerability in the MySQL Connectors product of Oracle MySQL component: Connector/J. Supported versions that are affected are 9.0.0-9.2.0. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successful attac...
be.ugent.idlab.knows:dataio (>=2.0.0, <=2.1.4), br.com.consultdg:database-module (>=1.0.1, <=1.0.10) +819 more potentially affected by CVE-2025-30706 via com.mysql:mysql-connector-j (>=9.0.0, <=9.2.0)
com.mysql:mysql-connector-j MAVEN version =9.0.0, =2.0.0, =1.0.1, =8.0.0, =2.4.1, =2.4.1, =0.0.12, =3.3.1.3, =3.3.1.3, =3.3.1.3, =3.3.1.3, =3.3.1.3, =3.3.1.3, =3.3.1.3, =3.3.1.3, =3.4.5.0 and more Source cves: CVE-2025-30706 Source advisory: SNYK:JAVA-COMMYSQL-9725315...
Incorrect Default Permissions
Overview Affected versions of this package are vulnerable to Incorrect Default Permissions. An attacker could achieve remote code execution and compromise MySQL Connectors by exploiting this vulnerability. Remediation Upgrade com.mysql:mysql-connector-j to version 9.3.0 or higher. References -...
CVE-2025-30714
Vulnerability in the MySQL Connectors product of Oracle MySQL component: Connector/Python. Supported versions that are affected are 9.0.0-9.2.0. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successful...
adstoolbox (>=1.0.29, <=2025.9.5), afw (>=0.0.6, <=0.0.21) +42 more potentially affected by CVE-2025-30714 via mysql-connector-python (>=9.0.0, <=9.2.0)
mysql-connector-python PYPI version =9.0.0, =1.0.29, =0.0.6, =1.7.0, =1.0.6, =0.5.0, =0.2.1, =1.0.1, =0.1.20, =1.107.2rc3, =0.1.0, =0.8.0, =1.0.3, =0.1.0.dev431, =1.2.3 and more Source cves: CVE-2025-30714 Source advisory: SNYK:PYTHON-MYSQLCONNECTORPYTHON-9724724...
Linux Distros Unpatched Vulnerability : CVE-2017-3589
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Vulnerability in the MySQL Connectors component of Oracle MySQL subcomponent: Connector/J. Supported versions that are affected are 5.1.41 and earlier. Easily...
Linux Distros Unpatched Vulnerability : CVE-2017-3586
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Vulnerability in the MySQL Connectors component of Oracle MySQL subcomponent: Connector/J. Supported versions that are affected are 5.1.41 and earlier. Easily...
openSUSE 15 Security Update : python-mysql-connector-python (openSUSE-SU-2024:0351-1)
The remote openSUSE 15 host has a package installed that is affected by a vulnerability as referenced in the openSUSE- SU-2024:0351-1 advisory. - Update to 9.1.0 boo1231740, CVE-2024-21272 - WL16452: Bundle all installable authentication plugins when building the C-extension - WL16444: Drop build...
Security update for python-mysql-connector-python (important)
openSUSE Security Update: Security update for python-mysql-connector-python Announcement ID: openSUSE-SU-2024:0351-1 Rating: important References: 1231740 Cross-References: CVE-2024-21272 Affected Products: openSUSE Backports SLE-15-SP5 An update that fixes one vulnerability is now available...
santoku (>=200902.10.0, <=201111.17.0) potentially affected by unknown CVE via mysql-connector-python (8.0.5)
mysql-connector-python PYPI version 8.0.5 is affected by a known vulnerability. The following packages have a transitive dependency on mysql-connector-python and may be impacted: - santoku =200902.10.0, =201111.17.0 Source cves: unknown CVE Source advisory: SNYK:PYTHON-MYSQLCONNECTORPYTHON-832093...
SQL Injection
Overview mysql-connector-python is a MySQL driver written in Python which does not depend on MySQL C client libraries and implements the DB API v2.0 specification PEP-249. Affected versions of this package are vulnerable to SQL Injection due to improper sanitization of schema and table names...
Connector/ODBC driver for MySQL
The vulnerability of the Connector/ODBC driver for MySQL Connectors in the Oracle MySQL database management system is related to deficiencies in the authentication process due to incorrect validation of input data. Exploiting this vulnerability can allow an attacker to gain read, modify, or delet...
blackline-mysql (>=0.1.0a0, <=0.1.2), csv-db-loader (1.0.0) +6 more potentially affected by CVE-2024-21272 via mysql-connector-python (8.0.32)
mysql-connector-python PYPI version 8.0.32 is affected by a known vulnerability. The following packages have a transitive dependency on mysql-connector-python and may be impacted: - blackline-mysql =0.1.0a0, =0.0.1, =0.0.1, =0.0.3, =0.80.0, =0.3.8, =0.3.18 Source cves: CVE-2024-21272 Source...
opengamedata-api-utils (>=1.1.0, <=1.1.1), opengamedata-common (>=0.0.1, <=1.2.2) +2 more potentially affected by CVE-2024-21272 via mysql-connector-python (8.0.25)
mysql-connector-python PYPI version 8.0.25 is affected by a known vulnerability. The following packages have a transitive dependency on mysql-connector-python and may be impacted: - opengamedata-api-utils =1.1.0, =0.0.1, =1.0.0.dev782, =1.0.0.dev782, =7.1.2 Source cves: CVE-2024-21272 Source...
allsql (>=0.0.1, <=0.0.5), bribrain (>=1.0.3, <=1.3.6) +5 more potentially affected by CVE-2024-21272 via mysql-connector-python (8.0.28)
mysql-connector-python PYPI version 8.0.28 is affected by a known vulnerability. The following packages have a transitive dependency on mysql-connector-python and may be impacted: - allsql =0.0.1, =1.0.3, =0.3.0, =0.0.6, =1.0.1, =2.0.0rc3, =2.0.5 Source cves: CVE-2024-21272 Source advisory:...