270 matches found
jsoncons:fuzz_msgpack: Heap-buffer-overflow in std::__1::enable_if<std::is_same<std::__1::iterator_traits<unsigned char const*>
Project: https://github.com/danielaparker/jsoncons.git Detailed Report: https://oss-fuzz.com/testcase?key=5065588456882176 Project: jsoncons Fuzzing Engine: libFuzzer Fuzz Target: fuzzmsgpack Job Type: libfuzzerasanjsoncons Platform Id: linux Crash Type: Heap-buffer-overflow READ 1 Crash Address:...
Malicious code in activerecord-msgpack-serializer (RubyGems)
--- Credit: OpenSSF source...
SUSE SLES15 Security Update : python-msgpack (SUSE-SU-2026:3113-1)
The remote SUSE Linux SLES15 / SLESSAP15 host has a package installed that is affected by a vulnerability as referenced in the SUSE-SU-2026:3113-1 advisory. This update for python-msgpack fixes the following issue - CVE-2026-57585: Unpacker reuse after a caught error can lead to an out-of-bounds...
openSUSE 16 Security Update : python-msgpack (openSUSE-SU-2026:21239-1)
The remote openSUSE 16 host has a package installed that is affected by a vulnerability as referenced in the openSUSE- SU-2026:21239-1 advisory. This update for python-msgpack fixes the following issue - CVE-2026-57585: reusing an Unpacker instance after an error has been caught can lead to an...
SUSE-SU-2026:22704-1 Security update for python-msgpack
This update for python-msgpack fixes the following issue - CVE-2026-57585: reusing an Unpacker instance after an error has been caught can lead to an out-of-bounds read bsc1269947...
PYSEC-2026-1944 Litestar allows unbounded resource consumption (DoS vulnerability)
Summary Litestar offers multiple methods to return a parsed representation of the request body, as well as extractors that rely on those parsers to map request content to structured data types. Multiple of those parsers do not have size limits when reading the request body into memory, which allo...
tarantool:msgpack_decode_test: Heap-buffer-overflow in mp_load_float
Project: https://github.com/tarantool/tarantool.git Detailed Report: https://oss-fuzz.com/testcase?key=6102314986045440 Project: tarantool Fuzzing Engine: libFuzzer Fuzz Target: msgpackdecodetest Job Type: libfuzzerasantarantool Platform Id: linux Crash Type: Heap-buffer-overflow WRITE 4 Crash...
allennlp (>=0.2.2, <=0.8.3), auklet (>=0.6.0, <=1.1.0b108) +36 more potentially affected by CVE-2026-57585 via msgpack (0.5.6)
msgpack PYPI version 0.5.6 is affected by a known vulnerability. The following packages have a transitive dependency on msgpack and may be impacted: - allennlp =0.2.2, =0.6.0, =1.3.1, =1.4.0, =1.3.2, =0.1.0, =2.0.0, =0.3.8, =0.0.1, =0.0.90, =0.1.0, =0.1.10, =1.13.0.dev1757972726,...
bktest (>=1.0.0, <=2.0.0), cereal-lazer (>=0.0.3, <=0.1.6) +8 more potentially affected by CVE-2026-57585 via msgpack (0.6.1)
msgpack PYPI version 0.6.1 is affected by a known vulnerability. The following packages have a transitive dependency on msgpack and may be impacted: - bktest =1.0.0, =0.0.3, =0.2.0, =0.0.4, =0.0.2, =3.0.0rc1, =0.0.0, =1.0.6, =0.3.0, =0.4.7 Source cves: CVE-2026-57585 Source advisory:...
AZL-91746 CVE-2026-57585 affecting package python-msgpack for versions less than 1.0.5-3
MessagePack is the serializer implementation for Python msgpack.org. Prior to 1.2.1, there is an Out-of-bounds read/crash on Unpacker reuse after a caught error, potentially leading to a DoS attack. If the Unpacker is used repeatedly after an error occurs, the process may crash with a SEGV. This...
yy-spider (1.0.0) potentially affected by CVE-2026-57585 via msgpack (0.5.0)
msgpack PYPI version 0.5.0 is affected by a known vulnerability. The following packages have a transitive dependency on msgpack and may be impacted: - yy-spider 1.0.0 Source cves: CVE-2026-57585 Source advisory: OSV:PYSEC-2026-3625...
cloudcix (>=0.2.136, <=0.2.144) potentially affected by CVE-2026-57585 via msgpack (0.5.4)
msgpack PYPI version 0.5.4 is affected by a known vulnerability. The following packages have a transitive dependency on msgpack and may be impacted: - cloudcix =0.2.136, =0.2.144 Source cves: CVE-2026-57585 Source advisory: OSV:PYSEC-2026-3625...
acelerai (>=0.0.32, <=0.0.45), acelerai-staging (>=0.0.1, <=0.0.13) +605 more potentially affected by CVE-2026-57585 via msgpack (>=1.0.0rc1, <=1.2.0)
msgpack PYPI version =1.0.0rc1, =0.0.32, =0.0.1, =1.0.0, =0.1.31, =1.1.0, =0.1.1, =0.9.2, =2.6.0, =2.0.0, =2.0.1, =0.4.0, =0.1.0, =0.2.0 and more Source cves: CVE-2026-57585 Source advisory: OSV:PYSEC-2026-3625...
synapse (>=0.0.45, <=0.0.56) potentially affected by CVE-2026-57585 via msgpack (0.5.1)
msgpack PYPI version 0.5.1 is affected by a known vulnerability. The following packages have a transitive dependency on msgpack and may be impacted: - synapse =0.0.45, =0.0.56 Source cves: CVE-2026-57585 Source advisory: OSV:PYSEC-2026-3625...
acapy-mydata-did-protocol (>=0.1.0, <=0.1.15), acapy-patched (>=0.5.6.dev0, <=0.5.6) +116 more potentially affected by CVE-2026-57585 via msgpack (0.6.2)
msgpack PYPI version 0.6.2 is affected by a known vulnerability. The following packages have a transitive dependency on msgpack and may be impacted: - acapy-mydata-did-protocol =0.1.0, =0.5.6.dev0, =0.1.7, =1.0.0, =0.1.3, =2.0.3, =0.1.0, =3.0.0, =0.0.1, =0.3.0, =0.0.0, =18.12.0, =1.4.0, =19.9.27...
electron-rpc (0.0.4), guardata (>=0.0.2, <=0.1.0) +1 more potentially affected by CVE-2026-57585 via msgpack (0.6.0)
msgpack PYPI version 0.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on msgpack and may be impacted: - electron-rpc 0.0.4 - guardata =0.0.2, =1.14.0rc3, =2.6.0 Source cves: CVE-2026-57585 Source advisory: OSV:PYSEC-2026-3625...
aam-annotator (0.1.0), adarnauth-esi (>=1.4.1, <=1.4.14) +322 more potentially affected by CVE-2026-57585 via msgpack-python (>=0.4.2, <=0.5.6)
msgpack-python PYPI version =0.4.2, =1.4.1, =1.0.0, =0.9.1, =1.0.0, =0.0.3, =0.1.2, =2.0.0b2, =0.2.0, =0.1.0, =1.0.0, =0.0.1, =0.2.0 - arxlang 0.2.0 and more Source cves: CVE-2026-57585 Source advisory: MEND:CVE-2026-57585...
acapy-mydata-did-protocol (>=0.1.0, <=0.1.15), acapy-patched (>=0.5.6.dev0, <=0.5.6) +756 more potentially affected by CVE-2026-57585 via msgpack (>=0.5.0, <=1.2.0)
msgpack PYPI version =0.5.0, =0.1.0, =0.5.6.dev0, =0.0.32, =0.0.1, =1.0.0, =0.1.7, =0.1.31, =1.1.0, =1.0.0, =0.1.3, =0.1.1, =0.9.2, =2.0.3, =2.0.5 and more Source cves: CVE-2026-57585 Source advisory: MEND:CVE-2026-57585...
Use After Free
Overview Affected versions of this package are vulnerable to Use After Free in the clear function. An attacker can access or manipulate memory contents from another buffer by triggering the reuse of a memory page after it has been returned to the shared pool, leading to unintended disclosure or...