838 matches found
[SECURITY] Fedora 44 Update: mongo-c-driver-1.30.9-1.fc44
mongo-c-driver is a client library written in C for MongoDB...
[SECURITY] Fedora 43 Update: mongo-c-driver-1.30.9-1.fc43
mongo-c-driver is a client library written in C for MongoDB...
[SECURITY] Fedora 45 Update: mongo-c-driver-2.5.2-1.fc45
mongo-c-driver is a client library written in C for MongoDB...
Fedora 44 : mongo-c-driver (2026-8ed63cce6b)
The remote Fedora 44 host has a package installed that is affected by multiple vulnerabilities as referenced in the FEDORA-2026-8ed63cce6b advisory. libmongoc 1.30.9 Fixes - Fix OCSP error handling. CVE-2026-84964 - Fix unsafe casts during JSON parsing. CVE-2026-84965 - Fix possible unsafe...
CVE-2026-88031
A flaw was found in go.mongodb.org/mongo-driver for version 1.17.10 and 2.9.1. Improper handling of data query elements in the GridFS component can lead to a file identifier being misinterpreted as a query. An authenticated user can exploit this to delete all GridFS file chunks, making stored fil...
Improper Neutralization of Special Elements in Data Query Logic
Overview Affected versions of this package are vulnerable to Improper Neutralization of Special Elements in Data Query Logic via improper neutralization of special elements in the GridFS process. An attacker can access unauthorized file content or delete all file chunks by injecting query operato...
Malicious code in express-mongo-santi (npm)
Source: amazon-inspector 85c97cf70eead9dda2069dc9da7e4a780f7c69953714ad050566c0e94a343e33 The package's main file index.js is a heavily obfuscated bundle obfuscator.io-style rotated string array with base64+RC4 decoders whose only purpose is a remote-fetch-and-execute pipeline that fires when the...
Out-of-bounds Write
Overview Affected versions of this package are vulnerable to Out-of-bounds Write in the BSON-to-JSON conversion process when a binary field is encoded and the output is truncated at a specified length limit. An attacker can alter a small amount of data outside the intended buffer by supplying...
Double Free
Overview Affected versions of this package are vulnerable to Double Free in the OCSP certificate revocation checking process during a TLS handshake with a trusted endpoint. An attacker can cause the client application to terminate unexpectedly by sending specially crafted certificate data that...
Integer Overflow or Wraparound
Overview Affected versions of this package are vulnerable to Integer Overflow or Wraparound via the JSON parsing process. An attacker can cause the application to terminate unexpectedly by supplying a specially crafted large JSON input, leading to memory corruption and potential denial of service...
Malicious code in bangscripts-mongo (npm)
The package bangscripts-mongo was found to contain malicious code. --- Credit: OpenSSF source...
Malware in express-mongo-limit
Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be rotated immediately from a different computer. The package should be removed, but as full control of the computer may have been given to an outsid...
Malicious Package
Overview express-mongo-limit is a malicious package. This package contains malicious code, and its content was removed from the official package manager. While this package might be attempting to impersonate a valid organization, there is no connection between that organization and this package...
GO-2025-3955 vulnerabilities
Vulnerabilities for packages: nri-memcached, swagger, aws-application-networking-k8s, ipfs-cluster, terraform-provider-azapi, aactl, cluster-api-helm-controller, kubernetes-dashboard-api, aws-otel-collector, gptscript, nri-f5, kubernetes-dashboard-web, grafana-rollout-operator, flux, dive,...
Security Bulletin:Vulnerability in Mongo affects IBM Netezza Appliance
Summary The Mongo package is used by IBM Netezza Appliance. IBM Netezza Appliance has addressed the applicable CVECVE-2026-2303 Vulnerability Details CVEID:CVE-2026-2303 DESCRIPTION: The mongo-go-driver repository contains CGo bindings for GSSAPI Kerberos authentication on Linux and macOS. The C...
EUVD-2026-54214
Insecure direct object reference in the mongodbmemory, elasticsearchmemory, and mem0memory tools in Amazon Strands Agents Tools before 0.8.3 might allow remote authenticated users to access, modify, or delete memories belonging to other tenants by influencing the LLM to emit tool calls with a...
Malicious code in @lyxa.ai/core (npm)
--- -= Per source details. Do not edit below this line.=- Source: amazon-inspector 1a32d4762c92b12ad7fd0567dfa0f07470a01884303acdc7a3585bfb4ad7fff2 The exported bootstrapCore unconditionally initializes the event bus with a hardcoded amqps:// URL containing embedded credentials for the author's...
Malicious code in express-mongo-santi (npm)
--- -= Per source details. Do not edit below this line.=- Source: amazon-inspector 85c97cf70eead9dda2069dc9da7e4a780f7c69953714ad050566c0e94a343e33 The package's main file index.js is a heavily obfuscated bundle obfuscator.io-style rotated string array with base64+RC4 decoders whose only purpose ...
MAL-2026-12377 Malicious code in express-mongo-santi (npm)
--- -= Per source details. Do not edit below this line.=- Source: amazon-inspector 85c97cf70eead9dda2069dc9da7e4a780f7c69953714ad050566c0e94a343e33 The package's main file index.js is a heavily obfuscated bundle obfuscator.io-style rotated string array with base64+RC4 decoders whose only purpose ...
alcali (>=2019.2.5, <=3000.1.0), deustest2022 (1.0.0) +6 more potentially affected by CVE-2026-15830 via django (3.0.5)
django PYPI version 3.0.5 is affected by a known vulnerability. The following packages have a transitive dependency on django and may be impacted: - alcali =2019.2.5, =0.2.32, =1.1.0, =8.2.0, =0.2.2, =0.9.9, =0.10.0 Source cves: CVE-2026-15830 Source advisory: OSV:GHSA-Q238-5CXM-5C9H...