222 matches found
CVE-2018-10717: Out-of-bounds Write
The DecodeGifImg function in ngiflib.c in MiniUPnP ngiflib 0.4 does not consider the bounds of the pixels data structure, which allows remote attackers to cause a denial of service WritePixels heap-based buffer overflow and application crash or possibly have unspecified other impact via a crafted...
PT-2018-10063
Name of the Vulnerable Software and Affected Versions MiniUPnP ngiflib version 0.4 Description The issue is related to the DecodeGifImg function in ngiflib.c, which does not consider the bounds of the pixels data structure. This allows remote attackers to cause a denial of service, resulting in a...
CVE-2018-10677
The DecodeGifImg function in ngiflib.c in MiniUPnP ngiflib 0.4 lacks certain checks against width and height, which allows remote attackers to cause a denial of service WritePixels heap-based buffer overflow and application crash or possibly have unspecified other impact via a crafted GIF file...
CVE-2018-10677
The DecodeGifImg function in ngiflib.c in MiniUPnP ngiflib 0.4 lacks certain checks against width and height, which allows remote attackers to cause a denial of service WritePixels heap-based buffer overflow and application crash or possibly have unspecified other impact via a crafted GIF file...
CVE-2018-10677
The DecodeGifImg function in ngiflib.c in MiniUPnP ngiflib 0.4 lacks certain checks against width and height, which allows remote attackers to cause a denial of service WritePixels heap-based buffer overflow and application crash or possibly have unspecified other impact via a crafted GIF file...
CVE-2018-10677
The DecodeGifImg function in ngiflib.c in MiniUPnP ngiflib 0.4 lacks certain checks against width and height, which allows remote attackers to cause a denial of service WritePixels heap-based buffer overflow and application crash or possibly have unspecified other impact via a crafted GIF file...
CVE-2018-10677
Summary: The vulnerability affects MiniUPnP ngiflib 0.4, specifically the DecodeGifImg function in ngiflib.c, which does not correctly validate width/height bounds. This lack of validation can enable a remote attacker to trigger a denial of service via a heap-based WritePixels buffer overflow and...
PT-2018-10047
Name of the Vulnerable Software and Affected Versions MiniUPnP ngiflib version 0.4 Description The issue is related to the DecodeGifImg function in ngiflib.c, which lacks checks against width and height. This allows remote attackers to cause a denial of service, resulting in a WritePixels...
CVE-2018-10677: Out-of-bounds Write
The DecodeGifImg function in ngiflib.c in MiniUPnP ngiflib 0.4 lacks certain checks against width and height, which allows remote attackers to cause a denial of service WritePixels heap-based buffer overflow and application crash or possibly have unspecified other impact via a crafted GIF file...
MiniUPnP <= 2.0 DoS Vulnerability (CVE-2017-1000494)
Uninitialized stack variable vulnerability in NameValueParserEndElt upnpreplyparse.c in miniupnpd allows an attacker to cause Denial of Service Segmentation fault and Memory Corruption or possibly have unspecified other impact. Copyright C 2018 Greenbone Networks GmbH Some text descriptions might...
Ubuntu 14.04 LTS / 16.04 LTS : MiniUPnP vulnerabilities (USN-3562-1)
The remote Ubuntu 14.04 LTS / 16.04 LTS host has packages installed that are affected by a vulnerability as referenced in the USN-3562-1 advisory. It was discovered that MiniUPnP incorrectly handled memory. A remote attacker could use this issue to cause a denial of service or possibly execute...
USN-3562-1 miniupnpc vulnerabilities
It was discovered that MiniUPnP incorrectly handled memory. A remote attacker could use this issue to cause a denial of service or possibly execute arbitrary code with privileges of the user running an application that uses the MiniUPnP library...
USN-3562-1: MiniUPnP vulnerabilities
It was discovered that MiniUPnP incorrectly handled memory. A remote attacker could use this issue to cause a denial of service or possibly execute arbitrary code with privileges of the user running an application that uses the MiniUPnP library...
MGASA-2017-0313 Updated miniupnpc packages fix security vulnerability
It was discovered that MiniUPnP incorrectly handled memory. A remote attacker could use this issue to cause a denial of service or possibly execute arbitrary code with privileges of the user running an application that uses the MiniUPnP library CVE-2017-8798...
Updated miniupnpc packages fix security vulnerability
It was discovered that MiniUPnP incorrectly handled memory. A remote attacker could use this issue to cause a denial of service or possibly execute arbitrary code with privileges of the user running an application that uses the MiniUPnP library CVE-2017-8798...
Ubuntu 17.04 : miniupnpc vulnerability (USN-3298-2)
USN-3298-1 fixed a vulnerability in MiniUPnP. This update provides the corresponding update for Ubuntu 17.04. It was discovered that MiniUPnP incorrectly handled memory. A remote attacker could use this issue to cause a denial of service or possibly execute arbitrary code with privileges of the...
Ubuntu 14.04 LTS / 16.04 LTS : MiniUPnP vulnerability (USN-3298-1)
The remote Ubuntu 14.04 LTS / 16.04 LTS host has packages installed that are affected by a vulnerability as referenced in the USN-3298-1 advisory. It was discovered that MiniUPnP incorrectly handled memory. A remote attacker could use this issue to cause a denial of service or possibly execute...
USN-3298-2: MiniUPnP vulnerability
USN-3298-1 fixed a vulnerability in MiniUPnP. This update provides the corresponding update for Ubuntu 17.04. Original advisory details: It was discovered that MiniUPnP incorrectly handled memory. A remote attacker could use this issue to cause a denial of service or possibly execute arbitrary co...
USN-3298-1: MiniUPnP vulnerability
It was discovered that MiniUPnP incorrectly handled memory. A remote attacker could use this issue to cause a denial of service or possibly execute arbitrary code with privileges of the user running an application that uses the MiniUPnP library...
USN-3298-1 miniupnpc vulnerability
It was discovered that MiniUPnP incorrectly handled memory. A remote attacker could use this issue to cause a denial of service or possibly execute arbitrary code with privileges of the user running an application that uses the MiniUPnP library...