13203 matches found
CVE-2026-97149
In OpenStack Swift before 2.38.2, the tempurl middleware does not reject the X-Copy-From header on PUT requests. A TempURL signature only covers the method, expiry, and path, and thus the list of disallowed headers is the only defense against a signed PUT request changing what the request does. A...
EUVD-2026-85786
In OpenStack Swift before 2.38.2, the tempurl middleware does not reject the X-Copy-From header on PUT requests. A TempURL signature only covers the method, expiry, and path, and thus the list of disallowed headers is the only defense against a signed PUT request changing what the request does. A...
PT-2026-97695
Name of the Vulnerable Software and Affected Versions OpenStack Swift versions prior to 2.38.2 Description The tempurl middleware fails to reject the X-Copy-From header during PUT requests. Because a TempURL signature only validates the method, expiry, and path, the system relies on a list of...
CVE-2026-63493: Authentication Bypass Using an Alternate Path or Channel
Snipe-IT is an IT asset/license management system. Prior to 8.7.0, a password-authenticated session for an account with self.api permission can reach the personal-access-token API flow before completing the account's second-factor challenge because CheckForTwoFactor is enforced in the web...
CVE-2026-97149: Incomplete List of Disallowed Inputs
In OpenStack Swift before 2.38.2, the tempurl middleware does not reject the X-Copy-From header on PUT requests. A TempURL signature only covers the method, expiry, and path, and thus the list of disallowed headers is the only defense against a signed PUT request changing what the request does. A...
Linux Distros Unpatched Vulnerability : CVE-2026-97149
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - In OpenStack Swift before 2.38.2, the tempurl middleware does not reject the X-Copy-From header on PUT requests. A TempURL signature only covers the method,...
Linux Distros Unpatched Vulnerability : CVE-2026-61629
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - nginx ignition is a user interface for the nginx web server. In versions 2.29.0 through 2.40.0, the gin i18n middleware in nginx-ignition's API server runs in...
Improper Validation Of Cookie Domain Attributes
Http4s is vulnerable to improper validation of cookie domain attributes. The vulnerability is due to the CookieJar client middleware accepting a response cookie’s Domain attribute without validating that it matches the response host, which allows an attacker controlling or compromising a server t...
UBUNTU-CVE-2026-61629
nginx ignition is a user interface for the nginx web server. In versions 2.29.0 through 2.40.0, the gin i18n middleware in nginx-ignition's API server runs in front of every HTTP request and calls golang.org/x/text/language.ParseAcceptLanguage on the raw Accept-Language header without imposing an...
Malicious code in hardhat-base (npm)
Source: amazon-inspector a65f09d6bfd4d7c28183a13e64a9eb5e989fa7b24fbf92c049a044accefe4950 Package presents itself as a pino-compatible logger module.exports.pino = middleware; keywords fast/logger/stream/json but ships an RCE loader. index.js spawns lib/caller.js as a detached child process on...
EUVD-2026-83924
nginx ignition is a user interface for the nginx web server. In versions 2.29.0 through 2.40.0, the gin i18n middleware in nginx-ignition's API server runs in front of every HTTP request and calls golang.org/x/text/language.ParseAcceptLanguage on the raw Accept-Language header without imposing an...
webpack-dev-middleware: webpack-dev-middleware: Information Disclosure via Path Traversal
A flaw was found in webpack-dev-middleware. A remote attacker can exploit a path traversal vulnerability when the configured publicPath lacks a trailing slash. By sending a specially crafted request, the attacker can bypass a security guard, allowing the middleware to resolve files from one...
CVE-2026-61629: Allocation of Resources Without Limits or Throttling
nginx ignition is a user interface for the nginx web server. In versions 2.29.0 through 2.40.0, the gin i18n middleware in nginx-ignition's API server runs in front of every HTTP request and calls golang.org/x/text/language.ParseAcceptLanguage on the raw Accept-Language header without imposing an...
CLSA-2026-1789721764 TuxCare security update for webpack-dev-middleware (1 CVE)
TuxCare rebuilt webpack-dev-middleware to address 1 CVE. Fixed in 1.11.0-tuxcare.1...
middleware-apm (>=0.1.29, <=0.1.37) potentially affected by CVE-2026-102925 via virtualenv (20.0.17)
virtualenv PYPI version 20.0.17 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - middleware-apm =0.1.29, =0.1.37 Source cves: CVE-2026-102925 Source advisory: OSV:PYSEC-2026-4013...
middleware-apm (>=0.1.29, <=0.1.37) potentially affected by CVE-2026-102930 via virtualenv (20.0.17)
virtualenv PYPI version 20.0.17 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - middleware-apm =0.1.29, =0.1.37 Source cves: CVE-2026-102930 Source advisory: OSV:PYSEC-2026-4011...
middleware-apm (>=0.1.29, <=0.1.37) potentially affected by CVE-2026-102937 via virtualenv (20.0.17)
virtualenv PYPI version 20.0.17 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - middleware-apm =0.1.29, =0.1.37 Source cves: CVE-2026-102937 Source advisory: OSV:PYSEC-2026-4014...
PT-2026-99834
TuxCare rebuilt webpack-dev-middleware to address 1 CVE. Fixed in 1.11.0-tuxcare.1...
Oracle Identity Manager (September 2026 CSPU)
The version of Oracle Identity Manager installed on the remote host are affected by multiple vulnerabilities as referenced in the September 2026 CSPU advisory. - Vulnerability in the Oracle Identity Manager product of Oracle Fusion Middleware component: Core. Supported versions that are affected...
middleware-apm (>=0.1.29, <=0.1.37) potentially affected by CVE-2026-102938 via virtualenv (20.0.17)
virtualenv PYPI version 20.0.17 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - middleware-apm =0.1.29, =0.1.37 Source cves: CVE-2026-102938 Source advisory: OSV:PYSEC-2026-4012...