150 matches found
ICOM SR-7100VN Privilege Escalation
The vulnerability of the microprogrammed software of the wireless VoIP router ICOM SR-7100VN is related to the improper assignment of privileges. Exploiting this vulnerability can allow a malicious actor to enhance their privileges remotely...
Cisco Small Business Series Switch DoS
The vulnerability of the web-based management interface for Microprogramming Software on Cisco Small Business Series Switches is related to buffer overflow in dynamic memory. Exploiting this vulnerability can allow a malicious actor to trigger a service failure through a specially crafted request...
HP Color LaserJet Printer Information Disclosure
The vulnerability of the microprogramming software of HP Color LaserJet Enterprise and HP Color LaserJet Managed MFP lies in the lack of protection for operational data. Exploiting this vulnerability can allow an attacker to disclose the protected information...
logic controllers for building
The vulnerability of microprogramming software for logic controllers used in building and facility control systems, such as Schneider Electric’s spaceLYnk, Wiser for KNX formerly homeLYnk, and FellerLYnk, is related to the exploitation of inter-site requests. Exploiting this vulnerability allows ...
Moxa NPort W2150A/W2250A Code Execution
The vulnerability of the microprogrammed software of Moxa NPort W2150A/W2250A serial interface converters lies in the lack of data cleaning measures at the control level. Exploiting this vulnerability allows a remote attacker to execute arbitrary code...
SIMATIC S7-1200 PLC
The vulnerability of microprogrammed software in programmable logic controllers SIMATIC S7-1200 and S7-1500 is related to insufficient protection of registration data. Exploiting this vulnerability can allow an intruder to gain full access to the device...
STARDOM FCN/FCJ Insufficient Verification Full Control
The vulnerability of microprogrammed software in STARDOM FCN/FCJ programmable logic controllers is related to insufficient verification of data authenticity. Exploiting this vulnerability can allow an attacker operating remotely to gain full control over the device...
Digi ConnectPort X2D Code Execution
The vulnerability of the microprogrammed software for Digi ConnectPort X2D converters is related to access control errors. Exploiting this vulnerability allows a remote attacker to execute arbitrary code by loading specially crafted Python files...
Schneider Electric Easergy P5 Relay Cryptographic Defects
The vulnerability of microprogrammed software in Schneider Electric Easergy P5 relay protection and control devices is related to the use of cryptographic algorithms that contain vulnerabilities. Exploiting this vulnerability could allow a malicious actor to compromise the confidentiality,...
Schneider Electric Easergy P5 Relay Buffer Overflow
The vulnerability of microprogrammed software in Schneider Electric Easergy P5 relay protection and control devices lies in the copying of buffers without checking the size of input data. Exploiting this vulnerability could allow a remote attacker to execute arbitrary code...
SCALANCE X302-7 Buffer Overflow DoS
The vulnerability of the microprogrammed software in industrial switches SCALANCE X302-7, SCALANCE X304-2FE, SCALANCE X306-1LD FE, SCALANCE X307-2, SCALANCE X307-3, SCALANCE X307-3LD, SCALANCE X308-2, SCALANCE X310, SCALANCE X320-1, SCALANCE X408-2, SCALANCE XR324-4M, and SCALANCE XR324-12M, SIPL...
WNR2000v3 WNR2000v4 WNR2000v5 R2000 Buffer Overflow
The vulnerability of the microprogrammed software of the WNR2000v3, WNR2000v4, WNR2000v5, and R2000 lies in the execution of operations beyond the buffer boundaries in memory. Exploiting this vulnerability can allow a remote attacker to execute arbitrary code...
SYSMAC CS/CJ/CP PLC Insufficient Data Authenticity
The vulnerability of microprogrammed software in programmable logic controllers of the SYSMAC CS/CJ/CP series is related to insufficient verification of data authenticity. Exploiting this vulnerability allows an attacker operating remotely to execute arbitrary commands...
PLC Software Insufficient Data Authenticity
The vulnerabilities of microprogrammed software in programmable logic controllers such as AXC 1050, AXC 1050 XC, AXC 3050, FC 350 PCI ETH, ILC1x0, ILC1x1, ILC 1x1 GSM/GPRS, ILC 3xx, PC WORX RT BASIC, PC WORX SRT, RFC 430 ETH-IB, RFC 450 ETH-IB, RFC 460R PN 3TX, RFC 460R PN 3TX-S, RFC 470 PN 3TX,...
ControlLogix PLC Code Generation
The vulnerability of microprogrammed software in programmable logic controllers such as ControlLogix 5580, GuardLogix 5580, CompactLogix 5380, CompactLogix 5480, and Compact GuardLogix 5380 lies in improper code generation. Exploiting this vulnerability allows an intruder to implant code into the...
Cisco IP Phones CSRF
The vulnerability of the web interface for controlling microprogrammed software in Cisco IP Phones 6800, 7800, and 8800 is related to insufficient verification of the HTTP request source. Exploiting this vulnerability allows a malicious actor to execute a CSRF attack using a specially created web...
CAPITAL VSTAR APOGEE MBC APOGEE MEC APOGEE PXC TAL
The vulnerability of microprogrammed software for controllers CAPITAL VSTAR, APOGEE MBC, APOGEE MEC, APOGEE PXC, TALON TC, and the operating system Nucleus is related to errors in processing the UDP packet header. Exploiting this vulnerability can allow an attacker to gain access to protected...
Reason RT430/RT434 GNSS Grandmaster Clock Code Execution
The vulnerability of the microprogramming software used in time-synchronized server synchronization systems like Reason RT430/RT434 GNSS Grandmaster Clock is related to the possibility of code injection. Exploiting this vulnerability allows a malicious actor to execute arbitrary code remotely...
Sources TLS Code Execution
The vulnerability of Microprogrammed Software Sources for APC Smart-UPS battery backup systems of the SMT, SMC, SMTL, SCL, and SMX series is related to errors in processing TLS packets. Exploiting this vulnerability allows a remote attacker to execute arbitrary code...
APC Smart-UPS Power Supply Auth Code Execution
The vulnerability of microprogrammed software in APC Smart-UPS power supplies of the SMT, SMC, SMTL, SCL, and SMX series is related to errors during the authentication process. Exploiting this vulnerability could allow an attacker operating remotely to execute arbitrary code...