24922 matches found
PT-2024-25476 · Mp-Spdz · Mp-Spdz
Name of the Vulnerable Software and Affected Versions: MP-SPDZ version 0.3.8 Description: A stack overflow was discovered in the function octetStream::get bytes in /Tools/octetStream.cpp, allowing attackers to cause a Denial of Service DoS via a crafted message. Recommendations: For MP-SPDZ versi...
CVE-2024-33783
MP-SPDZ v0.3.8 was discovered to contain a segmentation violation via the function osuCrypto::SilentMultiPprfReceiver::expand in /Tools/SilentPprf.cpp. This vulnerability allows attackers to cause a Denial of Service DoS via a crafted message...
PT-2024-25477 · Mp-Spdz · Mp-Spdz
Name of the Vulnerable Software and Affected Versions: MP-SPDZ version 0.3.8 Description: A stack overflow was discovered in the function OTExtensionWithMatrix::extend in /OT/OTExtensionWithMatrix.cpp. This issue allows attackers to cause a Denial of Service DoS via a crafted message...
PT-2024-6377
Name of the Vulnerable Software and Affected Versions Traefik affected versions not specified Description A malformed DNS message in response to a query can cause the Lookup functions to get stuck in an infinite loop. The issue is related to the net component of the Go programming language, which...
CVE-2024-32972
go-ethereum geth is a golang execution layer implementation of the Ethereum protocol. Prior to 1.13.15, a vulnerable node can be made to consume very large amounts of memory when handling specially crafted p2p messages sent from an attacker node. The fix has been included in geth version 1.13.15...
CVE-2024-32972 go-ethereum denial of service via malicious p2p message
go-ethereum geth is a golang execution layer implementation of the Ethereum protocol. Prior to 1.13.15, a vulnerable node can be made to consume very large amounts of memory when handling specially crafted p2p messages sent from an attacker node. The fix has been included in geth version 1.13.15...
CVE-2024-32972
CVE-2024-32972 affects go-ethereum (geth). A vulnerable node can be forced to consume excessive memory by processing specially crafted p2p messages, triggering a denial of service. The underlying issue is related to handling certain p2p requests (notably a GetBlockHeadersRequest with crafted valu...
CVE-2024-32972 go-ethereum denial of service via malicious p2p message
go-ethereum geth is a golang execution layer implementation of the Ethereum protocol. Prior to 1.13.15, a vulnerable node can be made to consume very large amounts of memory when handling specially crafted p2p messages sent from an attacker node. The fix has been included in geth version 1.13.15...
Resource Exhaustion
Overview Affected versions of this package are vulnerable to Resource Exhaustion when handling specially crafted p2p messages. A vulnerable node can be made to consume very large amounts of memory. Remediation Upgrade github.com/microstack-tech/parallax/core/rawdb to version 0.1.4 or higher...
Ethereum Go-ethereum security vulnerabilities
Ethereum Go-ethereum is a codebase from the Ethereum community that implements the Ethereum protocol in the Go language. A security vulnerability exists in Ethereum Go-ethereum versions prior to 1.13.15, which stems from a vulnerable node that may consume a large amount of memory when processing...
Delta Electronics DIAEnergie security vulnerability
Delta Electronics DIAEnergie is an industrial energy management system from Delta Electronics, Taiwan, China. A denial of service vulnerability exists in Delta Electronics DIAEnergie, which originates from CEBC.exe restarting the system when processing ICS Restart messages. An attacker could...
PT-2024-31659 · Delta Electronics · Diaenergie
Name of the Vulnerable Software and Affected Versions: Delta Electronics DIAEnergie versions 1.10.1.8610 and prior Description: A denial of service issue exists when processing an 'ICS Restart!' message, causing CEBC.exe to restart the system. Recommendations: For Delta Electronics DIAEnergie...
CVE-2024-32972: Uncontrolled Resource Consumption
go-ethereum geth is a golang execution layer implementation of the Ethereum protocol. Prior to 1.13.15, a vulnerable node can be made to consume very large amounts of memory when handling specially crafted p2p messages sent from an attacker node. The fix has been included in geth version 1.13.15...
Cross-site Scripting (XSS)
Overview Affected versions of this package are vulnerable to Cross-site Scripting XSS due to improperly sanitized interface messages in the getError function. An attacker can inject malicious scripts. Note: Fixed versions: 1.39.6, 1.40.2, 1.41.1 are not in Packagist. Details Cross-site scripting ...
CVE-2024-34475
Open5GS before 2.7.1 is vulnerable to a reachable assertion that can cause an AMF crash via NAS messages from a UE: gmmstateauthentication in amf/gmm-sm.c for != OGSERROR...
CVE-2024-34476: Buffer Access with Incorrect Length Value
Open5GS before 2.7.1 is vulnerable to a reachable assertion that can cause an AMF crash via NAS messages from a UE: ogsnasencrypt in lib/nas/common/security.c for pkbuf-len...
CVE-2024-34500
An issue was discovered in the UnlinkedWikibase extension in MediaWiki before 1.39.6, 1.40.x before 1.40.2, and 1.41.x before 1.41.1. XSS can occur through an interface message. Error messages in the $err var are not escaped before being passed to Html::rawElement in the getError function in the...
CVE-2024-34500
The UnlinkedWikibase extension in MediaWiki is vulnerable to Cross-site Scripting (XSS) in versions prior to 1.39.6 , 1.40.x before 1.40.2 , and 1.41.x before 1.41.1 . The root cause is that error messages stored in the $err variable are not properly escaped before being passed to the Html::rawEl...
CVE-2024-34475: Reachable Assertion
Open5GS before 2.7.1 is vulnerable to a reachable assertion that can cause an AMF crash via NAS messages from a UE: gmmstateauthentication in amf/gmm-sm.c for != OGSERROR...