Lucene search
+L

11 matches found

Mend
Mend
•added 2026/05/19 12:25 p.m.•13 views

CVE-2026-47323

Camel-CXF and Camel-Knative Message Header Injection via Missing Inbound Filtering The CXF and Knative HeaderFilterStrategy implementations CxfRsHeaderFilterStrategy in camel-cxf-rest, CxfHeaderFilterStrategy in camel-cxf-transport, and KnativeHttpHeaderFilterStrategy in camel-knative-http only...

9.8CVSS8.7AI score0.19563EPSS
SaveExploits1References8
Cvelist
Cvelist
•added 2026/04/14 11:35 p.m.•43 views

CVE-2026-39971 Serendipity: Host Header Injection leads to SMTP header injection via unvalidated HTTP_HOST

Serendipity is a PHP-powered weblog engine. In versions 2.6-beta2 and below, the email sending functionality in include/functions.inc.php inserts $SERVER'HTTPHOST' directly into the Message-ID SMTP header without validation, and the existing sanitization function serendipityisResponseClean is not...

7.2CVSS0.00255EPSS
SaveExploits1References2
EUVD
EUVD
•added 2025/10/03 8:07 p.m.•26 views

EUVD-2025-6254

Malicious code in bioql PyPI...

5.6CVSS6.8AI score0.97057EPSS
SaveExploits5References7
Vulnrichment
Vulnrichment
•added 2025/04/01 11:56 a.m.•16 views

CVE-2025-30177 Apache Camel: Camel-Undertow Message Header Injection via Improper Filtering

Bypass/Injection vulnerability in Apache Camel in Camel-Undertow component under particular conditions. This issue affects Apache Camel: from 4.10.0 before 4.10.3, from 4.8.0 before 4.8.6. Users are recommended to upgrade to version 4.10.3 for 4.10.x LTS and 4.8.6 for 4.8.x LTS. Camel undertow...

6.5AI score0.01295EPSS
SaveExploits0References3
osv_cve
osv_cve
•added 2025/04/01 11:56 a.m.•29 views

CVE-2025-30177 Apache Camel: Camel-Undertow Message Header Injection via Improper Filtering

Bypass/Injection vulnerability in Apache Camel in Camel-Undertow component under particular conditions. This issue affects Apache Camel: from 4.10.0 before 4.10.3, from 4.8.0 before 4.8.6. Users are recommended to upgrade to version 4.10.3 for 4.10.x LTS and 4.8.6 for 4.8.x LTS. Camel undertow...

6.5CVSS6.8AI score
SaveExploits0References6
CVE
CVE
•added 2025/04/01 11:56 a.m.•140 views

CVE-2025-30177

The Apache Camel framework is vulnerable to a message header injection flaw in the Camel-Undertow component. The root cause is that the custom header filter strategy only applies to outgoing messages and fails to filter incoming requests. This oversight allows an unauthenticated attacker to injec...

6.5CVSS6.5AI score0.01295EPSS
SaveExploits0References3Affected Software1
Cvelist
Cvelist
•added 2025/04/01 11:56 a.m.•66 views

CVE-2025-30177 Apache Camel: Camel-Undertow Message Header Injection via Improper Filtering

Bypass/Injection vulnerability in Apache Camel in Camel-Undertow component under particular conditions. This issue affects Apache Camel: from 4.10.0 before 4.10.3, from 4.8.0 before 4.8.6. Users are recommended to upgrade to version 4.10.3 for 4.10.x LTS and 4.8.6 for 4.8.x LTS. Camel undertow...

0.01295EPSS
SaveExploits0References3
Tenable Nessus
Tenable Nessus
•added 2025/03/18 12:00 a.m.•34 views

Apache Camel 3.10.0 < 3.22.4 / 4.8.x < 4.8.5 / 4.10.x < 4.10.2 Message Header Injection (CVE-2025-27636)

The version of Apache Camel on the remote host is 3.10.0 prior to 3.22.4, 4.8.x prior to 4.8.5, or 4.10.x prior to 4.10.2. It is, therefore, affected by a message header injection vulnerability: - Bypass/Injection vulnerability in Apache Camel components under particular conditions. This issue...

5.6CVSS7AI score0.97057EPSS
SaveExploits4References2
Cvelist
Cvelist
•added 2025/03/12 2:42 p.m.•39 views

CVE-2025-29891 Apache Camel: Camel Message Header Injection through request parameters

Bypass/Injection vulnerability in Apache Camel. This issue affects Apache Camel: from 4.10.0 before 4.10.2, from 4.8.0 before 4.8.5, from 3.10.0 before 3.22.4. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and 3.22.4 for 3.x releases. This vulnerability is...

0.76087EPSS
SaveExploits2References2
Vulnrichment
Vulnrichment
•added 2025/03/12 2:42 p.m.•35 views

CVE-2025-29891 Apache Camel: Camel Message Header Injection through request parameters

Bypass/Injection vulnerability in Apache Camel. This issue affects Apache Camel: from 4.10.0 before 4.10.2, from 4.8.0 before 4.8.5, from 3.10.0 before 3.22.4. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and 3.22.4 for 3.x releases. This vulnerability is...

6.6AI score0.76087EPSS
SaveExploits2References2
Cvelist
Cvelist
•added 2025/03/09 12:09 p.m.•53 views

CVE-2025-27636 Apache Camel: Camel Message Header Injection via Improper Filtering

Bypass/Injection vulnerability in Apache Camel components under particular conditions. This issue affects Apache Camel: from 4.10.0 through = 4.10.1, from 4.8.0 through = 4.8.4, from 3.10.0 through = 3.22.3. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS an...

0.97057EPSS
SaveExploits4References3
Rows per page
Query Builder