45 matches found
CVE-2024-5082
Overview This repository contains a Python proof of concept for CVE-2024-5082 , a remote code execution vulnerability in Sonatype Nexus Repository Manager 2. The vulnerability allows a user with sufficient permission to publish a specially crafted Maven artifact and mark it for processing by the...
CLSA-2026-1786379796 TuxCare security update for org.codehaus.plexus:plexus-utils (1 CVE)
TuxCare rebuilt org.codehaus.plexus:plexus-utils to address 1 CVE. Fixed in 3.0.24-tuxcare.1...
jp.ikedam.jenkins.plugins:extensible-choice-parameter (>=1.4.0, <=1.8.0), org.jenkins-ci.plugins:extended-choice-parameter (0.65) +4 more potentially affected by CVE-2026-57280 via org.jenkins-ci.plugins:script-security (1.18.1)
org.jenkins-ci.plugins:script-security MAVEN version 1.18.1 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:script-security and may be impacted: - jp.ikedam.jenkins.plugins:extensible-choice-parameter =1.4.0, =1.2.3, =1.3.4, =1.9...
ai.h2o:h2o-admissibleml (>=3.34.0.1, <=3.46.0.12), ai.h2o:h2o-algos (>=0.1.9, <=3.46.0.12) +49 more potentially affected by CVE-2026-8752 via ai.h2o:h2o-core (>=0.1.9, <=3.46.0.12)
ai.h2o:h2o-core MAVEN version =0.1.9, =3.34.0.1, =0.1.9, =0.1.9, =3.12.0.1, =3.8.2.4, =3.14.0.7, =3.16.0.1, =3.14.0.1, =3.24.0.1, =3.30.1.1, =3.26.0.4, =3.10.5.1, =3.24.0.1, =3.30.0.1, =3.34.0.3, =3.46.0.12 and more Source cves: CVE-2026-8752 Source advisory: SNYK:JAVA-AIH2O-17279555...
com.googlecode.apparat:apparat-maven-plugin (1.0.rc4), org.apache.maven:apache-maven (3.0-beta-1) +33 more potentially affected by CVE-2025-67030 via org.codehaus.plexus:plexus-utils (2.0.3)
org.codehaus.plexus:plexus-utils MAVEN version 2.0.3 is affected by a known vulnerability. The following packages have a transitive dependency on org.codehaus.plexus:plexus-utils and may be impacted: - com.googlecode.apparat:apparat-maven-plugin 1.0.rc4 - org.apache.maven:apache-maven 3.0-beta-1 ...
org.glassfish.mq:mq-client (>=6.4.0, <=6.9.0), org.glassfish.mq:mq-cluster (>=6.4.0, <=6.9.0) +12 more potentially affected by CVE-2026-22886 via org.glassfish.mq:mqbroker-core (>=6.4.0, <=6.9.0)
org.glassfish.mq:mqbroker-core MAVEN version =6.4.0, =6.4.0, =6.4.0, =6.4.0, =6.4.0, =6.4.0, =6.4.0, =6.4.0, =6.4.0, =6.4.0, =6.4.0, =6.4.0, =6.4.0, =6.4.0, =6.4.0, =6.9.0 Source cves: CVE-2026-22886 Source advisory: SNYK:JAVA-ORGGLASSFISHMQ-15444256...
com.googlecode.refit.jenkins:refit (>=0.1, <=0.3.1), jenkins.plugins.clangscanbuild:clang-scanbuild-plugin (>=1.0, <=1.3.1) +19 more potentially affected by CVE-2025-67635 via org.jenkins-ci.main:jenkins-core (1.403)
org.jenkins-ci.main:jenkins-core MAVEN version 1.403 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - com.googlecode.refit.jenkins:refit =0.1, =1.0, =1.19, =1.3, =2.1, =0.2.4, =0.2.8 -...
org.jenkins-ci.plugins:maven-artifact-choicelistprovider (>=1.8.0, <=1.9.2) potentially affected by CVE-2025-64133 via jp.ikedam.jenkins.plugins:extensible-choice-parameter (1.7.0)
jp.ikedam.jenkins.plugins:extensible-choice-parameter MAVEN version 1.7.0 is affected by a known vulnerability. The following packages have a transitive dependency on jp.ikedam.jenkins.plugins:extensible-choice-parameter and may be impacted: -...
org.jenkins-ci.plugins:maven-artifact-choicelistprovider (>=1.3.4, <=1.7.1) potentially affected by CVE-2025-64133 via jp.ikedam.jenkins.plugins:extensible-choice-parameter (1.6.0)
jp.ikedam.jenkins.plugins:extensible-choice-parameter MAVEN version 1.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on jp.ikedam.jenkins.plugins:extensible-choice-parameter and may be impacted: -...
org.jenkins-ci.plugins:maven-artifact-choicelistprovider (>=1.0.3, <=1.3.2) potentially affected by CVE-2025-64133 via jp.ikedam.jenkins.plugins:extensible-choice-parameter (1.3.3)
jp.ikedam.jenkins.plugins:extensible-choice-parameter MAVEN version 1.3.3 is affected by a known vulnerability. The following packages have a transitive dependency on jp.ikedam.jenkins.plugins:extensible-choice-parameter and may be impacted: -...
org.jenkins-ci.plugins:maven-artifact-choicelistprovider (>=1.0.3, <=410.v93a_3e2d7c777) potentially affected by CVE-2025-64133 via jp.ikedam.jenkins.plugins:extensible-choice-parameter (>=1.3.3, <=255.vfa_41f46828ef)
jp.ikedam.jenkins.plugins:extensible-choice-parameter MAVEN version =1.3.3, =1.0.3, =410.v93a3e2d7c777 Source cves: CVE-2025-64133 Source advisory: SNYK:JAVA-JPIKEDAMJENKINSPLUGINS-13775577...
EUVD-2022-3796
Malicious code in bioql PyPI...
CVE-2018-1999030
An exposure of sensitive information vulnerability exists in Jenkins Maven Artifact ChoiceListProvider Nexus Plugin 1.3.1 and earlier in ArtifactoryChoiceListProvider.java, NexusChoiceListProvider.java, Nexus3ChoiceListProvider.java that allows attackers to capture credentials with a known...
org.jenkins-ci.plugins:maven-artifact-choicelistprovider (>=1.6.1, <=1.8.1), org.jenkins-ci.plugins:templating-engine (>=2.3, <=2.5.3) potentially affected by CVE-2024-47805 via org.jenkins-ci.plugins:credentials (2.3.11)
org.jenkins-ci.plugins:credentials MAVEN version 2.3.11 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:credentials and may be impacted: - org.jenkins-ci.plugins:maven-artifact-choicelistprovider =1.6.1, =2.3, =2.5.3 Source cves:...
com.blazemeter.plugins:blazemeterjenkinsplugin (>=4.8, <=4.18), org.jenkins-ci.plugins:docker-build-step (2.8) +1 more potentially affected by CVE-2024-47805 via org.jenkins-ci.plugins:credentials (2.3.19)
org.jenkins-ci.plugins:credentials MAVEN version 2.3.19 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:credentials and may be impacted: - com.blazemeter.plugins:blazemeterjenkinsplugin =4.8, =1.9.0, =1.9.2 Source cves:...
com.blazemeter.plugins:blazemeterjenkinsplugin (>=4.8, <=4.18), org.jenkins-ci.plugins:docker-build-step (2.8) +1 more potentially affected by CVE-2024-39458 via org.jenkins-ci.plugins:structs (1.22)
org.jenkins-ci.plugins:structs MAVEN version 1.22 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:structs and may be impacted: - com.blazemeter.plugins:blazemeterjenkinsplugin =4.8, =1.9.0, =1.9.2 Source cves: CVE-2024-39458 Sour...
Fedora: Security Advisory for maven-resolver (FEDORA-2024-129d8ca6fc)
The remote host is missing an update for the SPDX-FileCopyrightText: 2024 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
Fedora: Security Advisory for maven-artifact-transfer (FEDORA-2024-129d8ca6fc)
The remote host is missing an update for the SPDX-FileCopyrightText: 2024 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
[SECURITY] Fedora 40 Update: maven-resolver-1.9.18-3.fc40
Apache Maven Artifact Resolver is a library for working with artifact repositories and dependency resolution. Maven Artifact Resolver deals with the specification of local repository, remote repository, developer workspaces, artifact transports and artifact resolution...