9284 matches found
CVE-2023-6709
Improper Neutralization of Special Elements Used in a Template Engine in GitHub repository mlflow/mlflow prior to 2.9.2...
a2 (>=0.1.0, <=0.3.17), agentos (>=0.0.5, <=0.0.7) +170 more potentially affected by CVE-2023-6709 via mlflow (>=0.8.2, <=2.8.1)
mlflow PYPI version =0.8.2, =0.1.0, =0.0.5, =1.0.1, =0.1.2, =0.1.0, =1.0.18.2, =0.0.1, =1.0.41, =1.4.0, =3.0.0, =0.1.2, =0.3.5, =0.8.0, =1.0.0 - cortic 0.1.0 and more Source cves: CVE-2023-6709 Source advisory: MEND:CVE-2023-6709...
CVE-2023-6709 Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow
Improper Neutralization of Special Elements Used in a Template Engine in GitHub repository mlflow/mlflow prior to 2.9.2...
CVE-2023-6709 Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow
Improper Neutralization of Special Elements Used in a Template Engine in GitHub repository mlflow/mlflow prior to 2.9.2...
Mlflow Security Vulnerabilities
Mlflow is an open source platform for machine learning lifecycles. A security vulnerability exists in Mlflow versions prior to 2.9.2 that stems from incorrect neutralization of special elements used in the template engine...
CVE-2023-6709: Improper Neutralization of Special Elements Used in a Template Engine
Improper Neutralization of Special Elements Used in a Template Engine in GitHub repository mlflow/mlflow prior to 2.9.2...
PT-2023-32757 · Mlflow · Mlflow
Name of the Vulnerable Software and Affected Versions: mlflow/mlflow versions prior to 2.9.2 Description: The issue is related to Path Traversal in the GitHub repository mlflow/mlflow. Recommendations: For versions prior to 2.9.2, update to version 2.9.2 or later to resolve the issue...
PT-2023-32744 · Jinja2 +1 · Jinja2 +1
Name of the Vulnerable Software and Affected Versions: mlflow/mlflow versions prior to 2.9.2 Description: The issue is related to improper neutralization of special elements used in a template engine. This can lead to remote code execution due to jinja2 SSTI in MLflow. Recommendations: For versio...
Cross Site Scripting (XSS)
mlflow is vulnerable to Cross-site Scripting XSS. The vulnerability exists due to the lack of proper sanitization and escaping of user inputs in the Content-Type header of POST requests. An attacker can exploit this vulnerability to injecting malicious code into the header, which will then be...
cnext (>=0.3.5, <=0.3.8), code-first-pipelines (>=0.8.0, <=1.0.0) +51 more potentially affected by CVE-2023-6568 via mlflow (1.30.1)
mlflow PYPI version 1.30.1 is affected by a known vulnerability. The following packages have a transitive dependency on mlflow and may be impacted: - cnext =0.3.5, =0.8.0, =0.6.1rc1, =0.2.4, =0.24.24, =0.0.1a0, =1.0.1, =0.1.1, =0.3.0, =0.8.3, =0.48.0, =0.2.0, =0.2.0, =0.3.0 and more Source cves:...
autopilotml (>=1.0.1, <=1.0.14), autozeekwatch (>=0.1.0, <=0.1.3) +42 more potentially affected by CVE-2023-6568 via mlflow (>=2.0.0rc0, <=2.8.1)
mlflow PYPI version =2.0.0rc0, =1.0.1, =0.1.0, =0.0.4, =0.1.2, =0.8.0, =0.0.1, =0.0.9, =1.0.16, =0.0.1, =1.10.2, =0.7.0, =0.2.0rc0, =1.0.3, =1.2.6 and more Source cves: CVE-2023-6568 Source advisory: OSV:GHSA-VWHF-3V6X-WFF8...
autopilotml (>=1.0.1, <=1.0.14), autozeekwatch (>=0.1.0, <=0.1.3) +42 more potentially affected by CVE-2023-6568 via mlflow (>=2.0.0rc0, <=2.8.1)
mlflow PYPI version =2.0.0rc0, =1.0.1, =0.1.0, =0.0.4, =0.1.2, =0.8.0, =0.0.1, =0.0.9, =1.0.16, =0.0.1, =1.10.2, =0.7.0, =0.2.0rc0, =1.0.3, =1.2.6 and more Source cves: CVE-2023-6568 Source advisory: GHSA-VWHF-3V6X-WFF8...
a2 (>=0.1.0, <=0.3.17), ikomia (>=0.9.0, <=0.13.0) +2 more potentially affected by CVE-2023-6568 via mlflow (1.30.0)
mlflow PYPI version 1.30.0 is affected by a known vulnerability. The following packages have a transitive dependency on mlflow and may be impacted: - a2 =0.1.0, =0.9.0, =0.13.0 - mantik 0.1.2 - pyrovelocity 0.1.1 Source cves: CVE-2023-6568 Source advisory: OSV:GHSA-VWHF-3V6X-WFF8...
GHSA-VWHF-3V6X-WFF8 Cross-site Scripting (XSS) in MLflow
A reflected Cross-Site Scripting XSS vulnerability exists in the mlflow/mlflow repository, specifically within the handling of the Content-Type header in POST requests. An attacker can inject malicious JavaScript code into the Content-Type header, which is then improperly reflected back to the us...
azureml-contrib-run (>=1.0.18.2, <=1.0.21.1) potentially affected by CVE-2023-6568 via mlflow (0.8.2)
mlflow PYPI version 0.8.2 is affected by a known vulnerability. The following packages have a transitive dependency on mlflow and may be impacted: - azureml-contrib-run =1.0.18.2, =1.0.21.1 Source cves: CVE-2023-6568 Source advisory: OSV:GHSA-VWHF-3V6X-WFF8...
azureml-contrib-run (>=1.0.33, <=1.0.41), azureml-mlflow (1.0.41) potentially affected by CVE-2023-6568 via mlflow (0.9.1)
mlflow PYPI version 0.9.1 is affected by a known vulnerability. The following packages have a transitive dependency on mlflow and may be impacted: - azureml-contrib-run =1.0.33, =1.0.41 - azureml-mlflow 1.0.41 Source cves: CVE-2023-6568 Source advisory: OSV:GHSA-VWHF-3V6X-WFF8...
azureml-contrib-run (>=1.0.72, <=1.0.74), azureml-mlflow (>=1.0.72.1, <=1.0.74) potentially affected by CVE-2023-6568 via mlflow (1.3.0)
mlflow PYPI version 1.3.0 is affected by a known vulnerability. The following packages have a transitive dependency on mlflow and may be impacted: - azureml-contrib-run =1.0.72, =1.0.72.1, =1.0.74 Source cves: CVE-2023-6568 Source advisory: OSV:GHSA-VWHF-3V6X-WFF8...
gordo-components (>=0.44.0, <=0.46.0) potentially affected by CVE-2023-6568 via mlflow (1.4.0)
mlflow PYPI version 1.4.0 is affected by a known vulnerability. The following packages have a transitive dependency on mlflow and may be impacted: - gordo-components =0.44.0, =0.46.0 Source cves: CVE-2023-6568 Source advisory: OSV:GHSA-VWHF-3V6X-WFF8...
farm (>=0.4.5, <=0.6.1), farm-haystack (>=0.3.0, <=0.6.0) +2 more potentially affected by CVE-2023-6568 via mlflow (1.0.0)
mlflow PYPI version 1.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on mlflow and may be impacted: - farm =0.4.5, =0.3.0, =0.0.1a1.dev14, =0.0.1a1.dev15 - mlflow-faculty 0.3.1 Source cves: CVE-2023-6568 Source advisory: OSV:GHSA-VWHF-3V6X-WFF8...
faculty-models (>=0.1.0, <=0.1.1), mlflow-faculty (>=0.4.0, <=0.4.3) potentially affected by CVE-2023-6568 via mlflow (1.2.0)
mlflow PYPI version 1.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on mlflow and may be impacted: - faculty-models =0.1.0, =0.4.0, =0.4.3 Source cves: CVE-2023-6568 Source advisory: OSV:GHSA-VWHF-3V6X-WFF8...