Lucene search
+L

645 matches found

Vulnrichment
Vulnrichment
•added 2026/09/29 6:27 p.m.•8 views

CVE-2026-102824 Russh: Missing X25519 zero-point validation in hybrid ML-KEM key exchange

Russh is a Rust SSH client and server library. Prior to 0.63.0, the hybrid ML-KEM 768 and X25519 implementation in russh/src/kex/hybridmlkem.rs accepts an all-zero 32-byte peer X25519 public key in both serverdh and computesharedsecret, forcing the X25519 contribution to the combined shared secre...

4.3CVSS5.9AI score0.00141EPSS
SaveExploits0References3
CVE
CVE
•added 2026/09/29 6:27 p.m.•24 views

CVE-2026-102824

The Russh Rust SSH client and server library (prior to version 0.63.0 ) contains a vulnerability in the hybrid ML-KEM 768 and X25519 key exchange implementation. The root cause is a missing zero-point validation in russh/src/kex/hybrid_mlkem.rs, which allows the library to accept an all-zero 32-b...

4.3CVSS5.9AI score0.00141EPSS
SaveExploits0References3
Cvelist
Cvelist
•added 2026/09/29 6:27 p.m.•49 views

CVE-2026-102824 Russh: Missing X25519 zero-point validation in hybrid ML-KEM key exchange

Russh is a Rust SSH client and server library. Prior to 0.63.0, the hybrid ML-KEM 768 and X25519 implementation in russh/src/kex/hybridmlkem.rs accepts an all-zero 32-byte peer X25519 public key in both serverdh and computesharedsecret, forcing the X25519 contribution to the combined shared secre...

4.3CVSS0.00141EPSS
SaveExploits0References3
Oracle linux
Oracle linux
•added 2026/09/29 12:00 a.m.•14 views

thunderbird security update

140.16.0-1.0.1 - Add Oracle prefs 140.16.0-1 - Update to 140.16.0 ESR 140.15.0-1 - Update to 140.15.0 ESR - Fix ML-DSA certificate validation Resolves: RHEL-252227...

10CVSS5.8AI score0.00628EPSS
SaveExploits0
Positive Technologies
Positive Technologies
•added 2026/09/29 12:00 a.m.•5 views

PT-2026-102808

Name of the Vulnerable Software and Affected Versions Russh versions prior to 0.63.0 Description The hybrid ML-KEM 768 and X25519 implementation in russh/src/kex/hybrid mlkem.rs accepts an all-zero 32-byte peer X25519 public key within the server dh and compute shared secret functions. This allow...

4.3CVSS5.7AI score0.00141EPSS
SaveExploits0References8
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2026/09/29 12:00 a.m.•7 views

CVE-2026-102824: Use of a Broken or Risky Cryptographic Algorithm

Russh is a Rust SSH client and server library. Prior to 0.63.0, the hybrid ML-KEM 768 and X25519 implementation in russh/src/kex/hybridmlkem.rs accepts an all-zero 32-byte peer X25519 public key in both serverdh and computesharedsecret, forcing the X25519 contribution to the combined shared secre...

4.3CVSS5.9AI score0.00141EPSS
SaveExploits0References2
SUSE Linux
SUSE Linux
•added 2026/09/28 3:06 p.m.•16 views

Security update for libsodium

This update for libsodium fixes the following issues: Update to 1.0.22 jscPED-16890: Post-quantum key encapsulation is now available. ML-KEM768, the NIST-standardized lattice-based KEM, is accessible through the cryptokemmlkem768 functions. X-Wing, a hybrid KEM combining ML-KEM768 with X25519 for...

6.8CVSS5.5AI score0.00413EPSS
SaveExploits0References10
OSV
OSV
•added 2026/09/28 3:06 p.m.•5 views

SUSE-SU-2026:4368-1 Security update for libsodium

This update for libsodium fixes the following issues: Update to 1.0.22 jscPED-16890: Post-quantum key encapsulation is now available. ML-KEM768, the NIST-standardized lattice-based KEM, is accessible through the cryptokemmlkem768 functions. X-Wing, a hybrid KEM combining ML-KEM768 with X25519 for...

9.8CVSS5.6AI score0.00413EPSS
SaveExploits0References5
Positive Technologies
Positive Technologies
•added 2026/09/25 12:00 a.m.•7 views

PT-2026-98718

Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description An issue exists in the ASOC Intel AVS component where the snd hdac ext bus get ml capabilities function may fail without its return code being properly checked and accounted for. This...

5.7AI score0.00172EPSS
SaveExploits0References8
Tenable Nessus
Tenable Nessus
•added 2026/09/25 12:00 a.m.•7 views

MiracleLinux 9 : dotnet9.0-9.0.121-1.el9_8.ML.1 (AXSA:2026-1916:19)

The remote MiracleLinux 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the AXSA:2026-1916:19 advisory. dotnet10.0: dotnet9.0: dotnet8.0: .NET Information Disclosure Vulnerability CVE-2026-58649 dotnet10.0: dotnet9.0: .NET Elevation of Privilege...

7CVSS6.1AI score0.00756EPSS
SaveExploits0References3
Kitploit
Kitploit
•added 2026/09/19 9:08 a.m.•14 views

wolfCOSE v2.0.0

wolfCOSE wolfCOSE is a lightweight C library implementing CBOR RFC 8949, COSE RFC 9052/9053, and post-quantum ML-DSA for COSE RFC 9964 using wolfSSL as the crypto backend. Main Features Complete RFC 9052 message set : all six COSE message types, including multi-signer COSESign and multi-recipient...

6.1AI score
SaveExploits0References3
AstraLinux
AstraLinux
•added 2026/09/14 12:01 p.m.•8 views

Astra Linux – Vulnerability in pygments

An infinite loop in the SMLLexer of Pygments versions 1.5 to 2.7.3 may lead to a denial of service when performing syntax highlighting of a Standard ML SML source file. This issue is observed when the input only contains the “exception” keyword...

7.5CVSS6.9AI score0.02759EPSS
SaveExploits0References1
Oracle linux
Oracle linux
•added 2026/09/14 12:00 a.m.•13 views

firefox security update

140.15.0-1.0.1 - Fix firefox-oracle-default-prefs.js for new nss Orabug: 37079773 - Add firefox-oracle-default-prefs.js and remove the corresponding Red Hat file 140.15.0-1 - Update to 140.15.0 ESR - Fix ML-DSA certificate validation Resolves: RHEL-252227...

10CVSS5.9AI score0.00455EPSS
SaveExploits0
Tenable Nessus
Tenable Nessus
•added 2026/09/14 12:00 a.m.•12 views

Oracle Linux 10 : ELSA-2026-67129-0: / firefox (ELSA-2026-671290)

The remote Oracle Linux 10 host has a package installed that is affected by multiple vulnerabilities as referenced in the ELSA-2026-671290 advisory. 140.15.0-1.0.1 - Fix firefox-oracle-default-prefs.js for new nss Orabug: 37079773 - Add firefox-oracle-default-prefs.js and remove the corresponding...

10CVSS6AI score0.00455EPSS
SaveExploits0References11
OSV
OSV
•added 2026/09/10 9:45 a.m.•24 views

PYSEC-2026-3944 Windows ML CLI: CORS misconfig enables localhost RCE

Case Description: MSRC Notes: Attachments: 1 files attached 1 mp4 Summary: The vulnerability lies in the 'serve/cliapi.py' component of the 'winml-cli' project, which exposes all winml CLI commands over HTTP without authentication. Although it binds to localhost by default, it sets 'alloworigins'...

8.6CVSS6.8AI score0.01608EPSS
SaveExploits0References7
EUVD
EUVD
•added 2026/09/08 9:27 p.m.•16 views

EUVD-2026-70264

Windows ML CLI: CORS misconfig enables localhost RCE...

8.6CVSS5.7AI score0.01608EPSS
SaveExploits0References4
Positive Technologies
Positive Technologies
•added 2026/09/03 12:00 a.m.•16 views

PT-2026-85125

Deserialization of Untrusted Data CWE-502 in the Elasticsearch machine learning component can lead to remote code execution via Object Injection CAPEC-586. A specially crafted trained model artifact could cause attacker-controlled logic to execute with a materially broader system-call surface tha...

8.8CVSS6.6AI score0.00918EPSS
SaveExploits0References3
NVD
NVD
•added 2026/09/02 8:17 p.m.•11 views

CVE-2026-84452

Windows ML CLI is a command line tool for building portable, performant, and high-quality AI models for Windows ML. Prior to 0.4.0, the src/winml/modelkit/serve/cliapi.py component exposes WinML CLI commands through a localhost HTTP API without authentication and configures the alloworigins setti...

8.6CVSS0.01608EPSS
SaveExploits0References3
CVE
CVE
•added 2026/09/02 7:22 p.m.•29 views

CVE-2026-84452

Windows ML CLI (a command-line tool for building AI models for Windows) is vulnerable to arbitrary code execution via a CORS misconfiguration on its localhost HTTP API. Prior to version 0.4.0 , the cli_api.py and app.py components expose WinML CLI commands on localhost without authentication and ...

8.6CVSS6.4AI score0.01608EPSS
SaveExploits0References3
Vulnrichment
Vulnrichment
•added 2026/09/02 7:22 p.m.•18 views

CVE-2026-84452 Windows ML CLI: CORS misconfig enables localhost RCE

Windows ML CLI is a command line tool for building portable, performant, and high-quality AI models for Windows ML. Prior to 0.4.0, the src/winml/modelkit/serve/cliapi.py component exposes WinML CLI commands through a localhost HTTP API without authentication and configures the alloworigins setti...

8.6CVSS6.4AI score0.01608EPSS
SaveExploits0References3
Rows per page
Query Builder