1298 matches found
CVE-2026-108599
phi 0.1.1 through 0.28.4 contains an improper link resolution vulnerability that allows malicious repositories to bypass workspaceonlywrites by exploiting lexical-only path checks in the permission gate. Attackers can commit symlinks pointing outside the workspace and use prompt injection to make...
CVE-2026-108599 Phi 0.1.1 through 0.28.4 Symlink Workspace Write Restriction Bypass
phi 0.1.1 through 0.28.4 contains an improper link resolution vulnerability that allows malicious repositories to bypass workspaceonlywrites by exploiting lexical-only path checks in the permission gate. Attackers can commit symlinks pointing outside the workspace and use prompt injection to make...
EUVD-2026-96393
phi 0.1.1 through 0.28.4 contains an improper link resolution vulnerability that allows malicious repositories to bypass workspaceonlywrites by exploiting lexical-only path checks in the permission gate. Attackers can commit symlinks pointing outside the workspace and use prompt injection to make...
CVE-2026-108599
The phi software (versions 0.1.1 through 0.28.4 ) is vulnerable to an improper link resolution vulnerability (CWE-59) within its permission gate. The root cause is the use of lexical-only path checks , which allows malicious repositories to bypass workspace_only_writes restrictions. By committing...
CVE-2026-108599 Phi 0.1.1 through 0.28.4 Symlink Workspace Write Restriction Bypass
phi 0.1.1 through 0.28.4 contains an improper link resolution vulnerability that allows malicious repositories to bypass workspaceonlywrites by exploiting lexical-only path checks in the permission gate. Attackers can commit symlinks pointing outside the workspace and use prompt injection to make...
PT-2026-109740
Name of the Vulnerable Software and Affected Versions phi versions 0.1.1 through 0.28.4 open-multi-agent affected versions not specified Description An improper link resolution issue allows malicious repositories to bypass the workspace only writes restriction by exploiting lexical-only path chec...
CVE-2026-108599: Improper Link Resolution Before File Access
phi 0.1.1 through 0.28.4 contains an improper link resolution vulnerability that allows malicious repositories to bypass workspaceonlywrites by exploiting lexical-only path checks in the permission gate. Attackers can commit symlinks pointing outside the workspace and use prompt injection to make...
CVE-2026-108119: Improper Link Resolution Before File Access
A flaw was found in busybox. The tar applet's deferred link-creation handling for symlink and hardlink entries with unsafe-looking targets does not validate that the resolved destination remains inside the extraction directory once the deferred link is created. An attacker can craft a tar archive...
CVE-2026-107608
Improper link resolution before file access in the asset bundling output handling in AWS aws-cdk-lib before 2.267.0 might allow a context-dependent actor to cause files from the build host to be published as the deployed asset. To remediate this issue, users should upgrade to version 2.267.0 or...
CVE-2026-107608 Improper link resolution in asset bundling output handling in aws-cdk-lib
Improper link resolution before file access in the asset bundling output handling in AWS aws-cdk-lib before 2.267.0 might allow a context-dependent actor to cause files from the build host to be published as the deployed asset. To remediate this issue, users should upgrade to version 2.267.0 or...
CVE-2026-107608 Improper link resolution in asset bundling output handling in aws-cdk-lib
Improper link resolution before file access in the asset bundling output handling in AWS aws-cdk-lib before 2.267.0 might allow a context-dependent actor to cause files from the build host to be published as the deployed asset. To remediate this issue, users should upgrade to version 2.267.0 or...
CVE-2026-107608
The aws-cdk-lib library, versions prior to 2.267.0 , is vulnerable to improper link resolution (CWE-59) during asset bundling output handling. This flaw occurs because the system fails to properly resolve links before accessing files, potentially allowing a context-dependent actor to cause files ...
CVE-2026-107578
Improper link resolution and external control of file paths in the administrative command-line operations of hMailServer.exe in Progressive Robot hMailServer 6.3.4 and 6.3.5 allow a local attacker who already runs code as the low-privilege service account to escalate privilege. On Windows,...
EUVD-2026-94860
Improper link resolution and external control of file paths in the administrative command-line operations of hMailServer.exe in Progressive Robot hMailServer 6.3.4 and 6.3.5 allow a local attacker who already runs code as the low-privilege service account to escalate privilege. On Windows,...
CVE-2026-107578
Progressive Robot hMailServer versions 6.3.4 and 6.3.5 are vulnerable to local privilege escalation due to improper link resolution and external control of file paths in the hMailServer.exe administrative command-line operations. On Windows , a local attacker controlling the low-privilege service...
CVE-2026-107608: Improper Link Resolution Before File Access
Improper link resolution before file access in the asset bundling output handling in AWS aws-cdk-lib before 2.267.0 might allow a context-dependent actor to cause files from the build host to be published as the deployed asset. To remediate this issue, users should upgrade to version 2.267.0 or...
PT-2026-108194
Name of the Vulnerable Software and Affected Versions aws-cdk-lib versions prior to 2.267.0 Description Improper link resolution before file access in the asset bundling output handling allows a context-dependent actor to cause files from the build host to be published as the deployed asset...
CVE-2026-89091: Improper Link Resolution Before File Access
A flaw was found in ansible-core. When installing a collection with ansible-galaxy collection install, the archive extractor validates member paths using lexical path normalisation os.path.abspath instead of resolving symbolic links os.path.realpath, and it performs no containment check on...
CentOS Linux 7 [TuxCare] Security Update: bsdcpio / bsdtar / libarchive / libarchive-devel Multiple Vulnerabilities (CENTOS7:CLSA-2026:1777544831)
The CentOS Linux 7 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare CENTOS7:CLSA-2026:1777544831 advisory. - An improper link resolution flaw while extracting an archive can lead to changing the access control list ACL of the target of the lin...
CVE-2026-102242
Improper link resolution CWE-59 / CWE-22 in the allowedLocalRoots path validation in Google MCP Toolbox for Databases versions 1.2.0 through 1.9.0 allows a remote authenticated attacker with tool execution permissions to bypass directory boundary restrictions via symbolic links. Because path...