8401 matches found
[SECURITY] Fedora 39 Update: dotnet7.0-7.0.119-1.fc39
.NET is a fast, lightweight and modular platform for creating cross platform applications that work on Linux, macOS and Windows. It particularly focuses on creating console applications, web applications and micro-services. .NET contains a runtime conforming to .NET Standards a set of framework...
Power BI Client JS SDK Unauthenticated Access
The vulnerability of the tools and libraries used for data processing and report rendering in Power BI client JS SDK is related to insufficient validation of input data. Exploiting this vulnerability can allow an attacker to gain unauthorized access to protected information using specially create...
ROS-20240424-01
A vulnerability in the ImageIO component of Oracle GraalVM Enterprise Edition virtual machine exists due to insufficient input validation. Exploitation of the vulnerability could allow an attacker acting remotely to cause a denial of service. remotely to cause a denial of service A vulnerability ...
Important: Red Hat Security Advisory: glibc security update
An update for glibc is now available for Red Hat Enterprise Linux 9. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability from the...
USN-6784-1 cjson vulnerabilities
It was discovered that cJSON incorrectly handled certain input. An attacker could possibly use this issue to cause cJSON to crash, resulting in a denial of service. This issue only affected Ubuntu 22.04 LTS and Ubuntu 23.10. CVE-2023-50471, CVE-2023-50472 Luo Jin discovered that cJSON incorrectly...
PT-2024-8711 · Kingsoft · Kingsoft Wps Office
Name of the Vulnerable Software and Affected Versions: Kingsoft WPS Office versions 12.2.0.13110 through 12.2.0.17119 Description: The issue is related to improper path validation in the promecefpluginhost.exe file, allowing an attacker to load an arbitrary Windows library. This can lead to the...
Important: glibc security update
The glibc packages provide the standard C libraries libc, POSIX thread libraries libpthread, standard math libraries libm, and the name service cache daemon nscd used by multiple programs on the system. Without these libraries, the Linux system cannot function correctly. Security Fixes: glibc:...
PT-2024-6108 · Microsoft +1 · Ntasn1.Dll +3
Name of the Vulnerable Software and Affected Versions: CORSAIR iCUE version 5.9.105 Description: The issue is related to insufficient protection of service data due to the loading of dynamic libraries, including MSASN1.dll, NTASN1.dll, and profapi.dll, in the cuepkg-1.2.6 subdirectory of the...
RHEL 9 : glibc (RHSA-2024:3339)
The remote Redhat Enterprise Linux 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2024:3339 advisory. The glibc packages provide the standard C libraries libc, POSIX thread libraries libpthread, standard math libraries libm, and the name...
Moderate: Red Hat Security Advisory: motif security update
An update for motif is now available for Red Hat Enterprise Linux 8. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability from the...
Important: glibc security update
The glibc packages provide the standard C libraries libc, POSIX thread libraries libpthread, standard math libraries libm, and the name service cache daemon nscd used by multiple programs on the system. Without these libraries, the Linux system cannot function correctly. Security Fixes: glibc: Ou...
PT-2024-40315
Name of the Vulnerable Software and Affected Versions Bundle versions prior to 3.7 Description The issue concerns a security problem in JSON Web Token JWT libraries, which can be exploited to generate trusted device cookies, effectively bypassing two-factor authentication. Recommendations For...
GHSA-4RR6-GF59-GGW5 namshi/jose - Verification bypass
Several widely-used JSON Web Token JWT libraries, including node-jsonwebtoken, pyjwt, namshi/jose, php-jwt, and jsjwt, are affected by critical vulnerabilities that could allow attackers to bypass the verification step when using asymmetric keys RS256, RS384, RS512, ES256, ES384, ES512...
GHSA-9GXV-X7RP-R2HC gree/jose - "None" Algorithm treated as valid in tokens
Several widely-used JSON Web Token JWT libraries, including node-jsonwebtoken, pyjwt, namshi/jose, php-jwt, and jsjwt, are affected by critical vulnerabilities that could allow attackers to bypass the verification step when using asymmetric keys RS256, RS384, RS512, ES256, ES384, ES512...
gree/jose - "None" Algorithm treated as valid in tokens
Several widely-used JSON Web Token JWT libraries, including node-jsonwebtoken, pyjwt, namshi/jose, php-jwt, and jsjwt, are affected by critical vulnerabilities that could allow attackers to bypass the verification step when using asymmetric keys RS256, RS384, RS512, ES256, ES384, ES512...
Amazon Linux 2023 : python3-bson, python3-pymongo, python3-pymongo-gridfs (ALAS2023-2024-614)
It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2023-2024-614 advisory. Versions of the package pymongo before 4.6.3 are vulnerable to Out-of-bounds Read in the bson module. Using the crafted payload the attacker could force the parser to deserialize unmanaged...
[SECURITY] Fedora 39 Update: stb-0^20240213gitae721c5-6.fc39
Single-file public domain libraries for C/C++...
[SECURITY] Fedora 38 Update: stb-0^20240213gitae721c5-5.fc38
Single-file public domain libraries for C/C++...
RHEL 9 : redis (Unpatched Vulnerability)
The remote Redhat Enterprise Linux 9 host has one or more packages installed that are affected by multiple vulnerabilities that have been acknowledged by the vendor but will not be patched. - redis: heap overflow in the lua cjson and cmsgpack libraries CVE-2022-24834 - Redis is an in-memory...
nss bug fix update
An update is available for nss. This update affects Rocky Linux 9. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list Network Security Services NSS is a set of libraries designed to support the...