1125 matches found
CVE-2025-5302
A flaw was found in the JSONReader component of the llamaindex Python package, where the depthfirstyield function has no limit on the recursive number of times it is called. This vulnerability causes Python to reach its maximum recursive depth when parsing deeply nested JSON files. The program...
aimon-llamaindex (>=0.0.6, <=0.0.9), aiqtoolkit-llama-index (>=1.1.0a20250429, <=1.2.0rc1) +671 more potentially affected by CVE-2025-5302 via llama-index-core (>=0.9.56, <=0.12.37)
llama-index-core PYPI version =0.9.56, =0.0.6, =1.1.0a20250429, =3.0.0, =1.0.0, =0.0.3, =1.0.0rc1, =0.2.1.dev0, =0.2.1.dev0, =0.1.3, =0.1.169, =0.1.3, =0.3.0, =0.1.0b1, =0.0.52, =0.0.2, =0.0.5 and more Source cves: CVE-2025-5302 Source advisory: GHSA-7753-XRFW-CH36...
aimon-llamaindex (>=0.0.6, <=0.0.9), aiqtoolkit-llama-index (>=1.1.0a20250429, <=1.2.0rc1) +671 more potentially affected by CVE-2025-5302 via llama-index-core (>=0.9.56, <=0.12.37)
llama-index-core PYPI version =0.9.56, =0.0.6, =1.1.0a20250429, =3.0.0, =1.0.0, =0.0.3, =1.0.0rc1, =0.2.1.dev0, =0.2.1.dev0, =0.1.3, =0.1.169, =0.1.3, =0.3.0, =0.1.0b1, =0.0.52, =0.0.2, =0.0.5 and more Source cves: CVE-2025-5302 Source advisory: OSV:GHSA-7753-XRFW-CH36...
LlamaIndex affected by a Denial of Service (DOS) in JSONReader
A denial of service vulnerability exists in the JSONReader component of the run-llama/llamaindex repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth...
Uncontrolled Recursion
Overview llama-index-core is an Interface between LLMs and your data Affected versions of this package are vulnerable to Uncontrolled Recursion via the JSONReader component. An attacker can cause excessive resource consumption and crash the process by submitting deeply nested JSON files...
aimon-llamaindex (>=0.0.6, <=0.0.9), aiqtoolkit-llama-index (>=1.1.0a20250429, <=1.2.0rc1) +671 more potentially affected by CVE-2025-5302 via llama-index-core (>=0.9.56, <=0.12.37)
llama-index-core PYPI version =0.9.56, =0.0.6, =1.1.0a20250429, =3.0.0, =1.0.0, =0.0.3, =1.0.0rc1, =0.2.1.dev0, =0.2.1.dev0, =0.1.3, =0.1.169, =0.1.3, =0.3.0, =0.1.0b1, =0.0.52, =0.0.2, =0.0.5 and more Source cves: CVE-2025-5302 Source advisory: SNYK:PYTHON-LLAMAINDEXCORE-12304061...
CVE-2025-5302
A denial of service vulnerability exists in the JSONReader component of the run-llama/llamaindex repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth...
aimon-llamaindex (>=0.0.6, <=0.0.9), aiqtoolkit-llama-index (>=1.1.0a20250429, <=1.2.0rc1) +671 more potentially affected by CVE-2025-5302 via llama-index-core (>=0.9.56, <=0.12.37)
llama-index-core PYPI version =0.9.56, =0.0.6, =1.1.0a20250429, =3.0.0, =1.0.0, =0.0.3, =1.0.0rc1, =0.2.1.dev0, =0.2.1.dev0, =0.1.3, =0.1.169, =0.1.3, =0.3.0, =0.1.0b1, =0.0.52, =0.0.2, =0.0.5 and more Source cves: CVE-2025-5302 Source advisory: MEND:CVE-2025-5302...
CVE-2025-5302 Denial of Service (DOS) in JSONReader in run-llama/llama_index
A denial of service vulnerability exists in the JSONReader component of the run-llama/llamaindex repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth...
CVE-2025-5302
A denial of service vulnerability exists in the JSONReader component of the run-llama/llamaindex repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth...
CVE-2025-5302
The CVE-2025-5302 affects the JSONReader in run-llama/llama_index v0.12.37, where unconstrained recursion on deeply nested JSON can exhaust Python recursion depth, causing high CPU/memory use and potential DoS. The issue is resolved in v0.12.38. Remediation: upgrade llama_index to 0.12.38 or late...
CVE-2025-5302 Denial of Service (DOS) in JSONReader in run-llama/llama_index
A denial of service vulnerability exists in the JSONReader component of the run-llama/llamaindex repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth...
aiqtoolkit-llama-index (>=1.1.0a20250429, <=1.2.0rc1), airunner (>=3.0.0, <=3.1.14) +35 more potentially affected by CVE-2025-5302 via llama-index (>=0.10.0, <=0.12.36)
llama-index PYPI version =0.10.0, =1.1.0a20250429, =3.0.0, =1.0.5, =0.2.53, =0.1.3, =0.1.169, =0.1.3, =0.3.0, =0.0.52, =1.0.9, =1.0.3.post1, =0.1.2, =0.5.5 and more Source cves: CVE-2025-5302 Source advisory: MEND:CVE-2025-5302...
CVE-2025-5302: Uncontrolled Recursion
A denial of service vulnerability exists in the JSONReader component of the run-llama/llamaindex repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth...
PT-2025-34665
Name of the Vulnerable Software and Affected Versions: run-llama/llama index versions prior to 0.12.38 Description: A denial of service issue exists in the JSONReader component. The issue is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting i...
Deserialization of Untrusted Data
Overview llamafactory is an Easy-to-use LLM fine-tuning framework Affected versions of this package are vulnerable to Deserialization of Untrusted Data via the Checkpoint path parameter in the WebUI interface during the training process. An attacker can exploit this vulnerability by supplying a...
ai-dynamo (>=0.1.0, <=0.3.0), llama-index-llms-openllm (>=0.2.0, <=0.4.0) +1 more potentially affected by CVE-2025-54381 via bentoml (>=1.4.1, <=1.4.8)
bentoml PYPI version =1.4.1, =0.1.0, =0.2.0, =0.6.20, =0.6.30 Source cves: CVE-2025-54381 Source advisory: OSV:GHSA-MRMQ-3Q62-6CC8...
ai-dynamo (>=0.1.0, <=0.3.0), llama-index-llms-openllm (>=0.2.0, <=0.4.0) +1 more potentially affected by CVE-2025-54381 via bentoml (>=1.4.1, <=1.4.8)
bentoml PYPI version =1.4.1, =0.1.0, =0.2.0, =0.6.20, =0.6.30 Source cves: CVE-2025-54381 Source advisory: GHSA-MRMQ-3Q62-6CC8...
ai-dynamo (>=0.1.0, <=0.3.0), llama-index-llms-openllm (>=0.2.0, <=0.4.0) +1 more potentially affected by CVE-2025-54381 via bentoml (>=1.4.1, <=1.4.8)
bentoml PYPI version =1.4.1, =0.1.0, =0.2.0, =0.6.20, =0.6.30 Source cves: CVE-2025-54381 Source advisory: SNYK:PYTHON-BENTOML-11327149...
World-Writable NLTK Cache Directory Enables Local Users to Tamper with or Delete NLP Data
Description The llamaindex library sets the NLTK data directory to a subdirectory of the codebase by default e.g., static/nltkcache inside the package directory. In multi-user environments or shared hosting, this directory is world-writable or accessible by multiple users. As a result, any user c...