302341 matches found
CVE-2025-24071
CVE-2025-24071 Vulnérabilité d'usurpation de l'Explorateur de fichiers Windows - CVE-2025-24071 Divulguez le hash NTLM de Windows via l'extraction d'un fichier ZIP ou RAR manipulé, et en exploitant une vulnérabilité dans la gestion des fichiers .library-ms un type de fichier utilisé par Windows...
libinjection
libinjection SQL / SQLI tokenizer parser analyzer. For C and C++ PHP Python Lua Java external port LuaJIT/FFI https://github.com/p0pr0ck5/lua-ffi-libinjection external port See https://www.client9.com/ for details and presentations. Simple example: include include include include "libinjection.h"...
fully-homomorphic-encryption
The FHE Team at Google, in partnership with multiple collaborators, is working to Unlock Fully Homomorphic Encryption for Google and the world. Make it Easy Make it Fast at Scale What started with a C++ transpiler, has morphed into two new libraries: HEIR is the new development platform and...
Posh-SSH
Posh-SSH Description Windows Powershell module that leverages a custom version of the SSH.NET Library to provide basic SSH functionality in Powershell. The main purpose of the module is to facilitate automating actions against one or multiple SSH enabled Linux servers from a Windows Host. As of...
masc
masc A malware web scanner developed during CyperCamp Hackathon 2017 About homepage PyPI Features At the moment, there are some features avaiable for any type of website custom or CMS and some of them only available for specific platforms: Scan any website for malware using OWASP WebMalwareScanne...
Check-CVE-2021-23383
Check-CVE-2021-23383 تحقق من شروط استغلال CVE-2021-23383 عبر تقييم إصدار مكتبة handlebars...
scapy
Scapy Scapy est un puissant programme interactif de manipulation de paquets et une bibliothèque, basés sur Python. Il est capable de forger ou décoder des paquets d'un grand nombre de protocoles, de les envoyer sur le réseau, de les capturer, de les stocker ou de les lire à l'aide de fichiers pca...
vuke
vuke Research tool for analyzing and reproducing vulnerable Bitcoin key generation. Features Modular architecture - pluggable sources and transforms Multiple input sources Numeric ranges test weak seeds Wordlists brainwallet analysis Timestamps time-based PRNG exploitation Stdin streaming pipelin...
capslock
Capslock is a capability analysis CLI for Go packages that informs users of which privileged operations a given package can access. This works by classifying the capabilities of Go packages by following transitive calls to privileged standard library operations. The recent increase in supply chai...
sslyze
SSLyze SSLyze هي أداة مسح SSL/TLS سريعة وقوية ومكتبة بايثون. يمكن لـ SSLyze تحليل تكوين SSL/TLS لخادم عن طريق الاتصال به، وذلك لضمان استخدام إعدادات تشفير قوية الشهادة، مجموعات التشفير، المنحنيات الإهليليجية، إلخ، وأنه غير معرض للهجمات المعروفة على TLS Heartbleed, ROBOT, OpenSSL CCS injection، إل...
telegram-osint-lib
Telegram OSINT scenario library Description A lot of Telegram API libraries around, but none of them demonstrates how to execute complex scenarios like draining all photos from channels, monitor users presence or register new account. This projects aims to correct situation: now you can easily...
php-encryption
php-encryption composer require defuse/php-encryption Ceci est une bibliothèque permettant de chiffrer des données avec une clé ou un mot de passe en PHP. Elle nécessite PHP 5.6 ou plus récent et OpenSSL 1.0.1 ou plus récent. Nous recommandons d'utiliser une version de PHP qui bénéficie encore d'...
telegram-story-scraper
Telegram Story Scraper 📱 A Python script that allows you to automatically scrape and download stories from your Telegram friends using the Telethon library. The script continuously monitors and saves both photos and videos from stories, along with their metadata. TGSS - Main Interface Important...
CVE-2025-32463_PoC
CVE-2025-32463 NVD CVE-2025-32463 في معظم الحالات، لا يتم تثبيت GCC افتراضيًا على الخوادم المستهدفة. يوفر هذا الإثبات المفاهيمي نسخة مُجمّعة مسبقًا لضمان إمكانية تنفيذه فورًا على الأنظمة المتأثرة. الاستخدام 1. قم بتجميع ملف woot1337.c: gcc -shared -fPIC -Wl,-init,woot -o libwoot1337.so woot1337.c...
CVE-2023-38408
ثغرة OpenSSH - CVE-2023-38408 📚 مقدمة تم العثور على ثغرة في OpenSSH قبل الإصدار 9.3p2. تحتوي ميزة PKCS11 في ssh-agent في OpenSSH على مسار بحث غير موثوق بما يكفي، مما يؤدي إلى تنفيذ تعليمات برمجية عن بُعد إذا تم توجيه الوكيل إلى نظام يتحكم فيه المهاجم الكود في /usr/lib ليس بالضرورة آمنًا للتحميل ف...
xmloxide
xmloxide A pure Rust reimplementation of libxml2 — the de facto standard XML/HTML parsing library in the open-source world. libxml2 became officially unmaintained in December 2025 with known security issues. xmloxide aims to be a memory-safe, high-performance replacement that passes the same...
Steganography
Steganography Table of Contents Installation Byte Sequence Manipulation WavSteg LSBSteg StegDetect If you are unfamiliar with steganography techniques, I have also written a basic overview of the field in Steganography: Hiding Data Inside Data. Installation This project is on PyPI and can be...
openssl_g2.5_CVE-2014-3566
OpenSSL 1.0.1g 7 Apr 2014 Copyright c 1998-2011 The OpenSSL Project Copyright c 1995-1998 Eric A. Young, Tim J. Hudson جميع الحقوق محفوظة. الوصف مشروع OpenSSL هو جهد تعاوني لتطوير مجموعة أدوات قوية، بجودة تجارية، كاملة الميزات، ومفتوحة المصدر تنفّذ بروتوكولي طبقة المقابس الآمنة SSL v2/v3 وطبقة أم...
wolfCOSE
wolfCOSE wolfCOSE is a lightweight and fast C library implementing core CBOR and COSE standards, backed by wolfSSL for cryptography. Supported Standards & RFCs Core Specifications: RFC 8949 - Concise Binary Object Representation CBOR RFC 9052 - CBOR Object Signing and Encryption COSE RFC 9053 -...
wordlist.rb
Wordlist Source Issues Documentation Description Wordlist est une bibliothèque Ruby et un CLI pour lire, combiner, muter et construire des listes de mots wordlists, efficacement. Fonctionnalités Prend en charge la lecture de listes de mots .txt, ainsi que des listes de mots compressées .gz, .bz2,...