32 matches found
ipynb-path (>=0.1.2, <=0.1.3), jupyter-kernel-gateway (>=0.5.0, <=1.2.2) potentially affected by CVE-2019-10255 via notebook (4.4.1)
notebook PYPI version 4.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on notebook and may be impacted: - ipynb-path =0.1.2, =0.5.0, =1.2.2 Source cves: CVE-2019-10255 Source advisory: OSV:PYSEC-2026-2683...
ipynb-path (>=0.1.2, <=0.1.3), jupyter-kernel-gateway (>=0.5.0, <=1.2.2) potentially affected by CVE-2021-32797 via notebook (4.4.1)
notebook PYPI version 4.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on notebook and may be impacted: - ipynb-path =0.1.2, =0.5.0, =1.2.2 Source cves: CVE-2021-32797 Source advisory: OSV:PYSEC-2026-688...
hugo-jupyter (>=0.2.1, <=0.3.0), ipynb-path (>=0.1.2, <=0.1.3) +3 more potentially affected by unknown CVE via notebook (>=4.2.3, <=5.4.1)
notebook PYPI version =4.2.3, =0.2.1, =0.1.2, =0.5.0, =1.0.0, =0.1.0, =0.2.0.dev1 Source cves: unknown CVE Source advisory: MEND:WS-2018-0628...
hugo-jupyter (>=0.2.1, <=0.3.0), ipynb-path (>=0.1.2, <=0.1.3) +2 more potentially affected by unknown CVE via notebook (>=4.2.3, <=5.0.0)
notebook PYPI version =4.2.3, =0.2.1, =0.1.2, =0.5.0, =0.1.0, =0.2.0.dev1 Source cves: unknown CVE Source advisory: MEND:WS-2019-0025...
hugo-jupyter (>=0.2.1, <=0.3.0), ipynb-path (>=0.1.2, <=0.1.3) +3 more potentially affected by unknown CVE via notebook (>=4.2.3, <=5.4.1)
notebook PYPI version =4.2.3, =0.2.1, =0.1.2, =0.5.0, =1.0.0, =0.1.0, =0.2.0.dev1 Source cves: unknown CVE Source advisory: MEND:WS-2019-0027...
hugo-jupyter (>=0.2.1, <=0.3.0), ipynb-path (>=0.1.2, <=0.1.3) +3 more potentially affected by unknown CVE via notebook (>=4.2.3, <=5.4.1)
notebook PYPI version =4.2.3, =0.2.1, =0.1.2, =0.5.0, =1.0.0, =0.1.0, =0.2.0.dev1 Source cves: unknown CVE Source advisory: MEND:WS-2016-0075...
PYSEC-2026-169
Dask distributed is a distributed task scheduler for Dask. Prior to 2026.1.0, when Jupyter Lab, jupyter-server-proxy, and Dask distributed are all run together, it is possible to craft a URL which will result in code being executed by Jupyter due to a cross-side-scripting XSS bug in the Dask...
CVE-2026-23528
Dask distributed is a distributed task scheduler for Dask. Prior to 2026.1.0, when Jupyter Lab, jupyter-server-proxy, and Dask distributed are all run together, it is possible to craft a URL which will result in code being executed by Jupyter due to a cross-side-scripting XSS bug in the Dask...
GHSA-29GW-9793-FVW7 IPython vulnerable to command injection via set_term_title
IPython provides an interactive Python shell and Jupyter kernel to use Python interactively. Versions prior to 8.10.0 are vulnerable to command injection in the settermtitle function under specific conditions. This has been patched in version 8.10.0. Impact Users are only vulnerable when calling...
ipynb-path (>=0.1.2, <=0.1.3), jupyter-kernel-gateway (>=0.5.0, <=1.2.2) potentially affected by CVE-2022-29238 via notebook (4.4.1)
notebook PYPI version 4.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on notebook and may be impacted: - ipynb-path =0.1.2, =0.5.0, =1.2.2 Source cves: CVE-2022-29238 Source advisory: OSV:GHSA-V7VQ-3X77-87VG...
ipynb-path (>=0.1.2, <=0.1.3), jupyter-kernel-gateway (>=0.5.0, <=1.2.2) potentially affected by CVE-2022-29238 via notebook (4.4.1)
notebook PYPI version 4.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on notebook and may be impacted: - ipynb-path =0.1.2, =0.5.0, =1.2.2 Source cves: CVE-2022-29238 Source advisory: OSV:PYSEC-2022-212...
ipynb-path (>=0.1.2, <=0.1.3), jupyter-kernel-gateway (>=0.5.0, <=1.2.2) potentially affected by CVE-2019-9644 via notebook (4.4.1)
notebook PYPI version 4.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on notebook and may be impacted: - ipynb-path =0.1.2, =0.5.0, =1.2.2 Source cves: CVE-2019-9644 Source advisory: OSV:GHSA-HHX8-CR55-QCXX...
ipynb-path (>=0.1.2, <=0.1.3), jupyter-kernel-gateway (>=0.5.0, <=1.2.2) potentially affected by CVE-2022-24758 via notebook (4.4.1)
notebook PYPI version 4.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on notebook and may be impacted: - ipynb-path =0.1.2, =0.5.0, =1.2.2 Source cves: CVE-2022-24758 Source advisory: OSV:GHSA-M87F-39Q9-6F55...
ipynb-path (>=0.1.2, <=0.1.3), jupyter-kernel-gateway (>=0.5.0, <=1.2.2) potentially affected by CVE-2022-24758 via notebook (4.4.1)
notebook PYPI version 4.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on notebook and may be impacted: - ipynb-path =0.1.2, =0.5.0, =1.2.2 Source cves: CVE-2022-24758 Source advisory: OSV:PYSEC-2022-180...
ipynb-path (>=0.1.2, <=0.1.3), jupyter-kernel-gateway (>=0.5.0, <=1.2.2) potentially affected by CVE-2021-32798 via notebook (4.4.1)
notebook PYPI version 4.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on notebook and may be impacted: - ipynb-path =0.1.2, =0.5.0, =1.2.2 Source cves: CVE-2021-32798 Source advisory: OSV:GHSA-HWVQ-6GJX-J797...
ipynb-path (>=0.1.2, <=0.1.3), jupyter-kernel-gateway (>=0.5.0, <=1.2.2) potentially affected by CVE-2021-32797 via notebook (4.4.1)
notebook PYPI version 4.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on notebook and may be impacted: - ipynb-path =0.1.2, =0.5.0, =1.2.2 Source cves: CVE-2021-32797 Source advisory: OSV:GHSA-4952-P58Q-6CRX...
ipynb-path (>=0.1.2, <=0.1.3), jupyter-kernel-gateway (>=0.5.0, <=1.2.2) potentially affected by CVE-2020-26215 via notebook (4.4.1)
notebook PYPI version 4.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on notebook and may be impacted: - ipynb-path =0.1.2, =0.5.0, =1.2.2 Source cves: CVE-2020-26215 Source advisory: OSV:PYSEC-2020-215...
ipynb-path (>=0.1.2, <=0.1.3), jupyter-kernel-gateway (>=0.5.0, <=1.2.2) potentially affected by CVE-2020-26215 via notebook (4.4.1)
notebook PYPI version 4.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on notebook and may be impacted: - ipynb-path =0.1.2, =0.5.0, =1.2.2 Source cves: CVE-2020-26215 Source advisory: OSV:GHSA-C7VM-F5P4-8FQH...
ipynb-path (>=0.1.2, <=0.1.3), jupyter-kernel-gateway (>=0.5.0, <=1.2.2) potentially affected by CVE-2018-21030 via notebook (4.4.1)
notebook PYPI version 4.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on notebook and may be impacted: - ipynb-path =0.1.2, =0.5.0, =1.2.2 Source cves: CVE-2018-21030 Source advisory: OSV:GHSA-JQWC-JM56-WCWJ...
ipynb-path (>=0.1.2, <=0.1.3), jupyter-kernel-gateway (>=0.5.0, <=1.2.2) potentially affected by CVE-2018-21030 via notebook (4.4.1)
notebook PYPI version 4.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on notebook and may be impacted: - ipynb-path =0.1.2, =0.5.0, =1.2.2 Source cves: CVE-2018-21030 Source advisory: OSV:PYSEC-2019-157...