68960 matches found
PT-2026-106844
Name of the Vulnerable Software and Affected Versions RabbitMQ Java client library versions prior to 5.35.0 Description The ConnectionFactoryConfigurator.load function includes the raw URI value in wrapped exceptions when AMQP URI parsing fails. Since the URI can contain plaintext usernames and...
CVE-2026-105796: Improper Control of Generation of Code
Kiota is an OpenAPI based HTTP Client code generator. From 0.5.0 until 1.35.0, Kiota's Java and PHP documentation-comment sanitizers delete block-comment terminators rather than neutralizing them, allowing overlapping characters to reform a terminator and place attacker-controlled OpenAPI text...
PT-2026-107256
Five more CVE IDs are in. MITRE assigned CVE-2026-95248 and CVE-2026-95250 through CVE-2026-95253 to five findings we published in batch 11 — SCADA/HMI, graph analytics, document viewing and data-centre console management. All five were found, verified and disclosed by our AI-driven research...
CVE-2026-106122: Encoding Error
The RabbitMQ Java client library allows Java and JVM-based applications to connect to and interact with RabbitMQ nodes. Prior to 5.36.0, ValueReader.readShortstr decodes malformed UTF-8 bytes into replacement characters that can re-encode beyond the AMQP shortstr limit enforced by...
PT-2026-106843
Name of the Vulnerable Software and Affected Versions RabbitMQ Java client library versions prior to 5.36.0 Description The ValueReader.readShortstr function decodes malformed UTF-8 bytes into replacement characters that can re-encode beyond the AMQP shortstr limit enforced by...
CVE-2026-106453: Memory Allocation with Excessive Size Value
yawkat LZ4 Java provides LZ4 compression for Java. Prior to 1.11.2, LZ4DecompressorWithLength uses getDecompressedLength to trust the four-byte decompressed-length header before validating the compressed input, allowing a five-byte attacker-supplied input whose header declares a large output size...
CVE-2026-106452: Memory Allocation with Excessive Size Value
yawkat LZ4 Java provides LZ4 compression for Java. Prior to 1.11.2, net.jpountz.lz4.LZ4BlockInputStream refill validates that the compressedLen field in a legacy LZ4Block header is nonnegative but allocates a compressed-input buffer of that attacker-controlled size before reading payload data,...
PT-2026-107185
Name of the Vulnerable Software and Affected Versions yawkat LZ4 Java versions prior to 1.11.4 Description A flaw exists in the net.jpountz.lz4.LZ4BlockInputStream class when the stopOnEmptyBlock variable is set to false. In this configuration, the system handles well-formed empty LZ4Blocks by...
PT-2026-107241
Name of the Vulnerable Software and Affected Versions yawkat LZ4 Java versions prior to 1.11.2 Description The refill function in net.jpountz.lz4.LZ4BlockInputStream fails to properly validate the compressedLen field in a legacy LZ4Block header. While it checks that the value is non-negative, it...
PT-2026-107242
Name of the Vulnerable Software and Affected Versions yawkat LZ4 Java versions prior to 1.11.2 Description The LZ4DecompressorWithLength component trusts the four-byte decompressed-length header via the getDecompressedLength function before validating the compressed input. This allows an attacker...
CVE-2026-106451: Time-of-check Time-of-use (TOCTOU) Race Condition
yawkat LZ4 Java provides LZ4 compression for Java. From 1.7.0 until 1.11.4, net.jpountz.util.Native.load uses File.createTempFile to create an exclusive temporary .lck file but derives the native-library path by removing the suffix, then FileOutputStream opens that predictable path without...
SUSE SLES12: java-11-openjdk / java-11-openjdk-demo / java-11-openjdk-devel / etc (SUSE-SU-2026:4515-1)
The remote SUSE Linux SLES12 / SLESSAP12 host has packages installed that are affected by multiple vulnerabilities as referenced in the SUSE-SU-2026:4515-1 advisory. - CVE-2026-60589: improve resource resolving bsc1275777. - CVE-2026-61308: enhance HTTP connections bsc1275778. - CVE-2026-70907:...
Apache Curator 5.9.0 Java Deserialization
Apache Curator version 5.9.0 contains an unsafe Jackson deserialization issue in its service-discovery component that can instantiate an attacker-controlled payload class. !/usr/bin/env python Apache Curator 5.9.0 Java Deserialization Vendor: The Apache Software Foundation Product web page:...
CVE-2026-106123: Generation of Error Message Containing Sensitive Information
The RabbitMQ Java client library allows Java and JVM-based applications to connect to and interact with RabbitMQ nodes. Prior to 5.35.0, ConnectionFactoryConfigurator.load includes the raw uri value in wrapped exceptions when AMQP URI parsing fails. Because the URI may contain a plaintext usernam...
SUSE CVE-2026-66055
Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift C++, Java, Go, netstd, Python and Delphi bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue...
org.apache.beam:beam-sdks-java-io-snowflake (>=2.25.0, <=2.60.0) potentially affected by CVE-2026-86597 via net.snowflake:snowflake-jdbc (3.12.11)
net.snowflake:snowflake-jdbc MAVEN version 3.12.11 is affected by a known vulnerability. The following packages have a transitive dependency on net.snowflake:snowflake-jdbc and may be impacted: - org.apache.beam:beam-sdks-java-io-snowflake =2.25.0, =2.60.0 Source cves: CVE-2026-86597 Source...
net.snowflake:spark-snowflake_2.11 (>=2.5.6-spark_2.2, <=2.5.6-spark_2.4), net.snowflake:spark-snowflake_2.12 (2.5.6-spark_2.4) +1 more potentially affected by CVE-2026-86597 via net.snowflake:snowflake-jdbc (3.11.0)
net.snowflake:snowflake-jdbc MAVEN version 3.11.0 is affected by a known vulnerability. The following packages have a transitive dependency on net.snowflake:snowflake-jdbc and may be impacted: - net.snowflake:spark-snowflake2.11 =2.5.6-spark2.2, =2.5.6-spark2.4 - net.snowflake:spark-snowflake2.12...
net.snowflake:spark-snowflake_2.11 (>=2.7.2-spark_2.2, <=2.7.2-spark_2.4), net.snowflake:spark-snowflake_2.12 (2.7.2-spark_2.4) +1 more potentially affected by CVE-2026-86597 via net.snowflake:snowflake-jdbc (3.12.7)
net.snowflake:snowflake-jdbc MAVEN version 3.12.7 is affected by a known vulnerability. The following packages have a transitive dependency on net.snowflake:snowflake-jdbc and may be impacted: - net.snowflake:spark-snowflake2.11 =2.7.2-spark2.2, =2.7.2-spark2.4 - net.snowflake:spark-snowflake2.12...
Security Bulletin: Due to the use of Java SE, IBM Sterling Control Center is vulnerable to multiple CVEs (CVE-2026-70906, CVE-2026-61308, CVE-2026-70907, CVE-2026-60589, CVE-2026-16440)
Summary Java SE is used by IBM Sterling Control Center as part of dependency in IBM Semeru Runtime CSPU - Aug 2026 - Includes OpenJDK August 2026 CPU. Vulnerability Details CVEID:CVE-2026-70906 DESCRIPTION: Easily exploitable vulnerability allows unauthenticated attacker with network access via...
CVE-2026-104713
Allocation of resources without limits or throttling vulnerability in the Apache Struts REST plugin. A request body is read into memory without any bound on how much will be accepted, so a single request can cause the server to allocate memory in proportion to its size, exhausting the Java heap a...