Lucene search
+L

298 matches found

Debian CVE
Debian CVE
•added 2026/09/03 8:46 p.m.•20 views

CVE-2026-84185

A flaw was found in the jwcrypto library, which is used for implementing Javascript Object Signing and Encryption JOSE standards. The issue occurs when the library verifies a General JSON Serialization JWS using a set of keys. Due to a coding error, the library fails to correctly identify the...

5.9CVSS5.7AI score0.00131EPSS
SaveExploits0
CVE
CVE
•added 2026/09/03 8:46 p.m.•63 views

CVE-2026-84185

CVE-2026-84185 affects the jwcrypto library, a Python implementation of the JOSE (JSON Object Signing and Encryption) standards. The flaw occurs during verification of a General JSON Serialization JWS against a key set (JWKset): due to a coding error, the library fails to correctly match the key ...

5.9CVSS5.7AI score0.00131EPSS
SaveExploits0References2
Positive Technologies
Positive Technologies
•added 2026/09/03 12:00 a.m.•28 views

PT-2026-85251

A flaw was found in the jwcrypto library, which is used for implementing Javascript Object Signing and Encryption JOSE standards. The issue occurs when the library verifies a General JSON Serialization JWS using a set of keys. Due to a coding error, the library fails to correctly identify the...

5.9CVSS5.7AI score0.00131EPSS
SaveExploits0References10
Positive Technologies
Positive Technologies
•added 2026/08/19 12:00 a.m.•8 views

PT-2026-80653

Summary The ACME client used to issue certificates from Let's Encrypt / Google Public CA / private ACME CAs connects to an acme url, then issues requests to URLs that the ACME server returns in its directory/order/authorization/finalize responses - this is the classic ACME-client SSRF RFC 8555...

7.4CVSS6.3AI score0.00216EPSS
SaveExploits0References8
NVD
NVD
•added 2026/08/18 8:17 p.m.•16 views

CVE-2026-70666

Lemur manages TLS certificate creation. Prior to 1.9.3, an authority-role member could update acmeurl through PUT /api/1/authorities/ without revalidation and direct setupacmeclientnoretry to an attacker-controlled ACME server. ACME directory and order responses contain newNonce, newOrder,...

7.4CVSS0.00216EPSS
SaveExploits0References3
Vulnrichment
Vulnrichment
•added 2026/08/18 7:05 p.m.•13 views

CVE-2026-70666 Lemur: Server-Side Request Forgery via the ACME client following server-controlled URLs

Lemur manages TLS certificate creation. Prior to 1.9.3, an authority-role member could update acmeurl through PUT /api/1/authorities/ without revalidation and direct setupacmeclientnoretry to an attacker-controlled ACME server. ACME directory and order responses contain newNonce, newOrder,...

7.4CVSS5.9AI score0.00216EPSS
SaveExploits0References3
Positive Technologies
Positive Technologies
•added 2026/08/18 12:00 a.m.•18 views

PT-2026-77279

Name of the Vulnerable Software and Affected Versions Lemur versions prior to 1.9.3 Description A member with an authority role can update the acme url via the 'PUT /api/1/authorities/' endpoint without revalidation. This allows the setup acme client no retry function to be directed to an...

7.4CVSS5.7AI score0.00216EPSS
SaveExploits0References11
Tenable Nessus
Tenable Nessus
•added 2026/08/18 12:00 a.m.•15 views

Amazon Linux 2023 : python3-jwt, python3-jwt+crypto (ALAS2023-2026-2051)

It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2023-2026-2051 advisory. PyJWT is a JSON Web Token implementation in Python. Prior to 2.13.0, PyJWKClient passes its uri argument directly to urllib.request.urlopen which uses Python stdlib's default OpenerDirector...

5.3CVSS5.8AI score0.00415EPSS
SaveExploits2References6
Amazon
Amazon
•added 2026/08/17 12:00 a.m.•19 views

Medium: python-jwt

Issue Overview: PyJWT is a JSON Web Token implementation in Python. Prior to 2.13.0, PyJWKClient passes its uri argument directly to urllib.request.urlopen which uses Python stdlib's default OpenerDirector registering HTTPHandler, HTTPSHandler, FTPHandler, FileHandler, and DataHandler. There is...

5.3CVSS5.7AI score0.00415EPSS
SaveExploits2
RedhatCVE
RedhatCVE
•added 2026/08/07 12:55 p.m.•21 views

CVE-2026-50634

A flaw was found in Apache CXF. The JwsJsonContainerRequestFilter component can be exploited to process metadata that has not been authenticated by an accepted signature. This bypasses the application's security assumption that Content-Type or protected HTTP-header metadata originates from a...

6.5CVSS5.6AI score0.0036EPSS
SaveExploits0References5
osv_clsa
osv_clsa
•added 2026/08/04 2:52 p.m.•20 views

CLSA-2026-1784943208 TuxCare security update for 2 packages (2 CVEs)

TuxCare rebuilt 2 packages to address 2 CVEs. Fixed in 0.2.6-tuxcare.1...

7.5CVSS5.7AI score0.01798EPSS
SaveExploits1
PyPA
PyPA
•added 2026/07/13 3:46 p.m.•32 views

joserfc: b64=false RFC7797 JWS payloads bypass JWSRegistry payload-size limits during deserialization

RFC7797 b64=false JWS payloads bypass JWSRegistry payload-size limits during deserialization SummaryTesting revealed that joserfc accepts oversized RFC7797 b64=false JWS payloads without applying JWSRegistry.maxpayloadlength.The normal JWS compact and flattened JSON paths reject payloads above th...

5.3CVSS6.8AI score0.00265EPSS
SaveExploits0References6Affected Software1
RedHat Linux
RedHat Linux
•added 2026/07/11 1:14 a.m.•19 views

python-pyjwt: PyJWT: Denial of Service via processing of crafted detached JWS tokens

A flaw was found in PyJWT. A remote attacker can exploit this by supplying an arbitrarily large Base64URL payload segment when verifying detached JSON Web Signature JWS tokens using the unencoded-payload option. This forces excessive CPU work and memory allocations, leading to a Denial of Service...

5.3CVSS5.5AI score0.00415EPSS
SaveExploits1References5
PyPA
PyPA
•added 2026/07/07 4:03 p.m.•26 views

Authlib: JWS/JWT accepts unknown crit headers (RFC violation → possible authz bypass)

SummaryAuthlib’s JWS verification accepts tokens that declare unknown critical header parameters crit, violating RFC 7515 “must‑understand” semantics. An attacker can craft a signed token with a critical header for example, bork or cnf that strict verifiers reject but Authlib accepts. In...

7.5CVSS5.9AI score0.00262EPSS
SaveExploits1References7Affected Software1
vulnersOsv
vulnersOsv
•added 2026/07/07 11:45 a.m.•3 views

cumulusci (>=3.38.0.dev1, <=3.40.2.dev1), daml-dit-if (>=0.6.0, <=0.6.12) +1 more potentially affected by CVE-2024-28102 via jwcrypto (0.9.1)

jwcrypto PYPI version 0.9.1 is affected by a known vulnerability. The following packages have a transitive dependency on jwcrypto and may be impacted: - cumulusci =3.38.0.dev1, =0.6.0, =0.1.0, =0.9.0 Source cves: CVE-2024-28102 Source advisory: OSV:PYSEC-2026-1484...

6.8CVSS6.3AI score0.0098EPSS
SaveExploits1
EUVD
EUVD
•added 2026/06/26 8:59 p.m.•36 views

EUVD-2026-37805

joserfc: b64=false RFC7797 JWS payloads bypass JWSRegistry payload-size limits during deserialization...

5.3CVSS6.8AI score0.00265EPSS
SaveExploits0References3
SUSE CVE
SUSE CVE
•added 2026/06/19 1:50 a.m.•14 views

SUSE CVE-2026-48990

joserfc is a Python library that provides an implementation of several JSON Object Signing and Encryption JOSE standards. In versions 1.3.4 through 1.6.5, joserfc accepts oversized RFC7797 b64=false JWS payloads without applying JWSRegistry.maxpayloadlength, which can lead to resource exhaustion...

5.3CVSS6.4AI score0.00265EPSS
SaveExploits0References3
osv_ghsa
osv_ghsa
•added 2026/06/18 9:09 p.m.•37 views

GHSA-JC38-X7X8-2XC8 PHP JWT Framework: JWSVerifier uses algorithm from unprotected header, enabling algorithm confusion attacks

Summary JWSVerifier::getAlgorithm in src/Library/Signature/JWSVerifier.php line 144 merges protected and unprotected headers using PHP's spread operator: php $completeHeader = ...$signature-getProtectedHeader, ...$signature-getHeader; In PHP, when spreading arrays with duplicate string keys, the...

9.1CVSS5.5AI score
SaveExploits0References3
Snyk
Snyk
•added 2026/06/18 12:20 a.m.•33 views

Allocation of Resources Without Limits or Throttling

Overview Affected versions of this package are vulnerable to Allocation of Resources Without Limits or Throttling in the deserialization process of RFC7797 JWS payloads with b64=false. An attacker can cause resource exhaustion by submitting a payload that exceeds the intended size limits, bypassi...

8.7CVSS6.6AI score0.00265EPSS
SaveExploits0References2
Positive Technologies
Positive Technologies
•added 2026/06/18 12:00 a.m.•31 views

PT-2026-53185

Summary JWSVerifier::getAlgorithm in src/Library/Signature/JWSVerifier.php line 144 merges protected and unprotected headers using PHP's spread operator: php $completeHeader = ...$signature-getProtectedHeader, ...$signature-getHeader; In PHP, when spreading arrays with duplicate string keys, the...

9.1CVSS5.8AI score
SaveExploits0References4
Rows per page
Query Builder