3178 matches found
CVE-2020-11022: Improper Neutralization of Input During Web Page Generation
In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods i.e. .html, .append, and others may execute untrusted code. This problem is patched in jQuery 3.5.0...
CVE-2020-11022
CVE-2020-11022 affects jQuery versions >=1.2 and =3.5.0 or apply vendor guidance where applicable.
000demo (>=1.0.0, <=1.1.0), 03-npm-abc (>=1.0.0, <=1.1.0) +6503 more potentially affected by CVE-2020-11023 via jquery (>=1.5.1, <=3.4.1)
jquery NPM version =1.5.1, =1.0.0, =1.0.0, =1.0.0, =1.0.0, =0.0.1, =0.2.1, =0.1.75, =0.2.0 - 4.yarntest 1.0.3 - 4design 0.0.1 and more Source cves: CVE-2020-11023 Source advisory: MEND:CVE-2020-11023...
CVE-2020-11023: Improper Neutralization of Input During Web Page Generation
In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods i.e. .html, .append, and others may execute untrusted code. This problem is patched in jQuery 3.5.0...
CVE-2020-11022
In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods i.e. .html, .append, and others may execute untrusted code. This problem is patched in jQuery 3.5.0...
CVE-2020-11023
In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods i.e. .html, .append, and others may execute untrusted code. This problem is patched in jQuery 3.5.0...
Potential XSS vulnerability in jQuery
Impact Passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods i.e. .html, .append, and others may execute untrusted code. Patches This problem is patched in jQuery 3.5.0. Workarounds To workaround the issue without upgrading, adding the...
PT-2020-4421
Name of the Vulnerable Software and Affected Versions: jQuery versions 1.0.3 through 3.4.1 Description: The issue arises from insufficient cleaning of user-provided data when passing HTML elements to jQuery's DOM manipulation methods, such as .html and .append. This can allow an attacker to execu...
CVE-2020-11023 Potential XSS vulnerability in jQuery
In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods i.e. .html, .append, and others may execute untrusted code. This problem is patched in jQuery 3.5.0...
CVE-2020-11023 Potential XSS vulnerability in jQuery
In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods i.e. .html, .append, and others may execute untrusted code. This problem is patched in jQuery 3.5.0...
PT-2020-4638
Name of the Vulnerable Software and Affected Versions jQuery versions 1.2 through 3.5.0 Description The issue is related to the execution of untrusted code when passing HTML from untrusted sources to jQuery's DOM manipulation methods, such as .html, .append, and others, even after sanitizing the...
CVE-2020-11022
In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods i.e. .html, .append, and others may execute untrusted code. This problem is patched in jQuery 3.5.0...
000demo (>=1.0.0, <=1.1.0), 03-npm-abc (>=1.0.0, <=1.1.0) +6038 more potentially affected by CVE-2020-11022 via jquery (>=1.12.0, <=3.4.1)
jquery NPM version =1.12.0, =1.0.0, =1.0.0, =1.0.0, =1.0.0, =0.0.1, =0.2.1, =0.1.75, =0.3.0, =1.0.0, =4.13.7-rc4, =1.0.0-beta.4, =2.83.0 and more Source cves: CVE-2020-11022 Source advisory: MEND:CVE-2020-11022...
CVE-2020-11022 jQuery has a potential XSS vulnerability
In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods i.e. .html, .append, and others may execute untrusted code. This problem is patched in jQuery 3.5.0...
CVE-2020-11023
The connected Astra Linux bulletin confirms CVE-2020-11023: in jQuery versions >= 1.0.3 and < 3.5.0, passing HTML containing elements from untrusted sources to DOM manipulation methods (e.g., .html(), .append()) may lead to untrusted code execution. Patch released in jQuery 3.5.0. Remediat...
CVE-2020-11023
In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods i.e. .html, .append, and others may execute untrusted code. This problem is patched in jQuery 3.5.0...
CVE-2020-11023
In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods i.e. .html, .append, and others may execute untrusted code. This problem is patched in jQuery 3.5.0...
form-validator (0.0.11), heightline (1.0.1) +4 more potentially affected by CVE-2020-11022 via jquery (1.6.2)
jquery NPM version 1.6.2 is affected by a known vulnerability. The following packages have a transitive dependency on jquery and may be impacted: - form-validator 0.0.11 - heightline 1.0.1 - jsgrep =1.0.0, =0.1.61, =0.0.9, =0.0.15 - zappa 0.2.0 Source cves: CVE-2020-11022 Source advisory:...
bones (>=1.1.0, <=2.0.0), clustergrammer (>=1.4.8, <=1.12.0) +8 more potentially affected by CVE-2020-11022 via jquery (1.5.1)
jquery NPM version 1.5.1 is affected by a known vulnerability. The following packages have a transitive dependency on jquery and may be impacted: - bones =1.1.0, =1.4.8, =0.0.2, =0.0.0-rc1, =0.5.0, =0.6.2 Source cves: CVE-2020-11022 Source advisory: MEND:CVE-2020-11022...
CVE-2020-11023
In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing elements from untrusted sources – even after sanitizing it – to one of jQuery’s DOM manipulation methods i.e. .html, .append, and others may execute untrusted code. This problem is patched in jQuery 3.5.0...