16721 matches found
DEBIAN-CVE-2024-28243
KaTeX is a JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions could encounter malicious input using \edef that causes a near-infinite loop, despite setting maxExpand to avoid such loops. This can be used as an availability attack, where...
UBUNTU-CVE-2024-28243
KaTeX is a JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions could encounter malicious input using \edef that causes a near-infinite loop, despite setting maxExpand to avoid such loops. This can be used as an availability attack, where...
CVE-2024-28244
KaTeX is a JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions could encounter malicious input using "\def" or "\newcommand" that causes a near-infinite loop, despite setting "maxExpand" to avoid such loops. KaTeX supports an option name...
CVE-2024-28243
KaTeX is a JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions could encounter malicious input using "\edef" that causes a near-infinite loop, despite setting "maxExpand" to avoid such loops. This can be used as an availability attack,...
KaTeX security vulnerabilities
KaTeX is a fast, easy-to-use JavaScript library for TeX math rendering on the web. A security vulnerability existed prior to the KaTeX v0.16.10 release, which stemmed from the fact that KaTeX users rendering untrusted mathematical expressions could encounter malicious input using edef, potentiall...
KaTeX security vulnerabilities
KaTeX is a fast, easy-to-use JavaScript library for TeX math rendering on the web. A security vulnerability existed prior to the KaTeX v0.16.10 release, which arose from the fact that KaTeX users rendering untrusted mathematical expressions could encounter a malicious input using def or ewcommand...
PT-2024-22359
Name of the Vulnerable Software and Affected Versions: KaTeX versions prior to 0.16.10 Description: KaTeX is a JavaScript library for TeX math rendering on the web. Users who render untrusted mathematical expressions could encounter malicious input using def or ewcommand that causes a near-infini...
PT-2025-46749
Name of the Vulnerable Software and Affected Versions Linux Kernel affected versions not specified Description A flaw exists in the Linux kernel's IPMI driver related to message handling. A reverted patch intended to fix a message stack issue when IPMI is disconnected introduces a potential for a...
Infinite loop
Overview org.webjars.bower:markdown-it is a modern pluggable markdown parser. Affected versions of this package are vulnerable to Infinite loop in linkify inline rule when using malformed input. Remediation A fix was pushed into the master branch but not yet published. References - GitHub Diff -...
MGASA-2024-0087 Updated freeimage packages fix security vulnerabilities
Buffer Overflow vulnerability in FreeImageAllocateBitmap. CVE-2023-47995 Infinite loop exits in Load in PluginTIFF.cpp. CVE-2023-47997...
Updated freeimage packages fix security vulnerabilities
Buffer Overflow vulnerability in FreeImageAllocateBitmap. CVE-2023-47995 Infinite loop exits in Load in PluginTIFF.cpp. CVE-2023-47997...
Debian dsa-5647 : ctdb - security update
The remote Debian 11 host has packages installed that are affected by multiple vulnerabilities as referenced in the dsa-5647 advisory. -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA512 - ------------------------------------------------------------------------- Debian Security Advisory DSA-5647-1...
Fedora 38 : kubernetes (2024-5bae6c0ea7)
The remote Fedora 38 host has a package installed that is affected by a vulnerability as referenced in the FEDORA-2024-5bae6c0ea7 advisory. Updates google.golang.org/protobuf to v1.33.0 to resolve CVE-2024-24786. Kubernetes is now built with go 1.21.8. Tenable has extracted the preceding...
SUSE-SU-2024:0970-1 Security update for zziplib
This update for zziplib fixes the following issues: Security issue fixed: - CVE-2020-18442: Fixed infinite loop in zzipfileread as used in unzzipcatfile bsc1187526. - CVE-2020-18770: Fixed denial-of-service in function zzipdiskentrytofileheader in mmapped.c bsc1214577. Non-security issue fixed: -...
Siemens SCALANCE, SIMATIC and RUGGEDCOM Products Infinite Loop (CVE-2022-0778)
The BNmodsqrt function in openSSL, which computes a modular square root, contains a bug that can cause it to loop forever for non-prime moduli. Internally this function is used when parsing certificates that contain elliptic curve public keys in compressed form or explicit elliptic curve paramete...
Important: apache-commons-compress
Issue Overview: Loop with Unreachable Exit Condition 'Infinite Loop' vulnerability in Apache Commons Compress.This issue affects Apache Commons Compress: from 1.3 through 1.25.0. Users are recommended to upgrade to version 1.26.0 which fixes the issue. CVE-2024-25710 Affected Packages:...
Amazon Linux 2023 : apache-commons-compress, apache-commons-compress-javadoc (ALAS2023-2024-560)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2024-560 advisory. Loop with Unreachable Exit Condition 'Infinite Loop' vulnerability in Apache Commons Compress.This issue affects Apache Commons Compress: from 1.3 through 1.25.0. Users are recommended to upgrade to...
EulerOS Virtualization 2.11.1 : libX11 (EulerOS-SA-2024-1402)
According to the versions of the libX11 package installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : - A vulnerability was found in libX11 due to a boundary condition within the XkbReadKeySyms function. This flaw allows a local user ...
PT-2024-5782
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description The issue is related to the i2c hid xfer function in the i2c-hid component of the Linux kernel. The problem arises when the I2C HID READ PENDING flag is set and an interrupt occurs,...
Important: javapackages-bootstrap
Issue Overview: Loop with Unreachable Exit Condition 'Infinite Loop' vulnerability in Apache Commons Compress.This issue affects Apache Commons Compress: from 1.3 through 1.25.0. Users are recommended to upgrade to version 1.26.0 which fixes the issue. CVE-2024-25710 Affected Packages:...