Lucene search
+L

2727 matches found

osv_debian
osv_debian
•added 2022/05/26 5:15 p.m.•7 views

DEBIAN-CVE-2022-21831

A code injection vulnerability exists in the Active Storage = v5.2.0 that could allow an attacker to execute code via imageprocessing arguments...

9.8CVSS6.8AI score0.03098EPSS
SaveExploits0References1
NVD
NVD
•added 2022/05/26 5:15 p.m.•30 views

CVE-2022-21831

A code injection vulnerability exists in the Active Storage = v5.2.0 that could allow an attacker to execute code via imageprocessing arguments...

9.8CVSS0.03098EPSS
SaveExploits0References4
UbuntuCve
UbuntuCve
•added 2022/05/26 5:15 p.m.•42 views

CVE-2022-21831

A code injection vulnerability exists in the Active Storage = v5.2.0 that could allow an attacker to execute code via imageprocessing arguments...

9.8CVSS7AI score0.03098EPSS
SaveExploits0References2
Prion
Prion
•added 2022/05/26 5:15 p.m.•26 views

Code injection

A code injection vulnerability exists in the Active Storage = v5.2.0 that could allow an attacker to execute code via imageprocessing arguments...

6.8CVSS9.3AI score0.03098EPSS
SaveExploits0References4Affected Software2
osv_ubuntu
osv_ubuntu
•added 2022/05/26 5:15 p.m.•9 views

UBUNTU-CVE-2022-21831

A code injection vulnerability exists in the Active Storage = v5.2.0 that could allow an attacker to execute code via imageprocessing arguments...

9.8CVSS6.5AI score0.03098EPSS
SaveExploits0References3
attackerkb
attackerkb
•added 2022/05/26 5:15 p.m.•17 views

CVE-2022-21831

A code injection vulnerability exists in the Active Storage = v5.2.0 that could allow an attacker to execute code via imageprocessing arguments...

9.8CVSS6.9AI score0.03098EPSS
SaveExploits0References5
GitLab Advisory Database
GitLab Advisory Database
•added 2022/05/26 12:00 a.m.•50 views

Improper Control of Generation of Code ('Code Injection')

A code injection vulnerability exists in the Active Storage = v5.2.0 that could allow an attacker to execute code via imageprocessing arguments...

9.8CVSS6AI score0.03098EPSS
SaveExploits0References5Affected Software1
CVE
CVE
•added 2022/05/26 12:00 a.m.•371 views

CVE-2022-21831

CVE-2022-21831 affects Ruby on Rails’ Active Storage (Rails >= 5.2.0). The vulnerability arises from a code-injection in the image_processing backend (mini_magick), allowing remote code execution via crafted image_processing arguments. Impact is High (CVE describes RCE; CVSSv3.1 base score 9.8...

9.8CVSS9.4AI score0.03098EPSS
SaveExploits0References4Affected Software1
Cvelist
Cvelist
•added 2022/05/26 12:00 a.m.•79 views

CVE-2022-21831

A code injection vulnerability exists in the Active Storage = v5.2.0 that could allow an attacker to execute code via imageprocessing arguments...

9.7AI score0.03098EPSS
SaveExploits0References4
Debian CVE
Debian CVE
•added 2022/05/26 12:00 a.m.•125 views

CVE-2022-21831

A code injection vulnerability exists in the Active Storage = v5.2.0 that could allow an attacker to execute code via imageprocessing arguments...

9.8CVSS6.7AI score0.03098EPSS
SaveExploits0
NVD
NVD
•added 2022/05/25 10:15 p.m.•55 views

CVE-2022-29256

sharp is an application for Node.js image processing. Prior to version 0.30.5, there is a possible vulnerability in logic that is run only at npm install time when installing versions of sharp prior to the latest v0.30.5. If an attacker has the ability to set the value of the PKGCONFIGPATH...

6.7CVSS0.00385EPSS
SaveExploits0References2
Prion
Prion
•added 2022/05/25 10:15 p.m.•34 views

Design/Logic Flaw

sharp is an application for Node.js image processing. Prior to version 0.30.5, there is a possible vulnerability in logic that is run only at npm install time when installing versions of sharp prior to the latest v0.30.5. If an attacker has the ability to set the value of the PKGCONFIGPATH...

4.6CVSS6.5AI score0.00385EPSS
SaveExploits0References2Affected Software1
osv_cve
osv_cve
•added 2022/05/25 9:20 p.m.•34 views

CVE-2022-29256 Possible vulnerability at 'npm install' time in sharp if an attacker has control over build environment

sharp is an application for Node.js image processing. Prior to version 0.30.5, there is a possible vulnerability in logic that is run only at npm install time when installing versions of sharp prior to the latest v0.30.5. If an attacker has the ability to set the value of the PKGCONFIGPATH...

6.5CVSS6.4AI score
SaveExploits0References4
CVE
CVE
•added 2022/05/25 9:20 p.m.•116 views

CVE-2022-29256

CVE-2022-29256 affects sharp (Node.js image processing) versions prior to 0.30.5. If an attacker can control PKG_CONFIG_PATH in the build environment, they may inject arbitrary commands at npm install time (not a runtime issue; Windows builds are not affected). The issue is fixed in sharp v0.30.5...

6.7CVSS6.4AI score0.00385EPSS
SaveExploits0References2Affected Software1
Positive Technologies
Positive Technologies
•added 2022/05/25 12:00 a.m.•10 views

PT-2022-3459 · Pillow · Pillow

Name of the Vulnerable Software and Affected Versions: Pillow version 9.1.0 Description: The issue is related to a heap buffer overflow in the processing of invalid TGA image files. This can be exploited by a remote attacker to impact the confidentiality, integrity, and availability of protected...

10CVSS7.5AI score0.03334EPSS
SaveExploits1References29
osv_ghsa
osv_ghsa
•added 2022/05/24 9:59 p.m.•37 views

GHSA-3W4H-R27H-4R2W TYPO3 Image Processing susceptible to Code Execution

TYPO3 8.x before 8.7.25 and 9.x before 9.5.6 is susceptible to remote code execution because it does not properly configure the applications used for image processing, as demonstrated by ImageMagick or GraphicsMagick. For a successful exploit, the GhostScript binary gs must be available on the...

7.5CVSS6.2AI score0.03917EPSS
SaveExploits0References9
Github Security Blog
Github Security Blog
•added 2022/05/24 9:59 p.m.•37 views

TYPO3 Image Processing susceptible to Code Execution

TYPO3 8.x before 8.7.25 and 9.x before 9.5.6 is susceptible to remote code execution because it does not properly configure the applications used for image processing, as demonstrated by ImageMagick or GraphicsMagick. For a successful exploit, the GhostScript binary gs must be available on the...

9.3CVSS8AI score0.03917EPSS
SaveExploits0References9Affected Software2
BDU FSTEC
BDU FSTEC
•added 2022/05/18 12:00 a.m.•23 views

ImageProcessing Command Injection

The vulnerability of the ImageProcessing software exists due to the lack of measures taken to neutralize special elements used in the operating system’s commands. Exploiting this vulnerability allows a remote attacker to execute shell commands...

10CVSS7.9AI score0.02686EPSS
SaveExploits1References4Affected Software1
Mageia
Mageia
•added 2022/05/12 10:24 a.m.•111 views

Updated python-pillow packages fix security vulnerability

pathgetbbox in path.c in Pillow before 9.0.0 improperly initializes ImagePath.Path. CVE-2022-22815 pathgetbbox in path.c in Pillow before 9.0.0 has a buffer over-read during initialization of ImagePath.Path. CVE-2022-22816 PIL.ImageMath.eval in Pillow before 9.0.0 allows evaluation of arbitrary...

9.8CVSS7.3AI score0.03334EPSS
SaveExploits0References5
attackerkb
attackerkb
•added 2022/05/11 2:15 p.m.•10 views

CVE-2022-29977

There is an assertion failure error in stbijpeghuffdecode, stbimage.h:1894 in libsixel img2sixel 1.8.6. Remote attackers could leverage this vulnerability to cause a denial-of-service via a crafted JPEG file...

6.5CVSS6.6AI score0.01037EPSS
SaveExploits1References2
Rows per page
Query Builder