143 matches found
CVE-2020-16898
CVE-2020-16898: “Bad Neighbor” CVSS Score: 8.8 CVSS Vector: CVSS3.0/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H/E:P/RL:O/RC:C Overview On October 13, Microsoft announced an exceptionally critical vulnerability in the Windows IPv6 stack, which allows an attacker to send maliciously crafted packets to...
Linux Distros Unpatched Vulnerability : CVE-2026-19742
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - The IPv6 stack derived the long-lived secret key used to compute RFC 7217 stable interface identifiers genstableiid in subsys/net/ip/ipv6.c and RFC 8981 tempora...
CVE-2026-19742
The IPv6 stack derived the long-lived secret key used to compute RFC 7217 stable interface identifiers genstableiid in subsys/net/ip/ipv6.c and RFC 8981 temporary interface identifiers gentemporaryiid in subsys/net/ip/ipv6pe.c with sysrandget. That API is documented as not cryptographically secur...
UBUNTU-CVE-2026-19742
The IPv6 stack derived the long-lived secret key used to compute RFC 7217 stable interface identifiers genstableiid in subsys/net/ip/ipv6.c and RFC 8981 temporary interface identifiers gentemporaryiid in subsys/net/ip/ipv6pe.c with sysrandget. That API is documented as not cryptographically secur...
CVE-2026-19742
The IPv6 stack derived the long-lived secret key used to compute RFC 7217 stable interface identifiers genstableiid in subsys/net/ip/ipv6.c and RFC 8981 temporary interface identifiers gentemporaryiid in subsys/net/ip/ipv6pe.c with sysrandget. That API is documented as not cryptographically secur...
PT-2026-123414
The IPv6 stack derived the long-lived secret key used to compute RFC 7217 stable interface identifiers gen stable iid in subsys/net/ip/ipv6.c and RFC 8981 temporary interface identifiers gen temporary iid in subsys/net/ip/ipv6 pe.c with sys rand get. That API is documented as not cryptographicall...
Zephyr Project Zephyr encryption issue vulnerability
In Zephyr Project versions from 3.7.0 up to 4.5.0, there is an encryption-related vulnerability. This vulnerability stems from the IPv6 stack’s use of non-cryptographically secure sysrandget in subsystems/net/ip/ipv6.c and subsystems/net/ip/ipv6pe.c to generate stable interface identifiers per RF...
CVE-2026-16515 ICMPv6 error messages sent for multicast-destined packets and non-unique source addresses enable network amplification in Zephyr's IPv6 stack
neticmpv6senderror in subsys/net/ip/icmpv6.c implemented only one of the three RFC 4443 section 2.4 suppression rules do not answer an ICMPv6 error with an ICMPv6 error. It did not check whether the triggering packet's source address identifies a single node rule e.6 or whether the packet was sen...
Linux Distros Unpatched Vulnerability : CVE-2026-72392
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - ipv6: fib6: fix NULL deref in fib6walkcontinue on multi-batch dump inet6dumpfib saves its progress in cb-args1 as a positional index within the current hash...
Exploit for Integer Underflow (Wrap or Wraparound) in Microsoft
CVE-2024-38063 — Windows IPv6 Stack Vulnerability Analysis &...
Unity Linux 20.1060a / 20.1070a Security Update: kernel (UTSA-2026-002199)
The Unity Linux 20 host has a package installed that is affected by a vulnerability as referenced in the UTSA-2026-002199 advisory. The fib6addrt2node function in net/ipv6/ip6fib.c in the IPv6 stack in the Linux kernel through 3.10.1 does not properly handle Router Advertisement RA messages in...
SUSE CVE-2023-54265
In the Linux kernel, the following vulnerability has been resolved: ipv6: Fix an uninit variable access bug in ip6makeskb Syzbot reported a bug as following: ===================================================== BUG: KMSAN: uninit-value in archatomic64inc arch/x86/include/asm/atomic6464.h:88 inli...
CVE-2025-13823
A security issue was found in the IPv6 stack in the Micro850 and Micro870 controllers when the controllers received multiple malformed packets during fuzzing. The controllers will go into recoverable fault with fault code 0xFE60. To recover the controller, clear the fault...
CVE-2025-13823: Dependency on Vulnerable Third-Party Component
A security issue was found in the IPv6 stack in the Micro850 and Micro870 controllers when the controllers received multiple malformed packets during fuzzing. The controllers will go into recoverable fault with fault code 0xFE60. To recover the controller, clear the fault...
EUVD-2013-4053
Malware in sbrugna...
EUVD-2015-6301
Malware in sbrugna...
EUVD-2015-5815
Malware in sbrugna...
EUVD-2015-3008
Malware in sbrugna...