7165 matches found
Important: httpd24, httpd
Issue Overview: Apache httpd allows remote attackers to read secret data from process memory if the Limit directive can be set in a user's .htaccess file, or if httpd.conf has certain misconfigurations, aka Optionsbleed. The attacker sends an unauthenticated OPTIONS HTTP request when attempting t...
mod_gnutls: Certificate validation error
Background modgnutls is an extension for āApacheās httpd. It uses the āGnuTLS library to provide HTTPS. It supports some protocols and features that modssl does not. Description It was discovered that the authentication hook in modgnutls does not validate clientās certificates even when option...
Amazon Linux AMI : httpd (ALAS-2017-892)
A NULL pointer dereference flaw was found in the httpd's modssl module. A remote attacker could use this flaw to cause an httpd child process to crash if another module used by httpd called a certain API function during the processing of an HTTPS request. CVE-2017-3169 It was discovered that the...
httpd: ap_some_auth_required() does not properly indicate authenticated request in 2.4
It was discovered that in httpd 2.4, the internal API function apsomeauthrequired could incorrectly indicate that a request was authenticated even when no authentication was used. An httpd module using this API function could consequently allow access that should have been denied...
httpd: Uninitialized memory reflection in mod_auth_digest
It was discovered that the httpd's modauthdigest module did not properly initialize memory before using it when processing certain headers related to digest authentication. A remote attacker could possibly use this flaw to disclose potentially sensitive information or cause httpd child process to...
Important: httpd
Issue Overview: A NULL pointer dereference flaw was found in the httpd's modssl module. A remote attacker could use this flaw to cause an httpd child process to crash if another module used by httpd called a certain API function during the processing of an HTTPS request. CVE-2017-3169 It was...
EulerOS 2.0 SP2 : httpd (EulerOS-SA-2017-1178)
According to the versions of the httpd packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : - It was discovered that the httpd's modauthdigest module did not properly initialize memory before using it when processing certain headers relate...
EulerOS 2.0 SP1 : httpd (EulerOS-SA-2017-1177)
According to the versions of the httpd packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : - It was discovered that the httpd's modauthdigest module did not properly initialize memory before using it when processing certain headers relate...
HiSilicon DVR Devices - Remote Code Execution
!/usr/bin/env python2 pwn hisilicon dvr web service from pwn import from time import sleep import re import argparse import os parser = argparse.ArgumentParserdescription='exploit HiSilicon DVR devices' parser.addargument'--rhost', help='target host', required=True parser.addargument'--rport',...
fli4l Arbitrary Code Execution Vulnerability
fli4l is a Linux-based ISDN, DSL and Ethernet router product developed by the fli4l team, which can be configured via ASCII files and supports multiple connection methods, displaying and calculating connection times and costs, monitoring traffic and monitoring ISDN calls. A security vulnerability...
CVE-2015-1443
The httpd package in fli4l before 3.10.1 and 4.0 before 2015-01-30 allows remote attackers to execute arbitrary code...
CVE-2015-1445
HTTP header injection in the httpd package in fli4l before 3.10.1 and 4.0 before 2015-01-30...
Code injection
The httpd package in fli4l before 3.10.1 and 4.0 before 2015-01-30 allows remote attackers to execute arbitrary code...
CVE-2015-1443
The httpd package in fli4l before 3.10.1 and 4.0 before 2015-01-30 allows remote attackers to execute arbitrary code...
CVE-2015-1443
Concrete details show that CVE-2015-1443 affects the httpd component of fli4l, with vulnerable versions prior to 3.10.1 and 4.0 prior to 2015-01-30. The vulnerability enables a remote attacker to execute arbitrary code. The CNVD entry WC explicitly describes this as a remote code execution vulner...
CVE-2015-1445: Improper Neutralization of CRLF Sequences in HTTP Headers
HTTP header injection in the httpd package in fli4l before 3.10.1 and 4.0 before 2015-01-30...
CVE-2015-1443: Improper Input Validation
The httpd package in fli4l before 3.10.1 and 4.0 before 2015-01-30 allows remote attackers to execute arbitrary code...
PT-2017-6490
Name of the Vulnerable Software and Affected Versions fli4l versions prior to 3.10.1 fli4l version 4.0 before 2015-01-30 Description The issue allows remote attackers to execute arbitrary code via the httpd package. Recommendations For fli4l versions prior to 3.10.1, update to version 3.10.1 or...
PT-2017-6491
Name of the Vulnerable Software and Affected Versions fli4l versions prior to 3.10.1 fli4l versions 4.0 before 2015-01-30 Description The issue concerns HTTP header injection in the httpd package. Recommendations For fli4l versions prior to 3.10.1, update to version 3.10.1 or later. For fli4l...
BSA-2017-377
Security Advisory ID : BSA-2017-377 Component : Apache HTTPD Revision : 3.0: Final In Apache httpd before 2.2.34 and 2.4.x before 2.4.27, the value placeholder in Proxy-Authorization headers of type 'Digest' was not initialized or reset before or between successive key=value assignments by...