93145 matches found
CVE-2026-93605
vm2 NodeVM versions before 3.12.1 contain a sandbox escape vulnerability where the DANGEROUSBUILTINS denylist omits childprocess despite blocking other host-spawning modules. Attackers can require childprocess and execute arbitrary commands on the host system when NodeVM is configured with...
CVE-2026-93603 vm2 before 3.12.1 Sandbox Escape RCE via Non-Strict Host Function
vm2 through 3.12.0 fixed in 3.12.1 does not correctly handle a nullish this receiver in the apply trap of its bridge lib/bridge.js: when sandboxed code calls a host-provided non-strict sloppy-mode function without a receiver — e.g. fn, a detached method, fn.call, fn.applyundefined, Reflect.applyf...
CVE-2026-93603
vm2 through 3.12.0 fixed in 3.12.1 does not correctly handle a nullish "this" receiver in the apply trap of its bridge lib/bridge.js: when sandboxed code calls a host-provided non-strict sloppy-mode function without a receiver — e.g. "fn", a detached method, "fn.call", "fn.applyundefined",...
CVE-2026-93603 vm2 before 3.12.1 Sandbox Escape RCE via Non-Strict Host Function
vm2 through 3.12.0 fixed in 3.12.1 does not correctly handle a nullish this receiver in the apply trap of its bridge lib/bridge.js: when sandboxed code calls a host-provided non-strict sloppy-mode function without a receiver — e.g. fn, a detached method, fn.call, fn.applyundefined, Reflect.applyf...
CVE-2026-93603
vm2 (Node.js sandbox library) through 3.12.0 is vulnerable to a complete sandbox escape due to incorrect handling of a nullish this receiver in the apply trap of its bridge (lib/bridge.js). When sandboxed code invokes a host-provided non-strict (sloppy-mode) function without a receiver (e.g., fn(...
CVE-2026-93603 vm2 before 3.12.1 Sandbox Escape RCE via Non-Strict Host Function
vm2 through 3.12.0 fixed in 3.12.1 does not correctly handle a nullish this receiver in the apply trap of its bridge lib/bridge.js: when sandboxed code calls a host-provided non-strict sloppy-mode function without a receiver — e.g. fn, a detached method, fn.call, fn.applyundefined, Reflect.applyf...
jumpserver v5.0.0
An open-source PAM platform Bastion Host !license-shieldlicense-link !docs-shielddocs-link !deepwiki-shielddeepwiki-link !discord-shielddiscord-link !docker-shielddocker-link !github-release-shieldgithub-release-link !github-stars-shieldgithub-stars-link English · 中文简体 · 中文繁體 · 日本語 · Português...
CVE-2026-12106
The Auto Upload Images plugin for WordPress (all versions up to and including 3.3.2 ) is vulnerable to a Limited Server-Side Request Forgery (SSRF) via the downloadImage function. The root cause is the use of wp_remote_get() instead of wp_safe_remote_get(), combined with a validate() method that ...
Malicious code in @tink/tink-link-core (npm)
Source: amazon-inspector 826e81131e7b2a296324d469c10f1e44d5b33683703c8a2e0f101a8674c1cfcf The package impersonates the Tink open-banking SDK name @tink/tink-link-core, description 'Enterprise-grade client core for open banking', homepage github.com/tink-link/core but its actual behavior is host...
Malicious code in requests-asetwe (PyPI)
Source: kam193 7078a9b4fc2be32cbeb1f2c20ec67834c8e293bd410ceeb4842cacd8340d9835 Installing the package or importing the module exfiltrates basic information about the host, and the package has no other purpose. --- Category: PROBABLYPENTEST - Packages looking like typical pentest packages, but al...
CVE-2026-93569: Inconsistent Interpretation of HTTP Requests
A flaw was found in Netty. A remote unauthenticated attacker can exploit a vulnerability in Netty's HTTP/1 to HTTP/2 conversion process. When an HTTP/1 request includes both an absolute-form request-target and a conflicting Host header, Netty incorrectly prioritizes the Host header for the HTTP/2...
CVE-2026-93604: Improper Access Control
vm2 through 3.12.0 exposes Node.js's crypto.setFips function to untrusted guest code when an embedder explicitly allowlists the crypto builtin for a NodeVM require.builtin: 'crypto'. The builtin sanitizer sanitizeCryptoModule in lib/builtin.js replaces crypto.setEngine but leaves crypto.setFips...
Fortinet FortiProxy 7.6.2 < 7.6.7 Improper Certificate Validation with Host Mismatch (FG-IR-26-174)
The version of FortiProxy installed on the remote host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the FG-IR-26-174 advisory. - An improper validation of certificate with host mismatch vulnerability in Fortinet FortiProxy 7.6.2 through 7.6.6 may allo...
CVE-2026-11549: Improper Access Control
IBM WebSphere Application Server 8.5 and 9.0, and IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.8 are affected by a virtual host bypass vulnerability...
EulerOS Virtualization 2.11.1 : wget (EulerOS-SA-2026-3481)
According to the versions of the wget package installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : Applications that use Wget to access a remote resource using shorthand URLs and pass arbitrary user credentials in the URL are...
CVE-2026-93605: Protection Mechanism Failure
vm2 NodeVM versions before 3.12.1 contain a sandbox escape vulnerability where the DANGEROUSBUILTINS denylist omits childprocess despite blocking other host-spawning modules. Attackers can require childprocess and execute arbitrary commands on the host system when NodeVM is configured with...
PT-2026-95579
Name of the Vulnerable Software and Affected Versions SysReptor versions prior to 2026.58 Description Installations that enable password reset by email and configure ALLOWED HOSTS with a wildcard accept an attacker-controlled Host header during the generation of password reset links. An...
PT-2026-95508
Name of the Vulnerable Software and Affected Versions spatie Scotty versions prior to 1.4.5 Description OS command injection is possible via remote attack in the Doctor Command Handler component. The issue exists within the DoctorCommand::checkSshConnectivity and DoctorCommand::checkRemoteTools...
PT-2026-95420
Name of the Vulnerable Software and Affected Versions Netty affected versions not specified Description A flaw exists in the HTTP/2 codec when converting HTTP/1 CONNECT requests to HTTP/2. The component incorrectly utilizes the Host header instead of the CONNECT authority-form request-target to...
CVE-2026-93567: Improper Input Validation
A flaw was found in Netty's HTTP/2 codec. When converting HTTP/1 CONNECT requests to HTTP/2, the component incorrectly uses the Host header instead of the CONNECT authority-form request-target for the tunnel authority. A remote attacker can exploit this by supplying a different Host header, leadi...