Lucene search
+L

178 matches found

RedhatCVE
RedhatCVE
•added 2026/10/15 1:00 p.m.•3 views

CVE-2026-86410

A flaw was found in the curl command-line tool. When configured to follow redirects to Secure File Transfer Protocol SFTP or Secure Copy Protocol SCP destinations, curl fails to apply user-specified Secure Shell SSH host verification settings. A malicious server can exploit this flaw by redirecti...

6.8CVSS5.7AI score
SaveExploits0References3
RedHat Linux
RedHat Linux
•added 2026/10/14 11:39 a.m.•3 views

curl: curl: redirect to SFTP or SCP bypasses host verification

A flaw was found in the curl command-line tool. When configured to follow redirects to Secure File Transfer Protocol SFTP or Secure Copy Protocol SCP destinations, curl fails to apply user-specified Secure Shell SSH host verification settings. A malicious server can exploit this flaw by redirecti...

5.7AI score
SaveExploits0References4
curl security advisories
curl security advisories
•added 2026/10/14 8:00 a.m.•9 views

redirect to SFTP or SCP bypasses host verification

A flaw in the curl command line tool's logic makes it only set SSH host verification options when interacting directly using SFTP or SCP, and not as a result of following a redirect...

5.8AI score
SaveExploits0References1Affected Software2
osv_curl
osv_curl
•added 2026/10/14 8:00 a.m.•22 views

CURL-CVE-2026-86410 redirect to SFTP or SCP bypasses host verification

A flaw in the curl command line tool's logic makes it only set SSH host verification options when interacting directly using SFTP or SCP, and not as a result of following a redirect...

5.8AI score
SaveExploits0
UbuntuCve
UbuntuCve
•added 2026/10/14 6:00 a.m.•8 views

CVE-2026-86410

A flaw in the curl command line tool's logic makes it only set SSH host verification options when interacting directly using SFTP or SCP, and not as a result of following a redirect. This means --knownhosts, --hostpubsha256, and --hostpubmd5 are never installed when the initial URL is HTTPS. If...

5.9AI score
SaveExploits0References3
Tenable Nessus
Tenable Nessus
•added 2026/10/08 12:00 a.m.•13 views

EulerOS 2.0 SP15 : curl (EulerOS-SA-2026-3969)

According to the versions of the curl packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : A use-after-free vulnerability exists in libcurl when an applicationx000D configures an HTTP/2 stream-dependency tree via CURLOPTSTREAMDEPENDS orx00...

9.8CVSS6.6AI score0.00661EPSS
SaveExploits7References8
Tenable Nessus
Tenable Nessus
•added 2026/10/08 12:00 a.m.•24 views

EulerOS 2.0 SP15 : curl (EulerOS-SA-2026-3903)

According to the versions of the curl packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : A use-after-free vulnerability exists in libcurl when an applicationx000D configures an HTTP/2 stream-dependency tree via CURLOPTSTREAMDEPENDS orx00...

9.8CVSS6.6AI score0.00661EPSS
SaveExploits7References8
Tenable Nessus
Tenable Nessus
•added 2026/10/01 12:00 a.m.•13 views

AlmaLinux 9.2 [TuxCare] Security Update: nodejs / nodejs-devel / nodejs-docs / nodejs-full-i18n / etc Multiple Vulnerabilities (ALMALINUX9.2:CLSA-2026:1783342928)

The AlmaLinux 9.2 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare ALMALINUX9.2:CLSA-2026:1783342928 advisory. - A flaw in Node.js WebCrypto implementation can crash the process if the input of subtle.encrypt is a multiple of 2GiB. This...

7.5CVSS6.4AI score0.03711EPSS
SaveExploits0References4
Tenable Nessus
Tenable Nessus
•added 2026/09/30 12:00 a.m.•12 views

Rocky Linux 9.6 [TuxCare] Security Update: nodejs / nodejs-devel / nodejs-docs / nodejs-full-i18n / etc Multiple Vulnerabilities (ALMALINUX9.6:CLSA-2026:1783353048)

The Rocky Linux 9.6 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1783353048 advisory. - A flaw in Node.js WebCrypto implementation can crash the process if the input of subtle.encrypt is a multiple of 2GiB. This...

7.5CVSS6.4AI score0.03711EPSS
SaveExploits0References4
Tenable Nessus
Tenable Nessus
•added 2026/09/30 12:00 a.m.•11 views

AlmaLinux 9.6 [TuxCare] Security Update: nodejs / nodejs-devel / nodejs-docs / nodejs-full-i18n / etc Multiple Vulnerabilities (ALMALINUX9.6:CLSA-2026:1783353048)

The AlmaLinux 9.6 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1783353048 advisory. - A flaw in Node.js WebCrypto implementation can crash the process if the input of subtle.encrypt is a multiple of 2GiB. This...

7.5CVSS6.4AI score0.03711EPSS
SaveExploits0References4
RedHat Linux
RedHat Linux
•added 2026/09/28 3:15 p.m.•21 views

curl: curl: SSH host verification bypass when using schemeless URLs with SFTP/SCP

A flaw was found in curl. When a user invokes curl with a schemeless URL and specifies SFTP SSH File Transfer Protocol or SCP Secure Copy Protocol as the default protocol, the tool layer fails to initialize critical SSH security options. This bypasses host verification, allowing curl to connect t...

7.5CVSS6.2AI score0.00399EPSS
SaveExploits1References7
Tenable Nessus
Tenable Nessus
•added 2026/09/14 12:00 a.m.•40 views

Amazon Linux 2023 : curl, curl-minimal, libcurl (ALAS2023-2026-2132)

It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2023-2026-2132 advisory. A use-after-free vulnerability exists in libcurl when an application configures an HTTP/2 stream- dependency tree via CURLOPTSTREAMDEPENDS or CURLOPTSTREAMDEPENDSE, subsequently invokes...

9.8CVSS6.6AI score0.0108EPSS
SaveExploits16References32
Positive Technologies
Positive Technologies
•added 2026/09/08 12:00 a.m.•21 views

PT-2026-87137

In affected Snowflake drivers, WORKLOAD IDENTITY authentication requests a cloud workload-identity token and attaches it to the login request without verifying that the configured host is a Snowflake endpoint. An attacker who can modify the connection configuration can cause the driver to mint a...

8.2CVSS5.7AI score0.00511EPSS
SaveExploits0References9
osv_oesa
osv_oesa
•added 2026/09/05 3:02 p.m.•13 views

OESA-2026-3588 perl-URI security update

This module implements the URI class. Objects of this class represent "Uniform Resource Identifier references" as specified in RFC 2396 and updated by RFC 2732. Security Fixes: URI versions before 5.36 for Perl encode non-NFC host names to non-standard punycode labels via missing normalization in...

9.8CVSS5.8AI score0.00229EPSS
SaveExploits0References2
Vulnrichment
Vulnrichment
•added 2026/08/31 5:29 p.m.•17 views

CVE-2026-19953 URI versions before 5.36 for Perl encode non-NFC host names to non-standard punycode labels via missing normalization in nameprep

URI versions before 5.36 for Perl encode non-NFC host names to non-standard punycode labels via missing normalization in nameprep. nameprep lowercases each host label but performs no Unicode normalization. IDNA requires a label to be normalized to Form C before it is encoded RFC 5891, so a label...

5.8AI score0.00229EPSS
SaveExploits0References4
NVD
NVD
•added 2026/08/26 3:16 p.m.•17 views

CVE-2026-54548

kas is a setup tool for bitbake based projects. Prior to 5.4, internal SSH key setup triggered by SSHPRIVATEKEY or SSHPRIVATEKEYFILE creates /.ssh/config when no user-specific SSH configuration exists and adds a global Host rule containing StrictHostKeyChecking no. In kas/libcmds.py,...

3.3CVSS0.00112EPSS
SaveExploits0References3
RedHat Linux
RedHat Linux
•added 2026/08/19 1:28 p.m.•29 views

curl: curl: SSH host verification bypass when using schemeless URLs with SFTP/SCP

A flaw was found in curl. When a user invokes curl with a schemeless URL and specifies SFTP SSH File Transfer Protocol or SCP Secure Copy Protocol as the default protocol, the tool layer fails to initialize critical SSH security options. This bypasses host verification, allowing curl to connect t...

7.5CVSS6.2AI score0.00399EPSS
SaveExploits1References7
RedHat Linux
RedHat Linux
•added 2026/08/17 5:15 a.m.•20 views

curl: curl: SSH host verification bypass when using schemeless URLs with SFTP/SCP

A flaw was found in curl. When a user invokes curl with a schemeless URL and specifies SFTP SSH File Transfer Protocol or SCP Secure Copy Protocol as the default protocol, the tool layer fails to initialize critical SSH security options. This bypasses host verification, allowing curl to connect t...

7.5CVSS6.2AI score0.00399EPSS
SaveExploits1References7
osv_pysec
osv_pysec
•added 2026/08/10 10:43 a.m.•23 views

PYSEC-2026-3627 AWS CLI: Disabled SSH host key verification in Amazon AWS CLI EMR helper commands

Summary The AWS Command Line Interface AWS CLI is a unified tool to manage AWS services from the command line. An issue exists where the EMR SSH helper commands aws emr ssh, aws emr socks, aws emr put, aws emr get passed StrictHostKeyChecking=no to the underlying SSH client, disabling host key...

6.9CVSS6.6AI score0.00291EPSS
SaveExploits0References8
RedHat Linux
RedHat Linux
•added 2026/08/10 2:56 a.m.•3 views

nodejs: Node.js: Certification validation bypass in TLS host verification

A flaw was found in Node.js. An attacker can exploit a vulnerability in the Transport Layer Security TLS host verification process to bypass certification validation. This bypass could allow an attacker to intercept or alter communications, potentially leading to information disclosure or integri...

4.3CVSS0.00258EPSS
SaveExploits0References5
Rows per page
Query Builder