Lucene search
+L

106 matches found

Cvelist
Cvelist
•added 2026/10/20 7:00 a.m.•20 views

CVE-2026-110180 fast-uri vulnerable to host confusion via unchecked WHATWG host canonicalization

fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions from 2.4.2 through 2.4.7, from 3.1.3 through 3.1.8, and from 4.0.1 through 4.2.2, for HTTP-family schemes the canonicalizeHost function passes the parsed host to the WHATWG URL parser and adopts its hostname...

4.8CVSS0.00208EPSS
SaveExploits0References2
RedHat Linux
RedHat Linux
•added 2026/10/06 10:06 p.m.•15 views

Important: Red Hat Security Advisory: OpenShift Container Platform 4.20.41 security and extras update

Red Hat OpenShift Container Platform release 4.20.41 is now available with updates to packages and images that fix several bugs. This release includes a security update for Red Hat OpenShift Container Platform 4.20. Red Hat Product Security has rated this update as having a security impact of...

7.5CVSS6.1AI score0.00781EPSS
SaveExploits0References5
RedHat Linux
RedHat Linux
•added 2026/10/01 3:04 p.m.•19 views

fast-uri: fast-uri: Host confusion via unbalanced URI brackets can bypass security policies

A flaw was found in fast-uri. The library incorrectly processes Uniform Resource Identifier URI hosts containing unbalanced brackets, leading to a discrepancy in how the host is parsed by fast-uri compared to other HTTP clients. This host confusion can allow an attacker to bypass security policie...

7.5CVSS7.1AI score0.0038EPSS
SaveExploits0References6
RedHat Linux
RedHat Linux
•added 2026/10/01 3:04 p.m.•20 views

fast-uri: fast-uri: Host confusion via skipped IDN canonicalization

A flaw was found in fast-uri, a URI parser for Node.js. This vulnerability arises because the parser fails to consistently convert internationalized domain names IDN to their standard ASCII form when processing scheme-relative references. This inconsistency can lead to host confusion, where an...

7.5CVSS7.1AI score0.00398EPSS
SaveExploits0References6
EUVD
EUVD
•added 2026/09/28 9:24 p.m.•21 views

EUVD-2026-70280

fast-uri vulnerable to authority injection via an unvalidated port in serialize...

7.5CVSS7.4AI score0.00239EPSS
SaveExploits0References7
Patchstack
Patchstack
•added 2026/09/28 9:23 p.m.•17 views

NPM: fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority

NPM: fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority vulnerability discovered by ? in WordPress Npm fast-uri versions 2.4.5...

7.5CVSS7.3AI score0.0038EPSS
SaveExploits0References9Affected Software1
Github Security Blog
Github Security Blog
•added 2026/09/28 9:23 p.m.•39 views

fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority

Impact fast-uri accepts a host that contains an unbalanced or misplaced authority bracket or without reporting an error. A host that starts with but does not end with , such as @127.0.0.1, is neither validated as an IP literal nor canonicalized as a domain name, so parse returns it as the host wi...

7.5CVSS6.9AI score0.0038EPSS
SaveExploits0References9Affected Software1
osv_ghsa
osv_ghsa
•added 2026/09/28 9:23 p.m.•26 views

GHSA-58MR-GQGX-XQ4G fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority

Impact fast-uri accepts a host that contains an unbalanced or misplaced authority bracket or without reporting an error. A host that starts with but does not end with , such as @127.0.0.1, is neither validated as an IP literal nor canonicalized as a domain name, so parse returns it as the host wi...

7.5CVSS6.9AI score0.0038EPSS
SaveExploits0References9
RedHat Linux
RedHat Linux
•added 2026/09/22 8:32 a.m.•19 views

Important: Red Hat Security Advisory: OpenShift Container Platform 4.20.39 security and extras update

Red Hat OpenShift Container Platform release 4.20.39 is now available with updates to packages and images that fix several bugs. This release includes a security update for Red Hat OpenShift Container Platform 4.20. Red Hat Product Security has rated this update as having a security impact of...

7.5CVSS7.2AI score0.0038EPSS
SaveExploits0References3
RedHat Linux
RedHat Linux
•added 2026/09/08 5:58 p.m.•19 views

fast-uri: fast-uri: Host confusion via unbalanced URI brackets can bypass security policies

A flaw was found in fast-uri. The library incorrectly processes Uniform Resource Identifier URI hosts containing unbalanced brackets, leading to a discrepancy in how the host is parsed by fast-uri compared to other HTTP clients. This host confusion can allow an attacker to bypass security policie...

7.5CVSS7.1AI score0.0038EPSS
SaveExploits0References6
RedHat Linux
RedHat Linux
•added 2026/09/08 4:15 p.m.•20 views

fast-uri: fast-uri: Host confusion via unbalanced URI brackets can bypass security policies

A flaw was found in fast-uri. The library incorrectly processes Uniform Resource Identifier URI hosts containing unbalanced brackets, leading to a discrepancy in how the host is parsed by fast-uri compared to other HTTP clients. This host confusion can allow an attacker to bypass security policie...

7.5CVSS7.1AI score0.0038EPSS
SaveExploits0References6
osv_oesa
osv_oesa
•added 2026/09/05 3:02 p.m.•22 views

OESA-2026-3591 perl-URI security update

This module implements the URI class. Objects of this class represent "Uniform Resource Identifier references" as specified in RFC 2396 and updated by RFC 2732. Security Fixes: URI versions before 5.36 for Perl encode non-NFC host names to non-standard punycode labels via missing normalization in...

9.8CVSS5.9AI score0.00229EPSS
SaveExploits0References2
RedHat Linux
RedHat Linux
•added 2026/09/04 3:47 p.m.•23 views

fast-uri: fast-uri: Host confusion via unbalanced URI brackets can bypass security policies

A flaw was found in fast-uri. The library incorrectly processes Uniform Resource Identifier URI hosts containing unbalanced brackets, leading to a discrepancy in how the host is parsed by fast-uri compared to other HTTP clients. This host confusion can allow an attacker to bypass security policie...

7.5CVSS7.1AI score0.0038EPSS
SaveExploits0References6
Tenable Nessus
Tenable Nessus
•added 2026/09/03 12:00 a.m.•23 views

Linux Distros Unpatched Vulnerability : CVE-2026-84292

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - fast-uri serializes the port component of a URI without validating it. When recomposing the authority, the userinfo and host components are escaped but the port...

7.5CVSS7.2AI score0.00239EPSS
SaveExploits0References4
Snyk
Snyk
•added 2026/09/02 9:36 p.m.•27 views

Host Confusion

Overview fast-uri is a Dependency-free RFC 3986 URI toolbox Affected versions of this package are vulnerable to Host Confusion in the parse function, which returns a host that begins with but has no closing , such as @127.0.0.1, without validating it as an IPv6 literal or canonicalizing it as a...

8.7CVSS7.1AI score0.0038EPSS
SaveExploits0References2
Vulnrichment
Vulnrichment
•added 2026/09/02 8:25 p.m.•24 views

CVE-2026-84394 fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority

fast-uri accepts a host that contains an unbalanced or misplaced authority bracket without reporting an error. A host that starts with an opening bracket but does not end with a closing bracket is neither validated as an IP literal nor canonicalized as a domain name, so parse returns it as the ho...

7.5CVSS7.1AI score0.0038EPSS
SaveExploits0References2
CVE
CVE
•added 2026/09/02 8:25 p.m.•86 views

CVE-2026-84394

fast-uri (a URI parsing library used by the Fastify ecosystem) contains a host confusion vulnerability: when a URI's authority contains an opening bracket [ without a matching closing bracket ], parse() returns the string as the host without error. Neither an IP literal nor a valid domain name is...

7.5CVSS7.1AI score0.0038EPSS
SaveExploits0References2Affected Software1
Cvelist
Cvelist
•added 2026/09/02 8:25 p.m.•59 views

CVE-2026-84394 fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority

fast-uri accepts a host that contains an unbalanced or misplaced authority bracket without reporting an error. A host that starts with an opening bracket but does not end with a closing bracket is neither validated as an IP literal nor canonicalized as a domain name, so parse returns it as the ho...

7.5CVSS0.0038EPSS
SaveExploits0References2
osv_cve
osv_cve
•added 2026/09/02 8:25 p.m.•37 views

CVE-2026-84394 fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority

fast-uri accepts a host that contains an unbalanced or misplaced authority bracket without reporting an error. A host that starts with an opening bracket but does not end with a closing bracket is neither validated as an IP literal nor canonicalized as a domain name, so parse returns it as the ho...

7.5CVSS5.8AI score
SaveExploits0References4
EUVD
EUVD
•added 2026/09/02 3:44 p.m.•26 views

EUVD-2026-64758

fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references...

7.5CVSS7.4AI score0.00398EPSS
SaveExploits0References9
Rows per page
Query Builder