124 matches found
CVE-2025-14847
CVE-2025-14847 Description CVE-2025–14847, also known as MongoBleed, is a vulnerability that allows attackers to perform unauthorized data reads from the heap memory space of the server on which the MongoDB database runs, without authentication. How to Reproduce podman-compose vuln-machine/ up -d...
CVE-2026-116841
DevilutionX 1.4.0 through 1.5.5 contains an out-of-bounds read vulnerability in the bundled libmpq libmpqfilenumberfromhash function that allows attackers to read heap memory via unchecked blocktableindex values. Attackers can place a crafted .mpq archive in the game's data path, such as a mod, t...
PT-2026-125552
DevilutionX 1.4.0 through 1.5.5 contains an out-of-bounds read vulnerability in the bundled libmpq libmpq file number from hash function that allows attackers to read heap memory via unchecked block table index values. Attackers can place a crafted .mpq archive in the game's data path, such as a...
CVE-2026-43849
A heap memory read vulnerability could allow an attacker to exfiltrate sensitive data...
CVE-2026-43849
A heap memory read vulnerability could allow an attacker to exfiltrate sensitive data...
CVE-2026-43849
Technical details regarding the specific affected software, component, or version are not publicly available in the provided documents. The description only confirms a heap memory read vulnerability that could allow an attacker to exfiltrate sensitive data. Monitor for further updates.
CVE-2026-43849
A heap memory read vulnerability could allow an attacker to exfiltrate sensitive data...
EUVD-2026-104850
A heap memory read vulnerability could allow an attacker to exfiltrate sensitive data...
PT-2026-118285
A heap memory read vulnerability could allow an attacker to exfiltrate sensitive data...
EUVD-2026-102856
A flaw was found in spice-server. Multiple migration data handlers use client-supplied offsets from SPICEMSGCMIGRATEDATA messages without bounds validation, allowing a malicious authenticated SPICE client during VM live migration to read arbitrary heap memory or trigger heap corruption via...
CVE-2026-111155 libTiMidity through 0.2.8 Out-of-Bounds Read via SoundFont Loader sndfont.c
libTiMidity through 0.2.8 contains a heap out-of-bounds read vulnerability in the SoundFont loader in src/sndfont.c that uses unvalidated sampleId and instrument generator values as table indices. Attackers can supply a crafted .sf2 file loaded through midsetsoundfont to read heap memory out of...
Linux Distros Unpatched Vulnerability : CVE-2026-107611
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - An out-of-bounds read vulnerability in the ZRLE decoder of GlavSoft TightVNC Viewer for Windows before 2.8.88 allows a malicious or compromised VNC server to re...
EulerOS 2.0 SP13 : perl-XML-LibXML (EulerOS-SA-2026-4090)
According to the versions of the perl-XML-LibXML package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : XML::LibXML versions through 2.0210 for Perl read out-of-bounds heap memory when parsing XML node names containing truncated UTF-8 byte...
PT-2026-107952
Name of the Vulnerable Software and Affected Versions GlavSoft TightVNC Viewer for Windows versions prior to 2.8.88 Description An out-of-bounds read issue exists in the ZRLE decoder. A malicious or compromised VNC server can trigger this by sending ZRLE-encoded tiles with palette indices that...
CVE-2026-93524
A flaw was found in xorg-x11-server. An authenticated local user can trigger an out-of-bounds heap memory read by sending specially crafted X Keyboard Extension XKB requests with inconsistent key range parameters. This flaw leads to information disclosure, allowing the user to read sensitive data...
Rocky Linux 9.6 [TuxCare] Security Update: perl-XML-LibXML (ALMALINUX9.6:CLSA-2026:1784554254)
The Rocky Linux 9.6 host has a package installed that is affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1784554254 advisory. - XML::LibXML versions through 2.0210 for Perl read out-of-bounds heap memory when parsing XML node names containing truncated UTF-8 byte...
AlmaLinux 9.2 [TuxCare] Security Update: perl-XML-LibXML (ALMALINUX9.2:CLSA-2026:1784553427)
The AlmaLinux 9.2 host has a package installed that is affected by a vulnerability as referenced in the TuxCare ALMALINUX9.2:CLSA-2026:1784553427 advisory. - XML::LibXML versions through 2.0210 for Perl read out-of-bounds heap memory when parsing XML node names containing truncated UTF-8 byte...
AlmaLinux 9.6 [TuxCare] Security Update: perl-XML-LibXML (ALMALINUX9.6:CLSA-2026:1784554254)
The AlmaLinux 9.6 host has a package installed that is affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1784554254 advisory. - XML::LibXML versions through 2.0210 for Perl read out-of-bounds heap memory when parsing XML node names containing truncated UTF-8 byte...
PT-2026-99107
Name of the Vulnerable Software and Affected Versions pgPointcloud versions prior to 1.2.6 Description An issue exists in the dimensional patch WKB Well-Known Binary deserialization process. Authenticated database users can exploit this by providing crafted pcpatch values with manipulated size...
EUVD-2026-74791
zstd-jni versions before 1.5.7-14 fail to validate offset and length parameters in the ZstdDictCompress constructor, allowing out-of-bounds memory reads. Attackers can supply untrusted offset or length values to read native heap memory into the compression dictionary, typically causing JVM crashe...