382 matches found
CVE-2023-1712
Use of Hard-coded, Security-relevant Constants in GitHub repository deepset-ai/haystack prior to 0.1.30...
PT-2023-17189
Name of the Vulnerable Software and Affected Versions deepset-ai/haystack versions prior to 0.1.30 deepset-ai/haystack version 1.15.0 and prior Description The issue is related to the use of hard-coded, security-relevant constants in the GitHub repository deepset-ai/haystack. A patch is available...
CVE-2023-1712: Use of Hard-coded, Security-relevant Constants
Use of Hard-coded, Security-relevant Constants in GitHub repository deepset-ai/haystack prior to 0.1.30...
CVE-2023-1712
Use of Hard-coded, Security-relevant Constants in GitHub repository deepset-ai/haystack prior to 0.1.30...
CVE-2023-1712 Use of Hard-coded, Security-relevant Constants in deepset-ai/haystack
Use of Hard-coded, Security-relevant Constants in GitHub repository deepset-ai/haystack prior to 0.1.30...
CVE-2023-1712
CVE-2023-1712 concerns the GitHub repository deepset-ai/haystack, prior to version 0.1.30, due to the use of hard-coded, security-relevant constants. Public documentation from multiple sources confirms the issue affects haystack versions before 0.1.30 (and related references mention version 1.15....
CVE-2023-1712 Use of Hard-coded, Security-relevant Constants in deepset-ai/haystack
Use of Hard-coded, Security-relevant Constants in GitHub repository deepset-ai/haystack prior to 0.1.30...
CVE-2023-1712 Use of Hard-coded, Security-relevant Constants in deepset-ai/haystack
Use of Hard-coded, Security-relevant Constants in GitHub repository deepset-ai/haystack prior to 0.1.30...
Haystack security vulnerabilities
haystack is an open source NLP framework for interacting with your data using Transformer models and LLMs GPT-4, ChatGPT, etc.. A security vulnerability exists in haystack versions prior to 0.1.30 that stems from the use of hard-coded constants...
farm (>=0.4.5, <=0.6.1), farm-haystack (>=0.3.0, <=0.6.0) +2 more potentially affected by CVE-2023-1177 via mlflow (1.0.0)
mlflow PYPI version 1.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on mlflow and may be impacted: - farm =0.4.5, =0.3.0, =0.0.1a1.dev14, =0.0.1a1.dev15 - mlflow-faculty 0.3.1 Source cves: CVE-2023-1177 Source advisory: OSV:GHSA-XG73-94FP-G449...
farm (>=0.4.5, <=0.6.1), farm-haystack (>=0.3.0, <=0.6.0) +2 more potentially affected by CVE-2023-1176 via mlflow (1.0.0)
mlflow PYPI version 1.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on mlflow and may be impacted: - farm =0.4.5, =0.3.0, =0.0.1a1.dev14, =0.0.1a1.dev15 - mlflow-faculty 0.3.1 Source cves: CVE-2023-1176 Source advisory: OSV:PYSEC-2023-28...
farm (>=0.4.5, <=0.6.1), farm-haystack (>=0.3.0, <=0.6.0) +2 more potentially affected by CVE-2023-1177 via mlflow (1.0.0)
mlflow PYPI version 1.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on mlflow and may be impacted: - farm =0.4.5, =0.3.0, =0.0.1a1.dev14, =0.0.1a1.dev15 - mlflow-faculty 0.3.1 Source cves: CVE-2023-1177 Source advisory: OSV:PYSEC-2023-29...
biome-text (>=3.0.0, <=3.2.1), farm (>=0.6.2, <=0.8.0) +5 more potentially affected by CVE-2023-1177 via mlflow (1.13.1)
mlflow PYPI version 1.13.1 is affected by a known vulnerability. The following packages have a transitive dependency on mlflow and may be impacted: - biome-text =3.0.0, =0.6.2, =0.7.0, =0.0.1, =1.1.0, =1.0.0, =0.4.5.dev2, =0.6.5 Source cves: CVE-2023-1177 Source advisory: OSV:PYSEC-2023-29...
OnionSearch - A Script That Scrapes Urls On Different .Onion Search Engines
OnionSearch is a Python3 script that scrapes urls on different ".onion" search engines. Prerequisite Python 3 Currently supported Search engines ahmia darksearchio onionland notevil darksearchenginer phobos onionsearchserver torgle onionsearchengine tordex tor66 tormax haystack multivac evosear...
Haystack Arq for Mac Local Elevation of Privilege Vulnerability
Haystack Arq for Mac is a Mac-based file backup software from Haystack Software, USA. auto-updater binary is one of the auto-updater components. A security vulnerability exists in the arqupdater binary in Haystack Arq 5.10 and earlier versions for Mac. A local attacker can exploit the vulnerabili...
Haystack Arq for Mac Elevation of Privilege Vulnerability
Haystack Arq for Mac is a Mac-based file backup software from Haystack Software, USA. arqupdater and others are among the components. Based on the Mac platform Haystack Arq 5.10 and the previous version of the standardrestorer binary file there is a security vulnerability. A local attacker can...
Arq 5.9.6 - Local Privilege Escalation
Arq 5.9.6 - Local Privilege Escalation Arq Backup from Haystack Software is a great application for backing up macs and windows machines. Unfortunately versions of Arq for mac before 5.9.7 are vulnerable to a local root privilege escalation exploit. The updater binary has a "setpermissions"...
Arq 5.9.6 - Local root Privilege Escalation Exploit
Exploit for macOS platform in category local exploits Arq Backup from Haystack Software is a great application for backing up macs and windows machines. Unfortunately versions of Arq for mac before 5.9.7 are vulnerable to a local root privilege escalation exploit. The updater binary has a...
Haystack Arq for Mac helper app elevation of privilege vulnerability
Haystack Arq for Mac is a Mac-based file backup software from Haystack Software, USA. arqupdater and others are among the components. Mac-based Haystack Software Arq 5.10 before the 5.x version of several helper app has a security vulnerability. A local attacker can exploit the vulnerability to...
Arq Backup 5.9.6 Local Root Privilege Escalation
Arq Backup from Haystack Software is a great application for backing up macs and windows machines. Unfortunately versions of Arq for mac before 5.9.7 are vulnerable to a local root privilege escalation exploit. The updater binary has a "setpermissions" function which sets the suid bit and root...