151 matches found
Fedora: Security Advisory for httpie (FEDORA-2022-cfcad08594)
The remote host is missing an update for the Copyright C 2022 Greenbone Networks GmbH Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-or-later This program is free software; you can...
Fedora: Security Advisory for httpie (FEDORA-2022-fbf40ae0e4)
The remote host is missing an update for the Copyright C 2022 Greenbone Networks GmbH Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-or-later This program is free software; you can...
[SECURITY] Fedora 34 Update: httpie-3.1.0-1.fc34
HTTPie is a CLI HTTP utility built out of frustration with existing tools. The goal is to make CLI interaction with HTTP-based services as human-friendly as possible. HTTPie does so by providing an http command that allows for issuing arbitrary HTTP requests using a simple and natural syntax and...
Information Disclosure
httpie is vulnerable to information disclosure. The vulnerability exists due to a lack of sanitization of cookies in persistent session allowing the cookies to be visible to all sites in that session...
GHSA-6PC9-XQRG-WFQW Exposure of Sensitive information in httpie
httpie is a modern, user-friendly command-line HTTP client for the API era. Prior to version 3.1.0, all cookies saved to session storage are supercookies. At this time, there is no known workaround. Users are recommended to update to version 3.1.0...
dalineunit (>=0.0.31, <=0.0.69) potentially affected by CVE-2022-0430 via httpie (2.0.0)
httpie PYPI version 2.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on httpie and may be impacted: - dalineunit =0.0.31, =0.0.69 Source cves: CVE-2022-0430 Source advisory: OSV:GHSA-6PC9-XQRG-WFQW...
encapsia-cli (>=0.1.8, <=0.2.1), httpie-credential-store (1.0.0) +1 more potentially affected by CVE-2022-0430 via httpie (1.0.3)
httpie PYPI version 1.0.3 is affected by a known vulnerability. The following packages have a transitive dependency on httpie and may be impacted: - encapsia-cli =0.1.8, =0.2.1 - httpie-credential-store 1.0.0 - veracode-api-signing 21.3.0 Source cves: CVE-2022-0430 Source advisory:...
navigator-api (>=1.3.21, <=1.9.24) potentially affected by CVE-2022-0430 via httpie (2.3.0)
httpie PYPI version 2.3.0 is affected by a known vulnerability. The following packages have a transitive dependency on httpie and may be impacted: - navigator-api =1.3.21, =1.9.24 Source cves: CVE-2022-0430 Source advisory: OSV:GHSA-6PC9-XQRG-WFQW...
Exposure of Sensitive information in httpie
httpie is a modern, user-friendly command-line HTTP client for the API era. Prior to version 3.1.0, all cookies saved to session storage are supercookies. At this time, there is no known workaround. Users are recommended to update to version 3.1.0...
encapsia-cli (>=0.2.2, <=0.5.1), httpie-astra (>=0.0.14, <=0.1.0) +2 more potentially affected by CVE-2022-0430 via httpie (2.6.0)
httpie PYPI version 2.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on httpie and may be impacted: - encapsia-cli =0.2.2, =0.0.14, =0.1.0 - httpie-credential-store 2.0.0 - httpie-nifcloud-authv4 0.1.0 Source cves: CVE-2022-0430 Source advisory:...
CVE-2022-0430
Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository httpie/httpie prior to 3.1.0...
DEBIAN-CVE-2022-0430
Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository httpie/httpie prior to 3.1.0...
CVE-2022-0430
Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository httpie/httpie prior to 3.1.0...
UBUNTU-CVE-2022-0430
Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository httpie/httpie prior to 3.1.0...
PYSEC-2022-167
Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository httpie/httpie prior to 3.1.0...
encapsia-cli (>=0.1.8, <=0.2.1), httpie-credential-store (1.0.0) +1 more potentially affected by CVE-2022-0430 via httpie (1.0.3)
httpie PYPI version 1.0.3 is affected by a known vulnerability. The following packages have a transitive dependency on httpie and may be impacted: - encapsia-cli =0.1.8, =0.2.1 - httpie-credential-store 1.0.0 - veracode-api-signing 21.3.0 Source cves: CVE-2022-0430 Source advisory:...
navigator-api (>=1.3.21, <=1.9.24) potentially affected by CVE-2022-0430 via httpie (2.3.0)
httpie PYPI version 2.3.0 is affected by a known vulnerability. The following packages have a transitive dependency on httpie and may be impacted: - navigator-api =1.3.21, =1.9.24 Source cves: CVE-2022-0430 Source advisory: OSV:PYSEC-2022-167...
encapsia-cli (>=0.2.2, <=0.5.1), httpie-astra (>=0.0.14, <=0.1.0) +2 more potentially affected by CVE-2022-0430 via httpie (2.6.0)
httpie PYPI version 2.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on httpie and may be impacted: - encapsia-cli =0.2.2, =0.0.14, =0.1.0 - httpie-credential-store 2.0.0 - httpie-nifcloud-authv4 0.1.0 Source cves: CVE-2022-0430 Source advisory:...
dalineunit (>=0.0.31, <=0.0.69) potentially affected by CVE-2022-0430 via httpie (2.0.0)
httpie PYPI version 2.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on httpie and may be impacted: - dalineunit =0.0.31, =0.0.69 Source cves: CVE-2022-0430 Source advisory: OSV:PYSEC-2022-167...