594 matches found
HTTP3-Adapter
HTTP/3-Adapter A Burp Suite extension that sends requests over HTTP/3. Burp does not support HTTP/3 natively. This extension implements a HTTP/3 stack, intercepts all requests, converts and sends them over HTTP/3 and then converts the response back into a HTTP version that burp can understand...
CVE-2026-42530
CVE-2026-42530 Scanner for CVE-2026-42530, a use-after-free in nginx's HTTP/3 module. Affected: nginx 1.31.0, 1.31.1 Fixed: nginx 1.31.2 Usage pip install aioquic python3 scannerCVE-2026-42530.py port python3 scannerCVE-2026-42530.py --file hosts.txt How it works Opens two QPACK encoder streams o...
ssh3
!NOTE SSH3 is probably going to change its name. It is still the SSH Connection Protocol RFC4254 running on top of HTTP/3 Extended connect, but the required changes are heavy and too distant from the philosophy of popular SSH implementations to be considered for integration. The specification dra...
CVE-2026-33555
HTTP Request Smuggling via HAProxy H3/QUIC Standalone FIN Body Validation Bypass Full post here : https://r3verii.github.io/cve/2026/04/14/haproxy-h3-standalone-fin-smuggling.html Summary A vulnerability in HAProxy's HTTP/3 implementation allows an attacker to send an HTTP request with a...
HTTP3ONSTEROIDS
Table of contents Vulnerability Description Source Code Review Lab Setup Identifying the issue References Vulnerability Description HAProxy's HTTP/3 implementation fails to block a malformed HTTP header field name , and when deployed in front of a server that incorrectly process this malformed...
CVE-2026-97200
Allocation of Resources Without Limits or Throttling vulnerability in hackneyconn in benoitc hackney allows a malicious HTTP server to exhaust client memory via an oversized or highly compressed response body. hackney:request/5 and hackney:body/1 return the whole response body, and nothing bounds...
CVE-2026-97200
The benoitc hackney library (versions 2.0.0-beta.1 to 4.8.4 ) is vulnerable to an Allocation of Resources Without Limits or Throttling (CWE-409, CWE-770) flaw in the hackney_conn component. The issue stems from unbounded accumulation in hackney_conn:read_full_body/2 and the HTTP/2 and HTTP/3 accu...
CVE-2026-97200 Unbounded response body buffering and decompression in hackney
Allocation of Resources Without Limits or Throttling vulnerability in hackneyconn in benoitc hackney allows a malicious HTTP server to exhaust client memory via an oversized or highly compressed response body. hackney:request/5 and hackney:body/1 return the whole response body, and nothing bounds...
EUVD-2026-109837
Allocation of Resources Without Limits or Throttling vulnerability in hackneyconn in benoitc hackney allows a malicious HTTP server to exhaust client memory via an oversized or highly compressed response body. hackney:request/5 and hackney:body/1 return the whole response body, and nothing bounds...
HTTP3-attacks
HTTP3-attacks CVE-2022-30592 Based on the work: E. Chatzoglou, V. Kouliaridis, G. Kambourakis, G. Karopoulos, and S. Gritzalis,"A hands-on gaze on HTTP/3 security through the lens of HTTP/2 and a public dataset", Computers & Security, p. 103051, 2022. The current repository serves the purpose of...
TornadoC2
TornadoC2 A pull-based C2 with ten native transports, concurrent multi-profile handlers, and an honest threat model. The agent is a single Go binary with every behavioural property baked in at build time — no runtime config file, no environment variable, no command-line arguments. Tasks and resul...
CVE-2026-4253-Scanner
CVE-2026-42530 — Safe-Check Scanner Non-destructive mass scanner for the NGINX HTTP/3 QUIC use-after-free Inventory which of your hosts are exposed — without ever triggering the bug. ⚠️ Disclaimer This tool is for authorized security testing only — your own infrastructure, or systems you have...
CVE-2026-42530
🛡️ CVE-2026-42530 - NGINX HTTP/3 QUIC Use-After-Free Vulnerability High-Severity Use-After-Free in NGINX HTTP/3 QUIC ⚠️ QPACK Encoder Stream Vulnerability 🔍 Overview CVE-2026-42530 is a use-after-free vulnerability in NGINX's ngxhttpv3module. A remote unauthenticated attacker can trigger it by...
CVE-2026-115482
In lsquic before 4.9.0, the HTTP/3 implementation can use an excessive amount of memory because the number of buffered header sets is not limited, as demonstrated by a QPACK amplification attack. This is related to headeroutdynamicentry and esmaxheaderlistsize...
CVE-2026-115482
The lsquic library (versions before 4.9.0 ) is vulnerable to a memory exhaustion issue within its HTTP/3 implementation. The root cause is an unlimited number of buffered header sets , which can be exploited via a QPACK amplification attack . This vulnerability is specifically related to header_o...
CVE-2026-115482
In lsquic before 4.9.0, the HTTP/3 implementation can use an excessive amount of memory because the number of buffered header sets is not limited, as demonstrated by a QPACK amplification attack. This is related to headeroutdynamicentry and esmaxheaderlistsize...
EUVD-2026-108211
In lsquic before 4.9.0, the HTTP/3 implementation can use an excessive amount of memory because the number of buffered header sets is not limited, as demonstrated by a QPACK amplification attack. This is related to headeroutdynamicentry and esmaxheaderlistsize...
CVE-2026-115482
In lsquic before 4.9.0, the HTTP/3 implementation can use an excessive amount of memory because the number of buffered header sets is not limited, as demonstrated by a QPACK amplification attack. This is related to headeroutdynamicentry and esmaxheaderlistsize...
CLEANSTART-2026-JT86822 In Eclipse Jetty, for HTTP/1, HTTP/2 and HTTP/3 requests, there is no strict check that the request authority (host and port) matches what provided in the Host header (if present)
CVE-2026-6790 affects multiple packages. In Eclipse Jetty, for HTTP/1, HTTP/2 and HTTP/3 requests, there is no strict check that the request authority host and port matches what provided in the Host header if present. See references for individual vulnerability details...
Debian dsa-6575 : libnginx-mod-http-geoip - security update
The remote Debian 13 host has packages installed that are affected by multiple vulnerabilities as referenced in the dsa-6575 advisory. - ------------------------------------------------------------------------- Debian Security Advisory DSA-6575-1 [email protected] https://www.debian.org/securit...