14773 matches found
CVE-2020-8492
Python 2.7 through 2.7.17, 3.5 through 3.5.9, 3.6 through 3.6.10, 3.7 through 3.7.6, and 3.8 through 3.8.1 allows an HTTP server to conduct Regular Expression Denial of Service ReDoS attacks against a client because of urllib.request.AbstractBasicAuthHandler catastrophic backtracking...
Security Bulletin: Multiple vulnerabilities in IBM HTTP Server used by WebSphere Application Server shipped with IBM Tivoli Netcool Performance Manager for Wireline
Summary Apache HTTP Server vulnerability has been identified in WebSphere Application Server. WebSphere Application Server is shipped with Tivoli Netcool Performance Manager. Information about a security vulnerability affecting WebSphere Application Server has been published in a security bulleti...
[SECURITY] Fedora 31 Update: php-7.3.15-1.fc31
PHP is an HTML-embedded scripting language. PHP attempts to make it easy for developers to write dynamically generated web pages. PHP also offers built-in database integration for several commercial and non-commercial database management systems, so writing a database-enabled webpage with PHP is...
[SECURITY] Fedora 30 Update: php-7.3.15-1.fc30
PHP is an HTML-embedded scripting language. PHP attempts to make it easy for developers to write dynamically generated web pages. PHP also offers built-in database integration for several commercial and non-commercial database management systems, so writing a database-enabled webpage with PHP is...
Security Bulletin: IBM Security SiteProtector System is affected by Apache HTTP Server vulnerabilities
Summary IBM Security SiteProtector System has addressed the following vulnerabilities in Apache HTTP Server. Vulnerability Details CVEID: CVE-2019-10092 DESCRIPTION: In Apache HTTP Server 2.4.0-2.4.39, a limited cross-site scripting issue was reported affecting the modproxy error page. An attacke...
Security Bulletin: IBM Security SiteProtector System is affected by Apache HTTP Server vulnerabilities
Summary IBM Security SiteProtector System has addressed the following vulnerabilities in Apache HTTP Server. Vulnerability Details CVEID: CVE-2018-20843 DESCRIPTION: libexpat is vulnerable to a denial of service, caused by an error in the XML parser. By persuading a victim to open a...
DoS Via Malformed URL with Reactor Netty HTTP Server
Reactor Netty HttpServer, versions 0.9.3 and 0.9.4, is exposed to a URISyntaxException that causes the connection to be closed prematurely instead of producing a 400 response...
ABB IDAL HTTP Server Stack Buffer Overflow (CVE-2019-7232)
A stack buffer overflow vulnerability exists in ABB IDAL HTTP Server. A remote unauthenticated attacker could exploit this vulnerability by sending a crafted request to the vulnerable server. Successful exploitation of this vulnerability could allow a remote attacker to execute arbitrary code on...
EulerOS 2.0 SP8 : httpd (EulerOS-SA-2020-1155)
According to the versions of the httpd packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : - In Apache HTTP Server 2.4.32-2.4.39, when modremoteip was configured to use a trusted intermediary proxy server using the 'PROXY' protocol, a...
Huawei EulerOS: Security Advisory for httpd (EulerOS-SA-2020-1155)
The remote host is missing an update for the Huawei EulerOS SPDX-FileCopyrightText: 2020 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
PT-2020-3261
Name of the Vulnerable Software and Affected Versions Apache HTTP Server versions 2.4.0 through 2.4.41 Description The issue is related to the mod rewrite function in the Apache HTTP Server, where redirects intended to be self-referential can be fooled by encoded newlines, causing them to redirec...
com.barchart.http:barchart-http-handlers (>=1.0.6, <=1.0.7), com.barchart.http:barchart-http-server (>=1.0.6, <=1.0.7) potentially affected by CVE-2019-20444 via io.netty:netty (4.0.0.alpha6)
io.netty:netty MAVEN version 4.0.0.alpha6 is affected by a known vulnerability. The following packages have a transitive dependency on io.netty:netty and may be impacted: - com.barchart.http:barchart-http-handlers =1.0.6, =1.0.6, =1.0.7 Source cves: CVE-2019-20444 Source advisory:...
com.barchart.http:barchart-http-handlers (>=1.0.6, <=1.0.7), com.barchart.http:barchart-http-server (>=1.0.6, <=1.0.7) +14 more potentially affected by CVE-2019-20445 via io.netty:netty (>=4.0.0.alpha1, <=4.0.0.alpha8)
io.netty:netty MAVEN version =4.0.0.alpha1, =1.0.6, =1.0.6, =0.3, =0.3, =0.2, =1.3.0, =1.0.0.alpha1, =1.0.0.alpha2 and more Source cves: CVE-2019-20445 Source advisory: GHSA-P2V9-G2QV-P635...
com.barchart.http:barchart-http-handlers (>=1.0.6, <=1.0.7), com.barchart.http:barchart-http-server (>=1.0.6, <=1.0.7) potentially affected by CVE-2019-20445 via io.netty:netty (4.0.0.alpha6)
io.netty:netty MAVEN version 4.0.0.alpha6 is affected by a known vulnerability. The following packages have a transitive dependency on io.netty:netty and may be impacted: - com.barchart.http:barchart-http-handlers =1.0.6, =1.0.6, =1.0.7 Source cves: CVE-2019-20445 Source advisory:...
Debian DLA-2109-1 : netty security update
Several vulnerabilities were discovered in the HTTP server provided by Netty, a Java NIO client/server socket framework : CVE-2019-20444 HttpObjectDecoder.java allows an HTTP header that lacks a colon, which might be interpreted as a separate header with an incorrect syntax, or might be interpret...
Debian: Security Advisory (DLA-2109-1)
The remote host is missing an update for the Debian SPDX-FileCopyrightText: 2020 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
[SECURITY] [DLA 2109-1] netty security update
Package : netty Version : 1:3.2.6.Final-2+deb8u2 CVE ID : CVE-2019-20444 CVE-2019-20445 CVE-2020-7238 Debian Bug : 950966 950967 Several vulnerabilities were discovered in the HTTP server provided by Netty, a Java NIO client/server socket framework: CVE-2019-20444 HttpObjectDecoder.java allows an...
CoTURN HTTP Server POST-parsing denial-of-service vulnerability
Summary An exploitable denial-of-service vulnerability exists in the way CoTURN 4.5.1.1 web server parses POST requests. A specially crafted HTTP POST request can lead to server crash and denial of service. An attacker needs to send an HTTP request to trigger this vulnerability. Tested Versions...
Easy File Sharing Web Server 7.2 Buffer Overflow
!/usr/bin/python Exploit Title: Easy File Sharing Web Server v7.2 - POST 'Email' Unauthenticated Remote Buffer Overflow Exploit Author: boku aka Bobby Cooke Date: February 7th, 2020 Vendor Homepage: http://www.sharing-file.com/ Software Link: http://www.sharing-file.com/efssetup.exe Version: 7.2...
Security Bulletin: A security vulnerability has been identified in multiple products that ship with IBM Predictive Customer Intelligence (CVE-2014-3566)
Summary IBM Cognos Business Intelligence, IBM Infosphere Integration Bus, IBM WebSphere MQ, IBM DB2 Enterprise Server, IBM HTTP Server and IBM SPSS Modeler are shipped as components of IBM Predictive Customer Intelligence. Information about security vulnerabilities affecting IBM Cognos Business...