7082 matches found
yellow
| | | | | | |/ \ | |/ \ \ /\ / / | || | / | | \ V V / , ||||/ // |/ - Just add blue. yellow - just add blue Simple binary modifications that will trigger a canarytoken when a binary is executed. Ideal for boobytrapping production systems against attackers. Currently there are four methods:...
looney-tunables-CVE-2023-4911
PoC of CVE-2023-4911 Looney Tunables This is a PoC of CVE-2023-4911 a.k.a. "Looney Tunables" exploiting a bug in glibc dynamic loader's GLIBCTUNABLES environment variable parsing function parsetunables. Getting Started Executing program We can check if target is vulnerable env -i...
pkwned
pkwned: Proof of Concept for CVE-2021-4034 This PoC will run PAYLOADPATH as defined in constants.h with root privileges from a vulnerable version of pkexec running on glibc. The directory "GCONVPATH=." needs to contain an executable file named after the directory containing the gconv module. As...
CVE-2015-7547
CVE-2015-7547 glibc getaddrinfo stack-based buffer overflow...
CVE-2023-4911
CVE-2023-4911 This is a PoC for CVE-2023-4911 "Looney Tunables" that exploits a bug in the glibc dynamic loader's GLIBCTUNABLES environment variable parsing function parsetunables. This is a rewrite of the C PoC's into a pure python approach. I did this to make it easier to customize the exploit...
CVE-2015-0235-workaround
CVE-2015-0235-workaround aka GHOST glibc vulnerability A shared library wrapper with additional checks for the vulnerable functions gethostbyname2r and gethostbynamer . The proper solution for CVE-2015-0235 is to upgrade glibc to at least glibc-2.18. In some cases, an immediate glibc upgrade is n...
CVE-2024-2961
CVE-2024-2961 CVE-2024–2961 Security Issue Mitigation Script Description This repository contains a Bash script to check and mitigate the buffer overflow vulnerability identified in GNU libc glibc versions 2.39 and older, known as CVE-2024-2961. This vulnerability affects PHP when the iconv...
CVE-2023-4911
PoC of CVE-2023-4911 "Looney Tunables" This is a PoC of CVE-2023-4911 a.k.a. "Looney Tunables" exploiting a bug in glibc dynamic loader's GLIBCTUNABLES environment variable parsing function parsetunables. Code has been tested on Ubuntu 22.04.3 with glibc version 2.35-0ubuntu3.3. No attempts have...
CVE-2024-6387
0. TL;DR This is essentially a statistical vulnerability: it requires a large number of attempts to win the race condition and successfully execute arbitrary code. Attackers need to overcome many obstacles, "Schwartz told SecurityWeek." Even in the best case, the most well-known vulnerabilities...
CVE-2023-4911
CVE-2023-4911 This is a PoC Proof Of Concept for the Looney Tunables Linux Privilege Escalation vulnerability. This is based on this PoC. Great thanks to leesh3288. Here you can find a very detailed writeup, and here you can see a very cool video by IppSec. Usage Check if it's vulnerable env -i...
CVE-2024-6387_poc
CVE-2024-6387 Proof of Concept PoC Description This repository contains a PoC for vulnerability CVE-2024-6387, which targets a signal handler race condition in the OpenSSH server sshd on glibc-based Linux systems. The vulnerability allows remote code execution as root by calling...
CVE-2015-7547-Research
Initial work on glibc exploit CVE-2015-7547. Currently just returns to libc and calls system to provide a shell. This version does not account for ASLR yet...
tools-for-CVE-2018-1000001
Tools for CVE-2018-1000001 Check vulnerability: $ cat /proc/sys/kernel/unprivilegedusernsclone Output: 1 If file "/proc/sys/kernel/unprivilegedusernsclone" does not exists: $ unshare -mU /bin/sh -c "sleep 5" & /bin/sh -c "sleep 1; cd /proc/$!/cwd; realpath .; kill -9 $!" The output must contain t...
CVE-2024-6387
CVE-2024-6387 This is an altered PoC for d0rb/CVE-2024-6387. This takes glibc addresses and trys to exploit the CVE through them...
cve-2024-6387_AImade
Presentation of the Test Code for CVE-2024-6387 Introduction This document presents a Python script designed to test the vulnerability CVE-2024-6387, identified in OpenSSH. This vulnerability is a race condition in the SIGALRM signal handler that can allow remote code execution RCE on glibc-based...
test_iconv
Testing CVE-2024-2961 V1 - Under Analysis This repository contains a C program to test for CVE-2024-2961, which involves a buffer overflow vulnerability in the iconv function of the GNU C Library glibc. Due to the structure of PHP’s heap, this overflow can be exploited to modify part of a free li...
cve-2023-4911-exploit-optimized
Security Notice : This repository contains working exploit code for educational and research purposes. Use responsibly and only on systems you own or have explicit permission to test. CVE-2023-4911 Exploit Looney Tunables Optimized, multi-processing exploits for CVE-2023-4911 targeting x8664 and...
ssh_poc2024
cve-2024-6387-poc a signal handler race condition in OpenSSH's server sshd 7etsuo Description An exploit for CVE-2024-6387, targeting a signal handler race condition in OpenSSH's server sshd on glibc-based Linux systems. The vulnerability allows for remote code execution as root due to...
CVE-2025-4802-Proof-of-Concept
CVE-2025-4802 — Proof of Concept ⚠️ Disclaimer: This repository is for educational and authorized security research purposes only. Do not use this exploit against systems you do not own or have explicit permission to test. Misuse may violate laws and regulations. CVE Summary Field| Details ---|---...
exploit_cve-2023-26326_using_cve-2024-2961
Exploit BuddyForms CVE-2023-26326 using Iconv CVE-2024-2961 This work was done by me, Omar Elshopky, and Nour El Dien Bassiouny. This repository contains an exploit for the WordPress BuddyForms Plugin CVE-2023-26326, initially reported in the advisory by Joshua Martinelle. The exploit leverages a...