2718 matches found
elemeno-ai-sdk (>=0.0.5, <=0.0.20), foresthog (>=0.9.0, <=1.3.6) +7 more potentially affected by CVE-2026-44243 via gitpython (2.1.1)
gitpython PYPI version 2.1.1 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - elemeno-ai-sdk =0.0.5, =0.9.0, =0.1.0, =0.4.0, =0.0.5, =0.0.1, =1.0.0, =1.0.4, =1.0.10 Source cves: CVE-2026-44243 Source advisory:...
git-semver (>=0.1.2, <=0.1.5) potentially affected by CVE-2026-44243 via gitpython (2.0.9)
gitpython PYPI version 2.0.9 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - git-semver =0.1.2, =0.1.5 Source cves: CVE-2026-44243 Source advisory: OSV:GHSA-7545-FCXQ-7J24...
arca (>=0.1.1, <=0.3.1), epab (>=2018.4.2.1, <=2018.4.2.3) +3 more potentially affected by CVE-2026-44243 via gitpython (2.1.9)
gitpython PYPI version 2.1.9 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - arca =0.1.1, =2018.4.2.1, =1.0.3, =0.0.0, =0.4.1 - ubuntudesign-documentation-builder 1.6.0 Source cves: CVE-2026-44243 Source advisory:...
aws-client (>=0.10.0, <=0.11.0), git-repo (>=1.7.0, <=1.7.1) potentially affected by CVE-2026-44243 via gitpython (2.0.6)
gitpython PYPI version 2.0.6 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - aws-client =0.10.0, =1.7.0, =1.7.1 Source cves: CVE-2026-44243 Source advisory: OSV:GHSA-7545-FCXQ-7J24...
GitPython reference APIs has a path traversal vulnerability that allows arbitrary file write and delete outside the repository
🧾 Summary A vulnerability in GitPython allows attackers who can supply a crafted reference path to an application using GitPython to write, overwrite, move, or delete files outside the repository’s .git directory via insufficient validation of reference paths in reference creation, rename, and...
GHSA-7545-FCXQ-7J24 GitPython reference APIs has a path traversal vulnerability that allows arbitrary file write and delete outside the repository
🧾 Summary A vulnerability in GitPython allows attackers who can supply a crafted reference path to an application using GitPython to write, overwrite, move, or delete files outside the repository’s .git directory via insufficient validation of reference paths in reference creation, rename, and...
PT-2026-38294
Name of the Vulnerable Software and Affected Versions GitPython versions prior to 3.1.48 Description Insufficient validation of reference paths in reference creation, rename, and delete operations allows attackers to write, overwrite, move, or delete files outside the repository's .git directory...
PT-2026-38295
Name of the Vulnerable Software and Affected Versions GitPython versions prior to 3.1.49 Description The set value function in GitConfigParser passes values to Python's configparser without validating for newlines. Although the write function converts embedded newlines into indented continuation...
[SECURITY] Fedora 43 Update: GitPython-3.1.49-1.fc43
GitPython is a python library used to interact with git repositories, high-level like git-porcelain, or low-level like git-plumbing. It provides abstractions of git objects for easy access of repository data, a nd additionally allows you to access the git repository more directly using eith er a...
Fedora 43 : GitPython (2026-fdbf3705cc)
The remote Fedora 43 host has a package installed that is affected by a vulnerability as referenced in the FEDORA-2026-fdbf3705cc advisory. Fixes security defects GHSA-rpm5-65cw-6hj4, GHSA-x2qx-6953-8485, GHSA-7545-fcxq-7j24, and GHSA-v87r-6q3f-2j67. Tenable has extracted the preceding descriptio...
Fedora 44 : GitPython (2026-9342da13e0)
The remote Fedora 44 host has a package installed that is affected by a vulnerability as referenced in the FEDORA-2026-9342da13e0 advisory. Fixes security defects GHSA-rpm5-65cw-6hj4, GHSA-x2qx-6953-8485, GHSA-7545-fcxq-7j24, and GHSA-v87r-6q3f-2j67. Tenable has extracted the preceding descriptio...
GitPython has Command Injection via Git options bypass
Summary GitPython blocks dangerous Git options such as --upload-pack and --receive-pack by default, but the equivalent Python kwargs uploadpack and receivepack bypass that check. If an application passes attacker-controlled kwargs into Repo.clonefrom, Remote.fetch, Remote.pull, or Remote.push, th...
GHSA-RPM5-65CW-6HJ4 GitPython has Command Injection via Git options bypass
Summary GitPython blocks dangerous Git options such as --upload-pack and --receive-pack by default, but the equivalent Python kwargs uploadpack and receivepack bypass that check. If an application passes attacker-controlled kwargs into Repo.clonefrom, Remote.fetch, Remote.pull, or Remote.push, th...
Command Injection
Overview GitPython is a python library used to interact with Git repositories Affected versions of this package are vulnerable to Command Injection via the uploadpack or receivepack kwargs in the Repo.clonefrom, Remote.fetch, Remote.pull, or Remote.push functions. An attacker can execute arbitrar...
ac-solver (0.1.0), acedeploy (>=2.4.15, <=2.4.366.dev1) +492 more potentially affected by CVE-2026-42215 via gitpython (>=3.1.30, <=3.1.46)
gitpython PYPI version =3.1.30, =2.4.15, =2025.10.17, =0.4.0, =0.4.0, =1.2.3, =0.4.7, =0.4.7, =0.2.0, =0.87.2.dev9, =0.5.0, =0.1.0.dev19, =1.3.0, =2.0.3 - aider-omni 0.86.2.dev20 and more Source cves: CVE-2026-42215 Source advisory: SNYK:PYTHON-GITPYTHON-16298057...
ac-solver (0.1.0), acedeploy (>=2.4.15, <=2.4.366.dev1) +492 more potentially affected by CVE-2026-42215 via gitpython (>=3.1.30, <=3.1.46)
gitpython PYPI version =3.1.30, =2.4.15, =2025.10.17, =0.4.0, =0.4.0, =1.2.3, =0.4.7, =0.4.7, =0.2.0, =0.87.2.dev9, =0.5.0, =0.1.0.dev19, =1.3.0, =2.0.3 - aider-omni 0.86.2.dev20 and more Source cves: CVE-2026-42215 Source advisory: GHSA-RPM5-65CW-6HJ4...
ac-solver (0.1.0), acedeploy (>=2.4.15, <=2.4.366.dev1) +492 more potentially affected by CVE-2026-42215 via gitpython (>=3.1.30, <=3.1.46)
gitpython PYPI version =3.1.30, =2.4.15, =2025.10.17, =0.4.0, =0.4.0, =1.2.3, =0.4.7, =0.4.7, =0.2.0, =0.87.2.dev9, =0.5.0, =0.1.0.dev19, =1.3.0, =2.0.3 - aider-omni 0.86.2.dev20 and more Source cves: CVE-2026-42215 Source advisory: OSV:GHSA-RPM5-65CW-6HJ4...
android-category (>=0.0.3, <=0.0.4), ant-cli (0.0.1) +34 more potentially affected by CVE-2026-42284 via gitpython (2.1.11)
gitpython PYPI version 2.1.11 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - android-category =0.0.3, =0.0.2, =0.3.0, =0.0.2, =0.12.4rc1, =0.1.26.dev1542857464, =0.2.3, =0.1.0, =0.0.1, =1.2.5, =0.1.0.0b1, =0.1.3 and mo...
bentodev (>=0.1.17, <=2018.11.2), confsave (>=0.1.0, <=0.3.0) +3 more potentially affected by CVE-2026-42284 via gitpython (2.1.3)
gitpython PYPI version 2.1.3 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - bentodev =0.1.17, =0.1.0, =0.9.0, =0.53.0 - reckoner 1.1.1 Source cves: CVE-2026-42284 Source advisory: OSV:GHSA-X2QX-6953-8485...
elib (>=0.1.55, <=0.1.57), emiz (>=0.1.35, <=2018.4.2.1) +11 more potentially affected by CVE-2026-42284 via gitpython (2.1.8)
gitpython PYPI version 2.1.8 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - elib =0.1.55, =0.1.35, =0.2.4a149, =0.0.1, =1.0.0, =0.4233.0, =0.2354.0, =0.2354.0, =0.1.7, =0.2.120, =1.0.0, =0.1.0, =2.1.1 Source cves:...